A Few Recent Issues I've Had With Thralls

I decided to test out the Blade of Seven Winds in a thralls hands. Initially I was surprised and happy to see that my thrall can and will use the heavy, charge attack. However, I soon encountered issues with the thrall. She wouldn’t move to areas where I commanded her to. She also would just stand looking at the Rot Branch boss without attacking while getting attacked and taking damage. This issue was while she was not in the charge pose too. And finally, when I went to take the Blade of Seven Winds from her inventory, she wouldn’t let go of it. It stayed equipped in her hand with no way for me to put it into her or my inventory.

Another issue I had with a thrall happened yesterday morning. I was getting Sadeh the Lithe experience in the Unnamed City. Everything was going smoothly. She did the Guardian fight fairly smoothly even though at one point she kicked 8 times in a row. I equipped her with Hanuman’s Gada. After that fight she bugged out to where she would raise her fists and just stare at the skeletons instead of attacking. At this point I tried equipping her with the Festering One axe. It didn’t change things. She was still just a useless spectator getting in the way of my character fighting. I do not know what happened that made her go from functioning somewhat properly (except for the 8 kicks in a row) to being useless.

I have also had to micro manage my thralls path finding in several locations across the Exiled Lands. This is not a fun or exciting thing to do.

I play SP, Exiled Lands with no mods.


Interesting points.

Had similar experiences yesterday, especially with some bearer i got for tests (out of cage thralls). They was all T3. They came with iron, or basic steel weapons, but like i’m used, i change them for better, but still in the same style they come with. Mostly had the best experience doing so. Changing them completely was never working perfectly.
Still, changed for a hardened steel axt for one, and a sword we looted for the other. First attack went very well. Second less, like you described, one went to the fist-fight stance pose, and just looked at the ennemis. Making run her away, take her weapon and give her back made her fight again.

1 Like

I’m curious if you guys have had this issue. I carry a truncheon on my thralls that I swap to if I spot a named I want to knock out. I’m having an issue that I did not have before 2.4 where if I try to swap the weapons in combat it gives me ‘that item cannot be moved’ message and then doesn’t swap the weapon out. Sometimes it won’t even let me simply take off the weapon they’re using. I think it’s happening as they’re fighting with it. I’ve killed a couple thralls that I wanted to break because it simply wouldn’t let me swap weapons mid fight.

1 Like

I have had this happen once. It happened when I tried the swap as my thrall was moving towards the enemy. I think in my case it was a range issue. That the thrall had moved too far away from me by the time I tried to make the swap.

Thanks, I’ll keep that in mind. It usually happens to me during hectic combat and my thrall might be chasing something out of range after I have the inventory window open. I’ll pay more attention to it and see if that’s the missing factor.

1 Like

Make sure thralls have still free inventory space, or this may trigger this message.
Can happen when food spoils, experienced this several times.

You need to learn how to not be dependable on your thrall to knock other thralls for you. I always knock the thralls myself, while i use my thrall as a “meat shield/tank” if i do a bad pull or an entire camp attacks me.

Always have a bow with you, if you cannot do body pulling with your thrall then a bow + blunted arrows will help you out.

The issues with weapon swapping/weapon going poof are for quite a long time in the game now. Always a client restart will make them visible/interactable again, ofc doing this is mid fight sucks :slight_smile: but will help save the thrall you are after(Thrall will stop doing damage while you are logged out).

Go Siptah :stuck_out_tongue: . The new “ashlands” rock formations, the black ones that you cannot mine are very buggy. When you walk on top of them your character goes into “tremble” state, there are also many wood stairs/floors that the thrall does not like to walk on. I miss the fine sand from EL :stuck_out_tongue:

I have seen all those issues you mentioned above, a restart has got my thrall back on track each time. Usually happen to me inside Vaults, mid vault the thrall would just refuse attacking. Relog and he was ok again.

Maybe we should start gathering more “correct” information on this matter. At the moment follower clipping to almost anything, or half buried into terrain, or simpli Moon Walking away(to god knows where) are the things that trouble me the most.

1 Like

I currently have a thrall that is producing Flinthead Arrows in her inventory :slight_smile:

It’s a different error message. I always keep free inventory space on my thralls because otherwise I can’t swap weapons/armor due to not enough inventory space. I generally keep a duplicate set of gear on my thralls and use that to swap to when my gear durability gets low. That’s why this issue stuck out to me because the error message is different. It’s something like ‘that item cannot be moved’ not ‘not enough inventory space’. It made me wonder if the animation restrictions with putting away weapons they implemented for players had an impact on thralls in any way but that’s entirely speculative.

@Coty I’m good with how I do things. I’ve used bows, I prefer truncheons. This is not an issue I experienced prior to 2.4 and I’m not seeking advice on how to knock thralls out safely or what the best way to do it is. The question was whether others had experienced a difference in the behavior of thralls in combat while trying to weapon swap since 2.4 dropped and if or when others are also getting this error message. While it’s possible that this happens due to distance that I’ve just overlooked, others on my server have also expressed frustration over a difference this patch trying to swap weapons. I’m trying to ascertain whether this was a change or whether it’s been pure coincidence that I have not experienced this issue previously. I’ve done this many, many times in 2.3 and had almost no problem swapping to a truncheon quickly. I’ve rarely had quirky issues where both the truncheon and 2h weapon was equipped on my thrall with overlapping graphics or where the truncheon disappeared like it was put in the inventory spot but no graphic change and then after combat I take the weapon off and the truncheon appears. Maybe a handful of times playing in the past few months and I’ve never needed a restart to fix those issues.

To the topic at large, I haven’t tinkered too much with different weapons on thralls yet, at least that’s not what’s causing issues. I have weird stuff where sometimes thralls won’t attack or where they simply stop attacking randomly and return to me or seem to get stuck in a spot doing nothing until I issue a command to attack or return which seems to reset them. And the typical shield issues where they just stand there blocking still happens. Most of the issues I experience seem to be related to pathing problems and occurs when there’s lots of debris on the ground where I’m fighting or when I have a lot of things knocked out on the ground and even occurs when on guard. I’ve found picking them up and moving them when on guard fixes the issue.

1 Like

That happens to me all the time - I give them star metal arrows and they spawn flinthead ones, because I keep forgetting to assign the star metal arrows to their bows before I give it to them.

Ok, now i understand. So i have to equip the bow with the arrows and then i can give the bow to the thrall :slight_smile: Then i will not have the 1 Flinthead arrow appearing in its inventory, right?

It has been a long time since i used a thrall that has main weapon a bow :)))

Another thing I thought of as it just happened. Still having issues where thralls get a super cripple effect that doesn’t go away until they actively engage in combat or an extreme amount of time passes. They don’t have any visible debuff but the stats screen shows a 100% cripple effect with no timer.

Can only agree. Experimented several of the bugs you mentioned.
I observed lot this last days thralls stopping fight after the first fight, then hold an imaginary shield (wights as example here, not thrall, still), or simply fist-fight while they have good weapons. Mostly next fight all is doing well again. I think you’re right with the idea that it may be a pathfinding issue here in most case.

But also in base, there strange behaviors. Often when i come back, i have some thralls stuck in strange position, like my bearer behind the furnace, or my dancer nearly dancing out of the wall behind a stove. They can clip, or go trough walls depending in animation.

1 Like

Its a bug and here is how to prevent it.

DO NOT replace thralls original weapon until its attacks a player/npc with a full combo. Once it does then swap to any weapon you want to.

If you swap out weapons before they do a combo with original weapon they will be stuck doing what you posted FOREVER.

I have not found a way to reverse this effect. I have swapped multiple weapons after having them glitched like this and even placed original weapons back on them only to discover they will still be stuck swinging once.

I will post a video on my YouTube page on what this looks like later today. The link to my page is below subscribe and hit notification bell to be alerted when it post.

maybe forcing said broken thralls to use a bandage would un break them, downside is dancers for whatever reason cannot use bandages.

could i perhaps request that (ability for a dancer to use a bandage) to be a feature somewhere?

Happens also with wights, and they don’t have a physical weapon, and no weapon switch.
Sure, they’re more considered as pet than as thrall, still same behavior.

Also they may dance the imaginary shield dance during some fights, next fight may be right again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.