Achievement bugs (on servers = problem, on single player = works)


#1

Yesterday and a day before it I was trying for an achievement hunting session.

I noticed something:
in single player most of the achievements works (I got all the level ones (10x multiplier for test purposes))
Also some “easy” to get ones on the way…

And surprise the journey works quite well while i am playing single player.

BUT

When I join to the official server (PVE-F #2)
I only got one achievement and not anymore. also journey step “equip a light armor” don’t do nothing there at all.
So the only one achievement I was able to make is beyond wolves or something when I teleported up north via removing the bracelet and using bed as my spawnpont…

EVER SINCE THAT MOMENT (which was almost the first move of mine)

Tried: falling (4.6 seconds) and landing in water … No 3sec falling achievement triggered after a successfully alive test.
Tried: creating some flawles piece of sheetmetal… I think it was a flawless steel 2h sword, and an exceptional zamoran thief armor via thralls knowledge in the respetive workstations. NO achievement of “create a flawless or exceptional…” triggered.

This is official server.

Also I wanted to kill that freekin’ bonedragon and he was spawned UNDER the map. I know I saw his back between 2 stairs when I was go for the snake. (speaking os snake it fell through the map as soon as I killed it…AGAIN)… :smiley:

So no achievements are possible on servers?