Age of Sorcery update broke my game :(

There was a Hot Fix!!

My system is set to automatically download so I didn’t catch the size or when it was released but it was significant.

I can confirm that on my PS4 the hot patch has made the game playable at least for lower level areas on official servers, I played on 2 official servers for over an hour each with zero crashes. And over an hour in higher level areas in solo play.

-weapons and tools no longer disappear after using construction hammer (nice).
-DLC building blocks all display again (that shocked the hell out of me)
-colours/textures are still very slow to render on DLC blocks and thrall armour. Grass/bushes pop into game suddenly as you are walk or run through a new area that is a bit startling…
-DLC armours now render, (no more invisible torsos, or missing legs/arms), but seem able to use most DLC armours without thralls or self disappearing.
-imps and alligators are no longer invisible (nice quality of life feature).

I think I will go the way of @PloddingDonkey , and disable auto downloads in future, it only took Funcom 2 to 3 days to address the most egregious bugs, but disabling auto updates lets me decide if I am going to be an ‘accidental’ Beta Tester or not.

Player textures do default to low resolution following sever corruption, but wow

Magic is looking amazing so far, am looking forward to trying things the YouTubers have been sharing for the last couple of weeks.

Thanks for fixing this hot patch Funcom…
thank you thank you thank you!


Ah this is music to my ears! Thanks for the update man, I’m away for work at the moment so I’m really glad I will be able to play when I get back :smiley:

1 Like

Just gonna add this because I was able to go back and play for 6 more hours last night trying everything my characters could interact with.

some more esoteric items (i.e. jhebbal sag religious mask) still doesn’t render. (only rarest of items, i spawned many many items to test in solo play).

I was able to use Conan Exiles Sorcery bench, DAMN, ability to reskin weapons and armour is AMAZING!!! You can use all of your DLC armours now because you can take stats from a legendary armour piece and place it on anything that looks cool.

This even extends to weapons, as long as they share Agility or Strength with the item you are mixing with, AND effects carry over… i.e. Bright Sword when combined with a DLC sword now glows!!!

I fought several world bosses with no problem, loading times are much improved, but I did lock up the game twice when using sorcery.

Both times I locked up was when trying to use magic, so I definitely would not use magic in combat on PS4 yet.
1.First lock up was using wand in Volcano ( I knew i was pushing it) lava and magic was too much GAME FREEZE.
2.Second lock up was just trying to start spell animation.

I currently only use sorcery at my bases or safe areas for summoning or transporting,(only 2 failures in 6 hours of game play is pretty amazing)

but that sorcery bench is AMAZING, and reskinning items and weapons is the update we all deserved.

Thank you Funcom!

Here are the latest patch notes.

Hotfix hardly addressed the issues.

1 Like

Same here server 8121 has not loaded for me since the original update, and is still crashing on load now… I really hope we are not about to lose all our work… please tell me someone thought to freeze the timers…


Did we actually get a choice regarding the latest two updates???

No unless you play offline mode maybe

1 Like

After update 1.80 the game doesn’t load in single player. On European version of the game there is no problem loading the game in single player also. As with Windows , introduce new features and bug fixes and bring new problems to fix later.

1 Like

Played again last night, trying to figure out how to build a comprehensive Bug Report:

-solo play, graphics were slow to load, but did load.
I previously boasted about 6 hours with only 2 crashes, in solo mode. Well that seems to have been a fluke.

  • I either locked up and/or blue screened every 50 minutes or so, over 6 hours of play.
    -twice my character got stuck under my horse, while approaching it on a slightly inclined plane (once in Unnamed City, Once on a plain outside of Sepamaru) only way to continue was to enter Admin mode and Admin teleport. (I know this problem has a history in game, but it has always happened to me against a rock, or building, when dismounting, NEVER when approaching my horse on an uneven plane).

  • 3 of my 6 lockups/blue screens came from interacting with new tabs for Challenges, and the Bazaar.

  • other screen lockups were random walking up stairs or trying to collect loot from a corpse…

Beautiful Game, saw my first event (in solo play, didn’t know that was a thing!), but ya you guys are right, lots of glitches going on, sorry about my earlier optimistic post, it was obviously premature…damnit.

1 Like

I have several private servers with public players that are on regularly, and the only map that is screwed up for me has been Siptah right now. There are other smaller bugs though on both since the update.

  1. The figurines on Isle of Siptah (big part of that map) can not be picked up (all players)
  2. Health bars do not show up on all NPC’s or players when set to show all. Very important in a fight.
  3. Spontaneously players get kicked from the servers and there is a FUNCOM Fatal Error message.

We have one of each didn’t play on Siptah server today. No invisible stuff on official we blue screened and froze alot on official going into bench thralls inventory and accidently going into Bazaar or battle Pass. Can’t swim over encumbered. Not touching Sorcery or buy anything until things are fixed. Day one player Exiles server been up about a month after release since you could not find your body. We are game supporters all dlcs just not going to invest too much on official or buy until bugs are ironed out I have been one who has said things are working ok for us and perhaps considered a fanboy way too old to be a boy and disenchanted after what is going on. Will get back and let you know what happens tomorrow. @DocAceZ


Pulling out the staff on a busy sever will crash anyone close by. Everyone is using magic On each other either to purposely send ppl to the main menu or to naked lighting spell someone’s base while they aren’t home.

It’s this kind of gameplay that makes people leave.

1 Like

SUPER slow swimming while “over encumbered” is a game change, not a bug.

Everyone has different issues with 3.0 it seems, some main stream, some isolated.
If you have been gaming for any length of time you should know/expect every new release of a major update has issues - sadly that’s just how it is at this point. Should Funcom have released it, I don’t know. What I can tell you is the Sorcery items my crew and I have performed worked OK. Were they all what we though they would be - no, but they worked. The issues (most not all) with the native game are what is ■■■■■■■■ this update up for us.

I want the people that visit my servers to enjoy themselves and these bugs are effecting that. Siptah was hit pretty hard on this update. So much so we are all on Exiled Lands, and the new sht is OK so far.

Give it a bit the hot fixes “should” remediate most of what going on - not all…


Go to a private server. Officials suck and are a place for the mentally insane.


Privates are dead on console and admins almost always play favorites

1 Like

server 8121 STILL not accessible after latest update, please tell me we’re not going to lose all our efforts yet again…

You know I get tired of you sometimes even though I agree with some of you’re crap leave private servers out of it we are not all bad…


@sestus2009 I did say almost


Cool :sunglasses:

1 Like

@sestus2009 , @Boobie