Age of War - Battlepass legendary challanges are mostly broken

Several legendary challanges do not trigger. I. e. pryaing at temple sempermeru or kill wine cellar boss. I guess that more legendary challanges are affected.

PS: Does not matter if playing with or without mods. Bug occurs with dedicated server too.

Cheers :slight_smile:

I just completed Winecellar withough issue. Kiilled Boss too - all of them.
All triggered as expected and, happily, damage nerfisisations worked in my favour!

1 Like

It might be a connection issue with the Funcom service. Sometimes it can cause things like challenges not updating or rewards being unable to be claimed. Though - if you were able to do other challenges while this was happening, then who even knows what it could be.

1 Like

I prayed yesterday at sepermeru and it worked.
Make sure you stand on the altar.
I used the mitra worship emote and it worked.

1 Like

Thanks for your response folks,

today i got the same for the challange Kinscourge. @drukuku , this is the point. Every ohter challanges are working 100% fine. I know from the past that sometimes it can take some seconds before the challange counts.

@Provokatze23: I used by crom, mitra, pray standing and kneeling on top of altar… doesn’t work.

For me really strange, because I do only the update - of course the steam client too. Of course it seems to be something on my side. If it would a general problem, I think I would find more topics like this or at google search… /:

Edit/Update: Thunderfoot is working - abyssal sewer not (for me)… wth :face_with_raised_eyebrow:

When I logged in yesterday in Singleplayer for a short look I saw this:

I am not gonna lie. This is stupido.

eah, thats normal. You see the new challanges. They reset after 6 hrs instead of 24h. Build a chest, place it, spawn 4000 gold ingots and put them into the chest. all challanges done :wink:

Greetings @GhOsT51 ,

Have you tried to complete this challenges without mods?

If so, can you let us know if you’re playing on a private or official server and if possible can you also please send us a video where we can verify this?

Thank you in advance and feel free to send us a video trough a private message if you prefer. :slight_smile:


I have tried the wine cellar and silver mine spider legendary challenges of course with and without mods. Last one to make sure, that not a mod is responsible for. But on other the hand, ALL other challanges (normal, special and rare are working fine. Even legendary challenges like killing a giant spider (in open world) or killing two stormsand beast (openworld) are working for me.

I guess the thing point in a direction with dungeons…?

I’ll try to make a vid and send it to you when I get one of those challenges again.


Todays update:

On a second PC I reinstalled CE fresh. Started a new game w/o mods and got a “surprised” result: all challenges working perfect. So that means I’ve now to investigate which of my used mods is causing that behaviour. As strange as it could be there are only the legendary challenges who are in seperate dungeon…

Never the less, this is NOT a bug from CE its self. SO this case can be closed.

Thanks in advance


Edit: After trying my normally used mods step by step I identified the responsible mod: Age of Calamitous. With it active it doesnt count i. e. on isle of siptah killing bobcats or bisons…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.