AI worse on thralls?

so im not the only one having this, i took my bandit and relic hunter into the new dungeon, both with sword of crom. after a while they do just stop hitting the mobs and i died twice. i switched up the weapon but its also the same thing. no changes no aggressiveness like they used to have before patch. they just back pedal or just look at the mobs and not do anything with weapon drawn.

os if u want to give it a try, take ur thrall to the dungeon and see if it stops attacking


i play on single player, and have noticed this as well.

archers on the ledges, i shoot my bow to lure a croc over, and the archers start running away scared …lol now i have to protect myself AND them!


Hello Guy’s yeah i just came here to post or see if someone had the same issue…i have a base near mounts of the dead and it took me 3xbandit and 2x t4 bearer thralls to get that aesir armor blueprint…the best was my faithfull rethrous the burdened who only had the wight boss to finish all the other thralls got bug after 2-3 kill even one bandit (that i had to take from my thralls chest) did not even attack anyone…

i took out a 4th bandit out of the chest to go craft the armor almost got kill because that thrall would not attack as well… don’t get me wrong i like to fight in this game i don’t sit there and watch thrall do all the work, depending on the built you have they can save your life.

i hopeit’s just a tempory thing and funcom will look into it…but i got to say that today was the worst day of my conan experience…and it’s sad cause i love the game !! someone on twitch told me to put weapon in second slot but it’s did nothing for me and i’ve tryied all my tip on how to not bug a thralls lol well will have to wait and see !! like always much love and KeepOnGaming


Hello @Pwndesal, welcome to the forums!

We’ve just forwarded this issue and all shared information to the developers so that they can look into any possible causes for the Thrall AI misbehaving.

Please continue to share any further tests cases or situations, including as many details as possible, as they will surely help us in replicating the issue on our end!


@Wak4863 Well i did a bunch of testing changing armor equip/unequip, make follow unfollow, stand guard, different thralls…etc !! and i was about to give up…did not want to open more new thralls…and finally i said screw it…took my good old faithfull dalinsla snowhunter and i left for a star metal run saw the shower and after i left…i was like dammmm i forgot my sword of crom.she had a 2hand star metal and to my great suprise no bug at all. so maybe it’s the sword of crom or something like that. cause i know i’ve use only that weapon on my thrall in all the test cause why not lol more have to be tested…and if someone in this post can test us what weapon they were using would help alot thank you and KeepOnGaming


Thrall AI has been pretty decent lately… Got way worse after patch. At the same time they seem to be consistently fine with punching if you take their weapon.

Only thing that has worked for me so far is taking their weapon and putting it directly in their hand during a fight. But only done it 3 times, so not sure if it will work every time or if I’m just lucky.

The new boss in the Kings Niche didn’t want to fight either. I had just got my Bandit Leader working, but when we got in there, he was just hanging out, at that point the boss was working. But I ran out and back in to see if my thrall would work and then the boss aggroed on me, but didn’t attack… Must have caught the Thrall flu

weirdest thing was, after I spanked the boss and went out, I didn’t change anything cos I was going home anyway, but then my Thrall worked fine again.


That’s an interesting thought will test switching weapons tonight.

Ran tests last night and this morning.

Dalinsia (Blade of the Adventurer) seemed to be sort of OK. Ran around with her for a couple of hours last night. There were definitely some times when she was slow to get involved. She was by far the most active.

Went over to the semi-giant spider (Seems smaller?) on the plateau in H5 with a Cimmerian Berserker (Sword of Crom). She was attack, Take 3 hits, back off, Take a hit, kick, Take a hit, back off, attack.

We then went into the Summoning Place, and where she would normally attack anyone who attacked me, she was slow to move. There were several times she just ran up to them sword in hand and had a conversation about how many arrows I was getting hit with at the time. A high level character should not leave this place with a quarter level of health.

I took A bearer, Kathibria (Sword of Crom), out to the valley to see how she did with the king Scorpion. Intermittant attacks with plenty of damage to her in between. I am pretty sure if the archers on my wall hadn’t been firing non-stop, she might not have survived.

While I like the new things to do, This is an issue that shouldn’t be an issue. It’s bad enough we have to carry extra healing potions to spend significant time around the world (thanks for fixing both the passive regen and Lifeblood), but now the thrall bodyguards are effectively less helpful.

We purposely didn’t go into the new dungeon because we wanted to see what the combat changes would do, and now I have no desire to go in any time soon.

EDIT: Added the weapons to who had them. I will have to try different ones tonight. I will say they seemed to be just fine with Truncheons.


captain was useless so I tried a dacias, not any better. This SUCKS

1 Like

I noticed that any thrall using a sword of Crom had some issues with the AI, but I had no issues with thralls using other weapons.

The AI behavior is terrible in general right now. In order to add more information I’ll share my experience from last night.

  1. Giant Crock near F7, attempted to kill using Narr (T4 Bearer) and all he wanted to do was stand there with sword in hand (Sword of Crom) and look at the crock. Then he started to back away slowly as if retreating 1 step at a time. I reset the fight - my base is near so I grabbed a different thrall (Treasure Seeker Fighter 4) using Blade of Adventurer. Killed the Croc no problem but did significantly less damage than I expected and have experienced recently (within the last 2-3 days).

I figured ok fine it’s just the named bearers but just to be sure I went and grabbed Eina the Light (T4 Bearer) and took her out to fight the queen at the bottom of the spider cave in F7. For about 1/3 of the fight she seemed like she was attacking mostly (Sword of the Adventurer) but then just randomly stopped and stood there like she was stupid.

I felt like my hypothesis was confirmed, went back to my base and grabbed a Captain (From SEP City 7425 health with Jedia’s Lightsaber.) Took her out to the Black Gall to inspect the new changes and she acted ok killing for a bit but then I found a named that I wanted to grab so I swapped her weapon from her inventory to a steel truncheon. Went to KO this named black smith and she just stood there with the Truncheon equipped. She ran up to it like she was going to bash it then just stood there. It is important to mention that I have learned NOT to manually equip weapons on my thralls weapons slots as it bugs them at least half the time so when I swap weapons on my thralls I wait until they return the current weapon to their inventory and then I switch it with the new weapon and allow them to equip it when combat is initiated.

That being said I tried several times to swap in and out different weapon types on this thrall (the captain I was using at Galleon.) I tried Sword and Board, I tried Axe and Board, I tried Whirlwind Blades and I eventually went back to the Jedia’s Lightsaber. The ONLY thing she would use was the Jedia’s Lightsaber and after the bug occurred she attacked like she was constantly stoned out of her mind. Waiting up to 10 seconds between swings, swinging sometimes once and pausing 10 seconds and other times doing the first 2 attacks in a heavy combo then stopping for another 5-8 seconds.

This prompted me to go back to my base and try different thralls in order to see if its a general bug or just specific fighters. Here is what I found.

80% or more of the thralls I tried to swap weapons with immediately became bugged and almost useless instantly and remained that way regardless of what weapons I swapped to them to or if I gave them back their original weapons or not.

100% of the time named bearers were complete and utter garbage regardless of weapon selection and regardless of what I was fighting. If they remain this way they are little more than pack mules. I have every single named bearer in the game by the way and I tried every single one of them against multiple mob types including 1 skull and 3 skulls. Named bearers (in their current state) are almost completely useless.

I realize you nerfed them but this isn’t a nerf this is a hack job. They are stupid, they don’t know what they have equipped, they don’t know where the fight is, they don’t know where to fight.

Fighter Thralls in general are also having MAJOR problems. Even when they weren’t bugged they were slow to initiate combat, slow to react to movement and had rediculously low damage output. When I say rediculously low I mean less than half of their damage output prior to patch.


AI is buggy and weird. Weapon swapping is a mess. T4 bearers didn’t get nerfed, they got nuked.

That is all.


So I did some more testing today. I have some video footage as well but it’s probably not necessary however if Funcom would like to see it I’ll render it up and link it.

After a fresh server restart…

Tested Cimmerian Berserker with the watch blade. Was able to stay engaged in the fight minor pauses but very acceptable and fluid battle.

Tested the same Cimmerian Berserker with the Sword of Crom. Saw the same result as yesterday. Long pauses, taking steps away from the enemy. Very inconsistent engagement in the battle.

My conclusion is that something has been done with the Sword of Crom. I also noticed a stamina bar on the thrall. Although I watched while the Thrall attacked with the Sword of Crom and the Watch Blade and I did not see a change in the stamina bar. Additionally when the thrall decides to kick while holding the Sword of Crom it still takes a “smoke break” between attacks. So I’m not real sure what’s going on. Hopefully the additional information helps.


I has this problem before this patch and the one before it, where my T3 bearer wouldn’t do anything in fights. I kept switching from his sword to bludgeon depending on situation and this is how it started. Someone suggested to stop switching their weapons around because it messes with them. I did that and it stopped.
I now have Eina the Light and she just has a club all the time. Makes her kind of useless when fighting wildlife but she does engage the enemy so that they leave me alone.
Sometimes…after a fight she has her club drawn and backs slowly away, even if nothing is there. But I don’t switch her weapons with anything so at least she knocks out people left and right inside camps.
I haven’t tested out switching weapons back and forth with her depending on situation as I did with my T3 backpack guy.

Went out last night and tested several thralls with multiple weapons;

The Weapons:
Sword of Crom
Blade of the Adventurer
Telith’s Sorrow
Baal-pteor’s Razor
Papyrus Blade

The Thralls
Two separate Cimmerian Berserkers
Kathibria something bearer
Two Separate Dalinsia Snowhunters
Erii the Ravager

The Results:

Every thrall using the Sword of Crom attacked, took a break, got hit a lot, swung the sword a bit, got hit, rinse and repeat.

Every thrall using any other weapon attacked consistently, and those that were previously aggressive, ie hunted down targets, were a little slower in doing so.

The biggest difference I saw was that they are a little slower to engage, pause a little longer than before, but are still doing their jobs, albeit not as well.

It appears in addition to rendering the Lifeblood moot, the Sword of Crom is also pretty useless.


just a hypothesis, but what if they are trying to implement thrall stamina and it is actually in effect but the display bar is not indicating this.

Then SoC would be acting as intended instead of exploited via infinite stamina thralls
ADDED: more supporting evidence:

as if it ran out of stamina?

I don’t disagree with this hypothesis, however it was not outlined in the patch notes. Which leaves it to us to test. Which admittedly is fun to do sometimes.


new user, little info:
T4 Bearer Eina the Light doesn’t even try to fight.
Sword of Crom may stop other fighter thralls from fighting after a while.

1 Like

I can buy into the thrall stamina thing with the sword of Crom…maybe. both of my Captains have bugged out, one has an old style Crom and the other has the new nerfed one. Neither will fight at all anymore. Today I ran tests with a named archer carrying the sword of the adventurer. She eventually bugged out after a few fights and refused to fight. She was awesome at running up and making threatening moves, but wouldnt’ swing that sword. I then ran a Snowhunter and she did the same thing. Fought valiantly for a few fights then stopped for a federally mandated lunchbreak and watched me fight. Tried the archer again with the whirlwind blades and she danced, backflipped and did her best but the DPS was terrible and it took so long to kill the miniboss I just jumped in and killed it. She never glitched though with the whirlwind blades at all. Another interesting thing I noticed, I gave a sword and shield to a berzerker and we went after the skeleton mini dragon thing. She was doing some wierd moves, she would hitch up her pants, move around in front of it, pause, then hit. The mob didn’t seem to mind that she took her time and seemed to wait on her. It was all too surreal. lol

I think sword of crom is causing pauses, but i think too many pauses will cause thrall ai to mess up and then it ends up with jus the thrall not doing anything i did a bit of testing and found this out. Other wepon seems alright but something indeed happen to sword of crom and thralls pausing in attacks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.