Armorsmith bugged?

Game mode: Online
Pr
Region:Eu

Named armorsmith not making any flawless armor apart basic one and aquilonien since 1.61 patch
What’s going on ?

Steps on how to reproduce issue:
1.
2.
3.
4.

Was having same problem yesterday with blacksmith bench. Tried to fix weapon I had made and it said I didn’t have the knowledge. Also happened to clanmate. We realized whoever accessed the bench last, it remembered their unlocked feats. He didn’t have maces unlocked so I couldn’t see my mace if he used it last. And if I used it last he couldn’t see his axe. Taking the thrall out and putting them back in seemed to reset it and then the feats would show up correctly. Also we unlocked the weapons the we were each using so that the bug didn’t make each others feats not show up as a work around. Hope they fix it soon.

1 Like

That is a fix to a similar problem from over a year ago. Didn’t stay long enough last night to check on that sort of thing.

Thanks the fact to take off the png and back on bench again worked

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.