Battle Pass No outcome

Basic Info:

Platform: Steam
Issue Type: Battle Pass
Game Mode: Online Official
Server Type: PvP
Map: Isle of Siptah
Server Name: 6447
Mods: =MODS=

Bug Description:

Bought up to lvl 43 in battle pass. At first it showed all my unlocks from battlepass. Yet it wanted me to spend points to unlock them. Ok, fine. I tried to click to unlock them. Nothing happened. Then it showed battle pass was unable to connect. Relog and load conan again. Now my ancestral knowledge tree is missing a lot of unlocks I have spent my hard earned money on and there is nothing I can do. There is also no real way to contact funcom when it comes to money related issues or ingame purchases like this. Other then bug report. So now I wait in hopes

Bug Reproduction:

bought pass up to lvl 43. When I wasnt able to unlock it in tree. I tried to relog several times. Nothing happens. Now my tree its greyed out but in a green tint and unlclickable

Greetings Visago!
Thank you for reporting your situation regarding the battlepass that you bought.

In order for our team to properly assess the situation, specially since its related to your account, please follow our Official servers guidelines to submit a ticket through our Zendesk platform:

Our team will await your report Visago!