[Bug] Change to 3840x2160 resolution > can't click anything


Changing to 3840x2160 resolution > I can´t klick any other element in the >options< menu.

Leaving the >options< menu without saving leads to a main page, where I can´t klick anything. Because the “usable” frame is much smaller than the main page.


Windows 10 Pro 1803 64bit

AMD Ryzen 7 1700


Nvidia GeForce GTX 1080



Thank you for bring this to our attention :slight_smile: Are you trying to run it Fullscreen of Windowed when you change your resolution?

Hi, I just bought the game In Jan 2020 on steam (not sure ver/build), and i run at 3860x2160 @ 60hz. Whether it was in the demo or the full build whenever i try to set the resolution 3860x2160, i get forced to select full screen or windowed, but my pointer no longer matches where i’m pointing on the screen.

I managed to use spacebar (really, can you guys just copy everyone’s elses menu’s, there are like no games on the market that use spacebar as a confirmation to setting/saving) ie a ok button at the bottom right once you’ve finished selecting the settings. You do not need to ask users if they want to save the changed setting. Its really redundant and soooooo 1990s.

Nonetheless i got back to the main screen on 4k but i couldn’t get to the menus.

Look i get it, 4k users make up like 1.5% of all users but if you could sneak a fix into your next release that would be nice.

Let me know what testing you’d like (screen shot/gif etc).

Hey Chugs,

We brought this up with the dev team around launch, when this thread was first created, but unfortunately it wasn’t prioritized by the developers and has thusly remained unfixed.

Right now there aren’t any additional updates planned for Mutant Year Zero: Road to Eden.

This reminds me a little bit of the response i got when i asked for 32:9 support. ( 32:9 (5120x1440) support? )
Yesterday i found out that apparently the priority of the developers was Corruption 2029 (fitting name :wink: )
Looks like its a cool game (witch is not on Steam btw :frowning: ), but can you blame us widescreen owners for feeling a little pushed to the side? :slight_smile:

I absolutely understand where you’re coming from and I don’t blame you for feeling a little pushed to the side.

1 Like

I found the workaround. The problem happens when Windows Scaling is not 100%. I play in a 4K TV and Windows “recommends” 300%.

If I set it to 100% before playing, I can use 4K resolution. If no, I am forced to 720p or the mouse gets stuck on the upper left corner (a square of 720p size). It is very annoying to do that before and after playing the game, but it works.

This is not a solution, but a workaround. I give this information to help to fix the bug. I don’t think it can take more than one or two hours to fix it knowing that. I think we deserve a fix after two years.