[BUG] Crimson Lotus can't be ground


#1

Game mode: [Online, Private Server]
Problem: [Bug]
Region: [EU]

Hello,
I’ve noticed over a month ago that it is completely impossible to grind any Crimson Lotus into Crimson Lotus Powder in the Grindstone. Thus effectively causing 3 Elixiers(Elixier of Grace, Elixier of Endurance & Fishgill Potion) to be unobtainable without the use of Admin privileges.
This has been a long standing issue by now(It’s been reported since over 3 months now!) and the fact it disables the crafting of 3 items is more than mildly infuriating.

Please let me know if there is a fix or a viable workaround.

Steps on how to reproduce issue:

  1. Farm some Crimson Lotus
  2. Put the flower in a Grindstone
  3. Watch as nothing happens
  4. Resign that you cant brew the Potions you wanted to make

#2

There isn’t. I fixed it by adding the missing row to the recipes table, which helps no one on official servers.

There is a mod on steam that apart from other changes, also fixes that and some other bugs. It’s called age of barbarians.


#3

could you tell me what line you have to add? Would be much apprechiated!


#4

I pasted my fix in a recent reply to another thread, but the forum mangled it so it’s invalid JSON if you try to paste it back in.

Are you sure you want it though?

You’d need to install the 150GB dev kit, modify the recipe table and use the mod in your private server.

The mod on steam fixes it (age of barbarians) and for the most part, the other things it changes are desirable imo. It’s a cool mod. (not mine, fwiw). Elevators that move faster than glass flows FTW.

Mine was just a quick hack to check that it worked and I didn’t do extensive testing. I recommend you wait for the official fix currently on testlive or use age of barbarians for now.

(although if you really want it, I can send you a link to the JSON row on pastebin or something).


#5

The new testlive patch notes now includes Crimson Lotus grinder fix. Now to see if they fixed harvesting them too!


#6