BUG REPORT - Purple Texture Issues


#1

Game mode: [Online | Singleplayer] - Both
Problem: [Crash | Bug | Performance | Misc] - Bug/Performance - it’s clearly a bug, and I am unsure if it causes slowdown of the game.
Region: Australia


I have a bug whereby the textures seem mixed up, I have been searching for a solution to no avail, so if there is a solution out there I could not find it - sorry.
The textures sometimes show up as normal, sometimes bright green or purple, or other times mixed up, sometimes parts of the texture are completely missing (for example I can sometimes see through a thached roof in parts, but other parts of the roof are a mixture of the above issues, and others are clearly the proper textures), I have screenshots, but ‘new users cannot post images’ so I cannot upload them.
I have two graphics cards in SLI/Crossfire
An AMD Radeon R9200 series, and a HD 7900 series.
If there is anything you can do to help me fix it, I would be most appreciative, I have uninstalled, reinstalled, unsubscribed from every mod I subscribed from; frankly I have been putting up with it but I am finally sick to death of it, it has been persisting for a long time now.
Thank you for your time and patience.


Steps on how to reproduce issue:

  1. Havn’t a clue
  2. Allow posting of screenshots maybe?
  3. Otherwise have no idea whatsoever.
  4. Sorry for lack of help in this…

AMD GPU Support
#2

That sounds like artifacting. This is most likely an issue on your end, with your GPU(s). Are you monitoring the temps on your cards? Have you updated your drivers? I’m not familiar with AMD protocol on this, but I’m sure you might get better direction visiting their forums. I’d personally try these things in this order:

  1. Check temps while in game. If they are getting over 90 degrees C after running for a bit, you should consider turning down your graphics settings or adjusting your fan profile. I run 3 cards and try not to let mine get over 90. 100 degrees is usually the point of thermal shutdown. If you’re running over 90 consistently, you risk damaging your hardware.
  2. Do a fresh install of the drivers, from scratch. Also, if you are running any 3rd party software for GPU overclocking or anything, disable those and go back to factory clock settings.
  3. Try running the game with crossfire disabled on a single GPU. See if that helps or hurts the situation.
  4. If you are running your GPUs in lower power mode, change over to full performance settings. Be sure to monitor your temps and clocks.
  5. Unplug your PC and reseat your GPUs. Do some cleaning and make sure you’re properly seated. If you have another crossfire connector, try swapping that out.
  6. You might need more power for your GPUs. How big is your power supply?

I would take a few minutes and sift through a google search on “AMD crossfire artifacts”. There are some pretty good, in depth articles you might get something out of. If this post doesn’t help you, I’m not sure what else to say. Overclock forums are usually a pretty good thing to participate in if you run SLI(NVidia) or Crossfire(AMD). If this seems above your head, that’s part of the package when you run multiple GPUs. More power, more problems. Good luck, and let me know if you get any changes or updates.


#3

Update:
Ok, thank you for letting me know it is called Artifacting, I have researched it and it does indeed seem to be the case for me, I’ve followed some of the driver settings for the AMD Radeon settings, and it seems to help with some of the problems.
My PSU is 850W I believe.
I disabled crossfire, no change.
I doubt I have them in low power mode, as I am unsure how to enable or disable that.
I haven’t opened up my case and fiddled around with the insides, I was somewhat busy today; I have grabbed HWMonitor, to see temperatures, but it only shows one card for some reason…
Thank you for your help with this persistent issue.


#4

I think for AMD you’re going to need to modify registry to change power modes. Like I said, I havent had AMD in a while, as I’ve been using NVIDIA. I would assume you have enough power with 850W and 2 GPUs.

Def get a temp monitor going and let the game run for a bit. When you see artifacting, check your temps. When you get more time, I would also suggest perhaps pulling both GPUs and putting them in one at a time to see if that changes your symptoms. Disabling crossfire puts the load on one GPU, but it could be that GPU that is being troublesome. Also, pulling the cards one using one at a time would certainly rule out any power supply issue possibility I would think. I’ve read some ppl having these issues with CCC enabled. Try disabling that in the desktop AMD profile settings.

Do you play any other games? If so, which ones? Does the artifacting present itself in those? You can also download furmark and put a heavy load on your rig and see if you start to see artifacting after a few minutes. It’s also a great way to monitor temps under heavy loads.

Keep us posted.


#5

Update:
Ok, I’ve got MSI Afterburner to monitor both temperatures, when GPU 1 got over 90C I pulled it out and found a fan had broken, I’ve fixed it, so I played again, temp still got high, used Afterburner to move fans from Auto to Manual at 100%, now the temp is ~80C.
Unfortunately the Artifacting is still happening, I have many other games and they aren’t present there that I can remember.
I am yet to remove them individually, as I had to reassemble my mother’s PC this afternoon.


#6

I have this same exact problem. It only seems to happen in Exiles.

Thank you for posting about this…I was starting to think I was going crazy!


#7

Cheers A_Nightfury,
You are right,it’s as you described,artifacting.It’s only doing it with the new AMD divers,fine when rolled back.Will try some of these work arounds and see how we go.


#8

I had this problem all throughout beta. On launch the problem of green/purple textures continued. The fix for me was to TURN OFF CROSSFIRE (Disable). This worked great for me. AMD GPU’s have problems. I had no problems for over a month after launch. However, patches within the last month or so have caused me to currently have problems with blinking trees, which people on Discord are confirming is an issue they also have with AMD GPU’s.


#9