Bugged org contracts

Org Contracts cant be altered, need help to fix it. Cant remove old ones.
In Old Athens i see the ones i want to remove, but when i go to any Towerspots we hold, i dont.

When you do /org contracts you should only need to click them to transfer them to your inventory, sometimes you have to close the window and open it again for them to disappear. Then you just add your new ones and wait two hours.

You don’t need to be in any specific location to do it.

Tried that, cant remove old ones. Tried anything to remove, just get duplicates in inventory, old ones stick in the contract window, and blocks me from adding new ones.
This is btw on Rk2019

Try transfering leadership to someone you trust and have them remove the contracts if it works. Could be client related that they arent being removed.

1 Like

Did that 2 hehe, i have tried every trick in the book, just not working, and FC dont care/responds to petitions, sadly. We are the ones providing their paycheck, wish they value that better.

Gotta wait for the petition man, sadly to say thats the only possible way. Been there, done that.
Good luck!