Climb Skill Increase Cooldown?


#1

Hey, tried climbing a couple ladders that required about 100 points more climb skill than my current stat. Went ahead and leveled up later that day and tried to increase my Climb skill, but the little (+) button for climb will not click. I have more than enough un-used points, and more than enough space below my maximum. I can click up runspeed, skulk, perception, etc, but it does not let me click up on Climb.

Is there some sort of mechanic that prohibits increasing a skill too soon after you failed a threshold, or is this some sort of bug that needs reporting? Thanks


#2

I’m not sure, but have you tried to log off and on again? :face_with_raised_eyebrow:


#3

First see what your climbing is currently at. The total max climbing is capped by your level. So you can’t put all your points into climbing. For example see if your climbing is at 400 of 400. Then it’s not possible to increase it anymore until you level up to the next climbing skill increase. If your climbing is not maxed and you are say at 350 of 400 and still have points to spent then try the relog first and also try to click in close proximity of the “+” sign. Sometimes my UI puts the click box for certains things off slightly. If that doesn’t work I’d try a petition.


#4

Nothing like that. I’ve bumped into a couple of ladders / climbs that needed more points then I had and I was able to add points right there in 50 pt increments (yah I don’t always keep those up to date so I had a bunch of points and room to play with) until I got to where I needed to be.

Sounds like your system just gliched or you weren’t hitting the sweet spot on the button.