Combat triggers automatically but there are no enemies left alive

bug

#1

Entering or loading my save at the Castle of Light automatically enters combat mode, but there are no enemies left alive so I can’t exit the map. I have a copy of my savegames here, it’s the last autosave that triggers it:

SaveGames-MagerValp-AutoCombatNoEnemies.zip

Background: I freed Lux slaves, took the lights, and traveled back to the Ark using the map without triggering the fight. I later traveled back to the Castle of Light, and initiated combat by mind controlling the tank at the gate. The tank was mind controlled for a couple of turns, but even after he turned red again he kept fighting with the other ghouls, until the fight was won. When he was the only enemy on the map, I triggered combat again by entering his aggro zone. The autosave is after killing the tank.


#2

Thank you for the savegame, we will look into this.
Mark


#3

No thank you for making an awesome game :smiley:

I tried today’s patch (the AMD fixes I think) just to make sure there are no changes, and as expected same problem.


#4

same here at the same spot, tried to redo the fight but the same annoying thing happened, now the auto save and manual save are at the same place and i’m stuck in combat mode forever … screwed all my game … too bad it was fun


#5

same for me. both saves are in the same spot stuck in combat mode after the lux fight. 30 hours in for me : [


#6

Confirmed fixed in the 1.03 patch, thank you!