Conan Exiles Dedicated Server App (Latest Version: 1.0.25)


@MidnightFC could you try this new version?

Dedicated Server Launcher 1.0.19:

  • Fixed the behavior of the Save Changes button (it stays grayed out if nothing has changed)
  • Fixed a manifest problem that resulted in the UI cutting in two when font scaling was set to more than 100%


Seems to work as advertised for me. :+1:

One minor suggestion that can probably easily be appended to the next version (doesn’t warrant an update on its own) is using the 24h format instead of the am/pm notation. Case in point I accidentally set the server to restart at 10:00pm instead of 10:00am a few days ago because the am/pm description is hardly visible. Alternatively I suppose you could also make the field a little wider. It looks like, whatever tool was used to build the UI, didn’t consider the space the little up/down arrows take up when it set the width. But overall I think the 24h notation would be more functional anyway. :slight_smile:



It’s supposed to be in 24:00 format already, guess there’s some hidden “local” parameter I missed, you will never see me default to AM/PM format, even under duress :smiley:

For the record, which locals do you use? (time format, keyboard layout, time zone, …)


It’s the US version of Windows 10 so it defaults to the US keyboard layout etc. I set the timezone to UTC to make it easier to convert things like restarts to all the timezones of our playerbase.

There’s also another weird bug that resets the restart time after it’s changed and saved. I haven’t been able to pinpoint exactly how and when it happens. I’ve had it happen to me a couple of times but since I’m occasionally a bit of a scatterbrain I blamed it on myself having done something wrong. :wink:
This time I decided to take screenshots to be sure and it actually happened again.

So I changed the restart time from 10:00 to 19:00 yesterday because a mod required an update and I like to utilize the automatic restart function for its warning messages. This screenshot was taken right after that restart:

Incidentally, posting the screenshot here I can say for certain that the 4 players connected part cannot be correct, because the server wasn’t accessible yet at that point.

After that I waited until the server had started up far enough for people to actually be able to connect to it (e.g. it shows up in the steam server list with 0 people online):

This screenshot is taken 12 minutes after the first one and 16 minutes after the restart. It’s plain to see that I changed the restart time back to 10:00 and saved that change (button greyed out).

This morning I checked the server again and lo and behold, it has indeed reverted back to the 19:00 restart time:

Changing it again made the changes actually stick.

It’s noteworthy that this has happened before version 1.0.19, so it’s not caused by the changes made in that version.


May we have an option to select the primary type of the server in the next version please? PvP, PvE, PvE-C


I’ve avoided so far to add any of the settings that could be changed in the in game interface, because these had historically a tendency to change often, also there is no clear limit of where we want to stop.

Basically the launcher is there to make it easier to get your server running, but after that you should just log on it, and then set up the parameters in the admin interface in the game.

The official servers settings are a mix and match of multiple parameters: There’s no “PvP” or “PvE” setting, what there is instead is a bunch of different parameters set to different values, and these have been regularly changed based on the community requests, adding these in the tool would be probably a permanent race for me to add this or change that.

Now, let me think out loud, maybe what would work is an easy way to apply community made sets of settings, like kind of templates that people could share, and that the tool would allow you to apply automatically, like for example a “Peaceful Role Play” template, with PVP disabled, faster XP, etc…

Then if somebody wants to make a “PvP” template, that would work as well, just select it and it would apply whatever parameter is necessary.

I’ve seen your message, did not have the time to look at the problem yet.


Thanks for your reply, all makes sense, :slight_smile:


No worries. It’s not urgent and I’m aware that - even though you’re now able to officially work on the tool - it’s still more of a side project. Look into it whenever it’s convenient and if there’s something I can help with, just let me know. :+1:


@MidnightFC could you try this new version?

Dedicated Server Launcher 1.0.20:

  • Forced the Restart Daily and Minimum uptime date control to use HH:mm:ss format to ensure 24 hour format is displayed (instead of AM/PM on US machines)

I’ve not looked at the weird time change, but as a first step, validating that the control correctly uses 24H format instead of 12H should eliminate some potential issues.

Btw, do you think 1.0.19 is worth putting as the new official version (right now it’s still 1.0.17)


I can confirm that it’s using the 24h format now with version 1.0.20.

As for making 1.0.19 the official version: While I can’t say that I experimented and tested a lot with it, it does run just fine with the settings I use.
As far as I can tell everything works fine and the Save Changes button does what it’s supposed to do (except the bug described above of course).


Hello! Why broadcast doesn’t recognize Russian language?



The reason is that the edit field does not support unicode (so it’s not only russian, it will not handle french accents, scandinavian letters, greek, etc…).

The main reason I did not fix that, is that it did not look like the RCON protocol was supporting unicode strings, but if somebody can confirm that it works and can specify which encoding they use (UTF8, UCS16, …) then I can probably try to fix that.

Another thing to check, is probably if the .ini files support unicode encoded strings, if yes I could also support that for the restart messages.


Can you solve this problem?
one more question.
Why does the message of the day not appear in the center of the screen when I go to the server?


Actually I looked at it, and it looks like the problem is on the server side. My tool do send correctly the messages in UTF8, but the server seems to parse them as if it was ANSI format.

I sent a possible fix to the server team, obviously they will have to review it and test it, and then if approved it will have to go through the normal publish process, so I can’t really say when this will happen.

Why does the message of the day not appear in the center of the screen when I go to the server?

I’ve no idea, is that something related to the Server Launcher tool? Or is it something in the game client when you log on?

If it’s a game client display issue, I fear you’ll have to ask on another area of the forum, it’s not my domain of expertise :slight_smile:


when I go to another server, a description (message of the day) appears on the screen. why doesn’t it appear on my server? help please solve the problem! thank.

Someone else’s server.

My server. No message. At the entrance to the server


Sorry I unfortunately did not save a backup of these files apologies for the long wait I quit playing for a long time and just now thought to check my messages if I come across the issue again ill be sure to send them your way


No problem, thanks for taking the time to post :slight_smile:

  1. Why is the DedicatedServerLauncher downloading ConanSandboxServer-Win64-Test
    path: J:\conan exiles\DedicatedServerLauncher\ConanExilesDedicatedServer\ConanSandbox\Binaries\Win64

  2. Make is so we can past Paths containing quotes in the “Mod List” eg. “J:\conan exiles\DedicatedServerLauncher\ConanExilesDedicatedServer\ConanSandbox\Mods\Jungle_Building_Set.pak”

  3. Make so we can set the ConanSandboxServer.exe manually and statically

  4. launch the server anyway even if it could not write to a read-only modlist.txt or ad an option to launch anyway.

  5. Separate “[ ] Don’t auto-update Server and Mods”
    “[ ] Don’t auto-update Server”
    “[ ] Don’t auto-update Mods”

  6. Server is 112258/20023 (no mods) and my game client is 112258/20023 (no mods), BattleEye and VAC is off on the server, still getting “incompatible version” error when joining it, please specify what the client is missing.

Edit: #1 and #6 is resolved, validated the installation


Since I just came across a reddit thread ( detailing how using the -useallavailablecores launch parameter helps server performance and I remember it being asked here before, I wondered if this was still on the to-do list somewhere? Seems like one of the easier things to implement.


From the thread:

++ Launch your server with the -useallavailablecores flag, AND be sure to also set the server process affinity such that at least one core is reserved for the OS. Do not do the former without doing the latter, or performance may decline instead of improve.

Adding the command line parameter is not difficult, but the affinity part is annoying because last time I checked it required to run the launch in admin mode.

Wonder if they are alternative ways to do that, maybe somebody wrote a tool that can launch other applications with custom affinity parameters, need to dig a bit more into it.

Now regarding @phyire questions:

  • #1 and #6 are apparently solved
  • #2 Does the game server actually accepts paths with quotes?
  • #3 Does that mean you want the tool to use your own server installation?
  • #4 May I ask in which cases would the modlist file be read only?
  • #5 is kind of difficult, the SteamCMD command line API is not super clear, when I tried that it did not update at all, apparently the order of parameters is super important, but basically I managed to update the server without updating the mods, but I did not manage to get the mods updated without the server

Basically I need more details about what you are trying to achieve :slight_smile: