Conan Exiles Dedicated Server Launcher (Official Version: 1.0.38 / Beta: -----)


Got it. Thank! What other innovations are planned?



How to change the name of the bot? it is displayed in the diskboard like this “Dedicated Server Launcher 1.0.24 BOT”



So, everybody, let summarize things a bit!

I’m going back to my family for the Christmas break, so that’s going to be the last version until 2019, hopefully I did not break anything, but if that’s the case you can just go back to the first post where every single version is still available.

About versions, we starts with the first version in June, and since then there’s been about 20 updates, including some fumbles here and there, but I think all in all it has been going quite ok, and just for memory sake here are two screenshots showing the evolution between 1.0.3 and 1.0.24

I can agree that the UI has become “quite busy”, on the other hand nothing is hidden, it’s pretty much all visible directly without having to hunt for sub menus or additional dialog boxes.

I’m not going to hide the fact that the code has become a bit ugly, and some refactoring would be welcome :smiley:

So in term of “what’s next”, the two next features that are planned are:

  • regular check of new version of mods in the steam workshop
  • making it easier for people to select specific rule sets for their servers (PVP, PVE, etc…)

I have some ideas on how to do that, but like the rest of the features it’s not my main job at Funcom, so thanks to my lead to let me spend three days this week to finish a few of these features that were started but not yet finished.

I’m probably not going to be looking much at this thread in the next two weeks, I fear my family would frown upon me spending my time looking at “work stuff”, so there you go: I wish you all a merry good time and see you back in 2019 :slight_smile:

@DemarumeRu You can’t, but feel free to write down a list of what you would like to see change (and how), I’ll take a look at it when I’m back: First the feature has to work at all, then we can make them work better.



Bad I can not. Merry Christmas. You are great. Health to your family!

1 Like


It works fine with me.
I was bored to pay Gportal every month so I downloaded 1.0.23 of your tool.
I changed the default ports so that I could run the client on the same computer.
Set up the port forwarding in my router and test ports was green.
Have to exit the steam app completely before running the launcher to avoid some error messages. Also put in some mods.
Started up the client and my server show up in the browser list and joined it perfect.

1 Like


Why when I put the number of players 40, does it change back to 30?



I keep receiving the following:



And after the above is complete, I receive the following:




The message in the white box, might be that you are running the client on the same computer. Exit the steam client completely before starting the launcher.



Hi! I use DedicatedServerLauncher1024

I have same problem and errors messages - mods are not downloaded, but run a regular vanilla Conan without mods

  • I use a dedicated server
  • steam client is not running
  • required ports are open

Anybody have idea about this problem? any solve?



Happy new year you all and especially TheToolGuy, many thanks for taking care of us with this wonderfull tool.

I have a question, not even a request for feature, what I would like to know is, if there is somone knowledgeable with Rcon (the Conan Exiles implementation I mean) could tell me if there is a way, a rcon command, that would let you send a specific message to a specific player via Rcon ?

(I know we can use rcon for general message, via any rcon client or this launcher, but here I would need to specifically send a special message to some players, like a whisp from pippi chat … a /w thisplayer mymessage )

Is there anybody that know a way or at least tell me adamantly that it’s NOT possible ?

Thank you in advance, and all the best to you all on this new year.

Edit : the “assertion failed” bug is unrelated to conan exiles and dedicated server app, it’s a steam workshop servers bug that have run errand like that for more than a year by now.



I’m back from holidays…
…quite many messages it seems!

Right now, I’m like: :thinking:
There must be an element somewhere, that we are missing.
Why did it work for you, and failed for many other (including myself…)

Do you have a fancy router, or multiple network cards, or maybe some VPN/Virtualization networking software?

Possibly a bug?

I’ll take a look at the code when I’m back at the office on monday.

This is correct, it’s also in the FAQ on the top post.

Just to do a test: Copy your DedicatedServerLaucher somewhere else on your disk, and start the process again, and see if it works: There are a certain number of known bugs in Valve’s SteamCMD tool, sometimes it crashes, sometimes it refuses to update, sometimes it updates but return error codes, etc… but in most cases it works fine on a clean install.

As far as I know, the only commands available are the ones on this page:

That being said, last time I looked at the code it did not seem very complicated to add commands, the person who implemented that did an extensible system with dynamically added commands, so technically it’s just a matter of adding one, should not be very difficult, probably a cross between “Broadcast” and “BanPlayer” :slight_smile:

And happy new year to you all as well



I am not using any special software, using a normal HUawei router.

But next day I got disconnected from the game and the ports in the launcher was red, when I clicked test ports it said port is locked.

I also tried to installed the launcher on my laptop but after a while I got a locked port problem there too, so it must be something else.
I only use 1 network card.



What does ‘’start up execute’’ mean?



What is startupscript?



It’s just some optional .BAT (Windows command-line shell batch program) script file you can run before the server gets started, can be used to do some custom stuff, if you want to backup, send some messages somewhere, etc…



I’ve got a strange issue. When I run the software “DedicatedServerLauncher1021.exe”, it opens up fine, launches an executable and then the window the says “close this window to shut down the server”. But during the process it kills my Ethernet adapter. I have to shut down and restart the server. I’m running windows server 2016.



We are getting some players on our server at the moment. We are running several Intel Xeon E5-2690 v2 processors (currently running 2 servers with 16 cores assigned to each), and a 16gb ram, but still the server window get (not responding) a lot, when there is 20-30 players on the server. We want to test if the server is smoother with 70 people logged in than it was in the summer before multi-core, but it seems that it is struggeling already… Ping in debug hud is between 100 and 500, and sever fps drops below 5, sometimes, but keeps at around 10-15. (is set to 30).

The server window and the server app window is often marked (not responding).

The interface is good imo. the more information the better…



Never seen that one before…

Could you try to start the server manually, without the launcher, to see if the problem is caused by something the launcher is doing, or if the problem comes from the game server itself? (The path to the server executable is written at the top of the UI)

Could you check if there is a lot of disk drive activity on the machine, as well as significant amount of free memory?

16 GB of ram is not actually a lot at all, and the memory usage of the server increases linearly with the number of players, so I could see a scenario where you start swapping physical memory to disk, which if it’s not a SSD would be dramatically slow.

We want to test if the server is smoother with 70 people logged in than it was in the summer before multi-core, but it seems that it is struggeling already… Ping in debug hud is between 100 and 500, and sever fps drops below 5, sometimes, but keeps at around 10-15. (is set to 30).

What type of internet line do you have on the machine, and which type of network card?
We found out that there was many motherboards with built-in RealTek chip which would start using a significant amount of CPU to process packets when the network traffic increased, to the point that even things like the mouse cursor would start to move around erratically.

The interface is good imo. the more information the better…

Good to know :slight_smile:

I’ve a question: Is the version 1.0.24 good enough to replace 1.0.21 as the new official version?



There disc is running constantly, so we can try to assign more ram to the server. The app used only 8 gig ram when we had 30 people on the server, but we have more available, so I will ask the server owner to get more. Maybe 64 gig. Will ask if it is possible to get a SSD also…

The servers is on a 500/500 line, will come back on what network card we have…

The Server runs on manly 2 of the 16 cores, but there is some traffic on 4-6 of the other cores.

The .24 is better than .21 imo. but haven’t tried the .21 with more than 4 people…