Conan Exiles Dedicated Server Launcher (Official Version: 1.0.39 / Beta: ----)

Ok, no complaints after two days: it’s now the new official version :slight_smile:


Apologies, meant to post this earlier. I try and test these deployments in a range of setups, and I’m still getting a warning executing the server app in Windows 8.1. It throws a Suspicious SW Flag when I run 1.0.15 – I noted it at an earlier version if you’d like to see how far back it might go. :slight_smile:

could you paste an actual screenshot of the error message, I’ll ask my colleagues how to fix that.
Maybe I could just sign the executable with the usual Funcom digital signature, maybe that’s not enough.

That being said, purely for curiosity any reason why you are on Windows 8.1?

I’ll capture a screenshot with the next launch. It’s a viable machine, and as a support professional I sort of owe it to my clients to run the environments they still maintain; I figured it was important for Funcom too. I also run CE servers on various client and Server platforms. :slight_smile: *

* Edit, updated to reflect other setups, as we have phased out most Win7

I also test the Server Launcher tool on Windows 7 :slight_smile:
Just that I don’t have any 8.1 lying around, it was very difficult to not have them auto-update to Windows 10!

It did take some doing – two of my clients run custom software written by another company that requires Win 8.1. In their business I suspect they will grind these PCs down to a nub before they get their money back out.

This is a composite of the message/resulting message – it fills the entire screen from left to right. The bottom message is what appears when you click More Info.

Digitally signed version works perfectly. No error message. Verified via txt on another machine/admin, thanks!

Sorry it took me so long to reply to this post I have been working on Website documentation for a site that I am building. But anyway to answer your question I have no other network adapter enabled other than the one i am using as multihome attached is some screen shots of the server tool , I updated to the 1.0.15 and it still worked as expected

Server launcher

and a screen shot of the server in the server list

I am able to connect and play the game on the same pc no issues not sure how it is working but as i said in my previous post my modem creates virtual servers for the port forwarding, not sure if that has anything to do with it or not. Just trying to help out where i can so others can have a great experience with the game as well…

if you need anymore information I’ll try to get it to you as soon as i can.

HI guys, I need some help here. I had opened the ports of my router and the firewall (windows and comodo) and today I see that the check is negative.
What’s wrong? I didn’t do anything

regarding the ports, not sure, the server was working the day before, and now it does not?

That being said, I have a question: Why do you run the DedicatedServerLauncher_1015_signed.exe from the “On Startup Execute” ???

If the idea was to start the tool itself when Windows start, you are supposed to enable the check box in the “Preferences” menu.

The place where you entered the executable name is to run some script or any program before the launcher tool starts your game server :slight_smile:

I’ve no idea what your setup does, but basically the tool is trying to start itself when it starts the server!

is there any way I can be sure that my server is discoverable to anyone through the game server list

I wish I could tell you there is.

The sad reality is that the whole “server browser” thing is a bit overwhelmed by the sheer number of servers there is around here, partly because of the Steam API struggling in updating the server status, and partly because the Unreal user interface is having problems handling so many entries as well.

I know it’s not 100% a Conan Exiles issue because even the Steam server browser is having issues where sometimes you can see your server for one second, and then it’s gone.

It’s not ideal, but the most certain way to be able to connect to a private server is still the direct connect using the IP.


I just would like to give my 2 cents of feedback/suggestion. Version 1.0.15 works like a breeze, everything works perfectly, I just have one little idea about the “nt updating at each server bootup/restart”.
Maybe we could have like, 2 buttons to start it, one “offline” not running update, and another just next to it which would do the updating. Both with distinctive icons on them representing the “online” or “offline” functionality. But maybe that’s just me finding stains where there are not, but, you know, OCD and all that.

Thanks for the feedback :slight_smile:

I just have one little idea about the “nt updating at each server bootup/restart”.
Maybe we could have like, 2 buttons to start it, one “offline” not running update, and another just next to it which would do the updating. Both with distinctive icons on them representing the “online” or “offline” functionality.

Not sure “offline” is a good word for something that is server related :smiley:

So, if I understood you correctly, we would have two buttons side by side:

  • One just start the server
  • The other just does the update (or does it do the update an start?)

The main problem here is that this removes one of the possibilities we have in the current system: You can start with the check box disabled, and at any time you can check it if you want the server to not update anything on the next restart.

Maybe a simpler solution would be to move the checkbox close to the on/off switch, maybe have it shown as a small image indicating if the auto-update is enabled or not?

But maybe that’s just me finding stains where there are not, but, you know, OCD and all that.

There are things that are real defects, and things that are actual personal feelings and impressions, these last ones still exist and have to be at least taken into consideration, even if that does not ultimately translate into actual changes for cost/benefit reasons.

As a tool programmer, what I often find out is that this type of feeling/feedback generally indicates that something does not feel quite right and should be investigated… but often the actual fix is not what was suggested or pointed by the person. One random example: People have been complaining about problems with the waterproof seal around the charging connector of cameras and phones, and suggested better ways of making the connectors or improve the seal… while an actual better solution was to replace that by wireless charging :slight_smile:


If people are suggesting cosmetics, it’s often a good time to put away the scalpel.

Your example of wireless charging is the perfect illustration of the conundrum of development. At first blush, it seems a fitting answer to fluids and juice; then after several months of use there are ghosts in the machine. The unknown properties of electrophoresis get into the mix, and it takes software engineers quite some time to nail this one down. Wireless charging is a practical innovation, so we may predict a net gain to the system. Just not necessarily to the innovator.

IOW, slap a fresh coat of paint on ‘er, Toolguy, this one is ready to ship! BTW I like it just the way it is, and from feedback, it has elevated many admins’ daily “grind.”

1 Like

This tool looks pretty good, but I could not get it to work for me. Below is my experience with it last night. I previously had a server running / setup using the manual method 6 months ago.

I stood up a new Windows 2016 server in Azure.

Downloaded the app and put it in c:/conanapp

Ran the app and started filling out the info.

The thing that confused me was it is not clear that this app will actually install steamcmd and the game server. The installation section could use some work to more clearly show the install step or more clearly state this app will install steamcmd and the game server.

“Then, you just run the program and edit the parameters you want, save the changes, and hit the switch. Everything should start running smoothly!”

I clicked the disk icon and all it did was save the config and nothing else.

So I figured it required me to have steamcmd and the server install already, so I proceeded to install steamcmd and then the server as before. Then re-ran the app and it kept telling me it could not find the path to the server or something like that.

I tried putting the app in the steamcmd folder and same result, server not found.

I tried putting the app in the server folder with the conansandboxserver.exe file and still told me server could not be found.

I gave up at this point and finished setting up my server manually.

What interests me the most about this app is the mod install and updating, but oh well. Maybe add an option to provided the server path to the tool if you already have one installed.

Ok, so to be clear, it’s not running on a physical machine, but on a VM running on the Microsoft Azure infrastructure, correct?

I have to admit I never tried that, did not even think anyone would do that :slight_smile:

Yes, the program is supposed to install SteamCMD and download the game server all by itself.

It’s not designed to work with some previously installed server configuration, but it’s perfectly fine to overwrite the config files and gamedb with your own older files if you want to restore a previous server.

I guess the problem started there: If you started from absolutely nothing, the tool should just have generated the various ini files in a subfolder of where you installed it (C:/conanapp), and then installed CMD, then launched SteamCMD which in turn would have downloaded the game server.

If that has failed, maybe we can find some information in the DedicatedServerLauncher log files?

Please check the content of
C:\conanapp\DedicatedServerLauncher\Logs for anything interesting

Normally after just saving, you should have this folder structure:

  • C:\conanapp
    • DedicatedServerLauncher1015_Signed.exe
    • DedicatedServerLauncher
      • Logs
      • ConanExilesDedicatedServer
        • ConanSandbox
          • Saved
            • Config
              • WindowsServer
                • Engine.ini
                • Game.ini
                • ServerSettings.ini

also, at this point, you should not have a SWITCH icon, the icon at the bottom right should look like a Floppy Disk over a CD Rom with a green plus icon.

If you have a switch, it means the software is installed.

Could you maybe zip your entire C:/conanapp folder and share it somewhere so I can look at what happened?

The behavior your experienced is not how it’s supposed to behave, but at this point without more details it’s hard to know what the cause is.

I actually did a test with Azure:

Took a bit of time, Internet Explorer nagged me with the security level, refused to download the executable, but after a bit of Safe Zone Persuasion ™ it finally accepted the download.

I copied the file to a newly created c:/conanapp folder and ran the program, setup some server name, password and admin password, pressed Save, and then clicked on the install button, and as expected SteamCMD populated the folder (you can see on the screnshot) and then started downloadiiinnnnnggggggggg veeeeeryyyyyy sloooowwwwllllyyyyyy… but ultimately got it all… and it failed with the dialog which was mentioned by @Grey2142 earlier:


(Which confirm it’s not actually the Dedicated Server Launcher but the game server itself having these requirements)

So, I’m not quite sure what the problem is, could be some configuration issue, anti-virus, SteamCMD failing to auto-update, etc… without more details I fear I can’t really do more.


1 Like

No problem. Thanks for checking into it. I don’t have that saved anymore as I went with the manual install route and got it all working. I am not sure what the actual icon looked like anymore after filling in the info, but once I clicked what ever it was in the lower right it did save the config files but then nothing else happened. Could be that since I didn’t have the ports opened on windows firewall that it could not connect out to grab the files? I had configured the firewall in Azure, but not inside of windows itself at that point. Maybe I will give it another try. yeah I also has to manually install directx and C++ 2015 runtime.

yeah, Azure is kind of a pain with all the IE restrictions it adds. I first grab firefox and then it makes it a lot easier to download other files. I get a free MSDN account through work, so it lets me create a pretty good VM and run it for free.

thanks again.

I just tried it again and it is working as you described. Only thing I can think of is that since I did not have 7777, 7778 and 27015 opened in Windows Firewall that it did not pass that check and then did not do the install.

Thanks again