Conan Exiles Dedicated Server Launcher (Official Version: 1.3.1 / Beta: -----)

Thx so much!!! My server and Up and running under the new Siptah Map!!! :0)

I got this with certain mods.

v1.2.3 Luancher working fine for me with small batch of 15Sept2020+ Mods. Looking forward to simple button click for map rather than .ini editing but its working.

Updated to 1203 and the server launches fine. It is even displaying properly in server selection. After connecting to the server I am stuck on a loading screen and cannot create a character to enter the world. I have green lights across the board for connections. Same issue whether or not multihome is selected. Any ideas on what is happening?

edit = This appears to be a “Pending Connection Failure” issue with the server browser showing a ping of 9999. I’ve gone through every troubleshooting step I could find online without success. This includes reinstalling the server and reconfiguring ports and firewalls. I have also reinstalled battleye and the game on the client computer. Still getting green lights across the board showing open connection on the server, but unable to connect. my friends can connect to the server without issue from across the country however I cannot connect from ten feet away =/

I have a question about the new map, is it possible to upload it to the server?

Launcher v1.2.3. I have a problem. The server on the new map is either not displayed in Steam or does not respond at all. Also, I cannot change the number of players in the launcher. Doesn’t save. After the restart, everything remains the same! Tell me what should I do?

New day, new version.

I still have plans on adding an easy to use selector to choose which map to play on, but I’ve prioritized things that can help people diagnose problems more easily, so here is are the changes:

1.2.4 (17 september 2020)

  • Fixed an issue with the ini file parser which would not properly remove duplicate entries in the ini files
  • Added a new “Errors” tab, which only lists the server log lines containing the “:Error:” pattern
  • Added a new “Players” tab, which only lists the server log lines containing the “Join succeeded” or “ChatWindow:” patterns
  • Added alternative tooltip description for the log output depending on which tab is selected
  • The currently running map name is now displayed in the title bar
  • Found out that the crash reporting did not work: Neither the log file or crash dump were sent, hopefully should work now
    Dedicated Server Launcher 1.2.4

and here is what it looks like:

Displaying the name of the map, is mostly to allow people to quickly see if they are running what they think they selected, the two new tabs are mostly filters on the main view to make it easier to see if there are problems in general, or specifically when people try to join - successfully or not -

Now, regarding the questions and comments:

That’s not server launcher related, it’s a known issue on the server browser/kds/fls system, it’s being worked on (some people are trying to figure out what the issue is), but it’s not my department, I’m only concerned by Dedicated Server Launcher related issues.

Also, I cannot change the number of players in the launcher. Doesn’t save. After the restart, everything remains the same! Tell me what should I do?

Could you check the “LogInit: Command line:” in your server log, normally you should have some “-MaxPlayers=xx” entry in it. Also check your “game.ini” and look for [/Script/Engine.GameSession] MaxPlayers, and check if the values make sense and if there’s only one entry in the ini file.

I’m not sure what you mean by that :slight_smile:

Also for

Deathdog The map is available by default to the server, it’s just a matter of selecting it, which at the moment means adding this to your Engine.ini:

[/Script/EngineSettings.GameMapsSettings]
ServerDefaultMap=/Game/DLC_EXT/DLC_Siptah/Maps/DLC_Isle_of_Siptah

Have you tried to use the local ip of the machine, since you are on the same local network?

That’s coming “soon”.
I’m trying to handle the list of issues before adding features.

Define “Before”: are we talking “last week”, or “a few months ago, before the EGS/FLS big update”?
There’s been a ginormous amount of network related code change in Conan Exiles, many things are working much better for many people (like for example, for the first time EVER, I was actually able to see my own server on the server list, never happened with the old code), but now and then, or for some people in specific cases, it gives things like 9999 ping, etc… and the team is trying to address these corner cases when they manage to identify the issue.

Is it vanilla server, or did you add some mods?

  • If it’s a non modded server, the message is probably correct, so try to click on “Validate Server Installation”
  • If it’s a modded server, it most probably caused by mods not being updated to the new version of the game, so either remove the mods or wait for an update

There’s a known (recent) issue with the Steam Query Port, for some reason it does not get properly detected by the game, so if you don’t want to use 27015, the current solution is to pass it as an additional Command Line Parameters:

-QueryPort=xxxxx

The Dedicated Server Launcher does not support editing the game specific settings, you can set all these values in the game itself using the admin panel.

3 Likes

In May-June 2020

Try “Direct Connect” button in server browser and use internal IP, it helps me to connect to my server on same PC.

In May-June 2020

Yeah, so before the EGS/FLS version, that was using the Steam online subsystem.

The new version is using the same internal servers are were used for the consoles versions, and the reason for the change is that the Steam server browsers had hard limits on the maximum numbers of servers it could handle, which is why some servers never appeared on the list.

Hopefully at some point it will all be working fine, cross fingers :slight_smile:

Hi,

I’m having difficulty with the RCON setting. When enabled via the DSL, it creates the game.ini configuration “RconEnabled=True”. This does not seem to enable the RCon service on the server. I have to manually edit the game.ini file after every “save changes” to switch the syntax to: “RconEnabled=1”.

Toolguy, you got to do something with that mod list window box.
It really is clunky in that horizontal format and having a small window requiring a scroll over.

Anyway you could sexy it up with a new layout, drop down, popout window and possibly have it allow you to hover over the mod and it shows you the name of the file within.

I don’t know about you though I haven’t memorized the mod ID numbers…

thanks

I’m sorry, but can you provide a link, who can I contact for help in this matter?

Could you open your server log, and search for rcon, and things like that: “Rcon listen socket starting up using listen port 27104”, or “Rcon is ready for client connections on…”, “Rcon disabled” or even “Could not enable Rcon, no chosen Rcon password”.

We checked the code and unreal has a function that accepts True, Yes, On, 1, False, No, Off, 0 as valid values understood as booleans, and I did a check here, with my RconEnabled set to True, I do get “Rcon is ready…”

There’s an issue somewhere, but “True” does seem to be a valid value.

If some other people have any idea regarding the topic, please feel free to share.

Not sure if you noticed, but I’m adding tabs at the bottom, the idea is to improve the UI over time, but important things go first.

Right now I’m more interested in making sure everybody can use the system, that all the weird configuration issues are fixed, that’s also why I shelved the changes to select the map name, right now it’s less important that making sure that the correct ports are working properly for everybody.

You could join the Admin Discord channel to see if anyone could help you with diagnosing the issue.

I could only find:

“Rcon disabled”

I would enter an rcon password, and check the enable box. If i clicked on the game.ini tab I would see RconEnabled=True. Hit save, launch server. Then the entire rcon config would get wiped out and removed from the game.ini file.

" RequestAsyncLoad called with empty or only null assets!"
What does this error mean?

Its all fine currently.
I merely meant that i forgot to change off the port as recommended if you want to launch steam on the same machine and do the not too recommended part of playing conan also on. I changed it as i made the edit entry.

Currently the server works mostly (in acceptable range) good.

I just noticed the backup doesn’t handle whitelist.txt. It would be nice to add that, and maybe blacklist.txt aswell.

Ok, I’ve never seen that one, could be quite many things.

Could you try an experiment:

  • Make a new folder somewhere on your machine with just the server launcher there
  • Set the Rcon Enabled checkbox and Save
  • Verify that the Rcon values in the game.ini tab are all correct
  • Deploy the server
  • Check that the Rcon values are still there

Basically I’d like to know if that happens to you also on a vanilla server with any changes or if the issue is a consequence of having had multiple updates, etc…

Well, hard to say, these are messages from the game server, and even when running fine it outputs a lot of scary warnings and errors, and it get even worse when servers get modded, the art of “server administering” is to learn which ones are scary and which ones are “fine”.

The dev team is trying to clean up the errors, but there are still quite many.

Cool :slight_smile:

That’s a good point, thanks for pointing it out.

1 Like

Another version, the focus was to help diagnose problems (there was reports of mysterious “can’t save” and “port failed”, so I added some error messages).

1.2.5 (18 september 2020)

  • The dedicated server launcher log files (in the /Logs subfolder) will now clearly indicate which ini file failed saving when it happens.
  • The backup code now also handles the “blacklist.txt” and “whitelist.txt” files
  • All restrictions on the maximum number of players have been removed, that does not mean your server will manage to run with 150 players, but if you want to try, you now can
  • Add the server PID in the title bar, can be useful to locate the process to see which port it uses in NETSTAT, or to simply kill the process
  • Modified the “Test Port Accessibility” to give some proper diagnostic on what did go wrong: TimedOut, could not bind the port, …
  • Added a new “Mods” tab, which only lists the server log lines containing mod related stuff
    Dedicated Server Launcher 1.2.5

Hopefully, if no major issue is found, I’ll have the “map selector” in the next version next week.

7 Likes