Conan Exiles Dedicated Server Launcher (Official Version: 1.3.1 / Beta: -----)

Struggling after the last update getting the “The match you are trying to join is running an incompatible version of the game. Please try upgrading your game version.” issue.

As far as I can tell I have the latest of both game and client - 1.2.5 server, Revision (#246072/26452) of game.

Server log mismatch line is:

LogNet: NotifyControlMessage: Client connecting with invalid version. LocalNetworkVersion: 2005681914, RemoteNetworkVersion: 2015823700

Any advice?

In the case where mods no longer work, what is the process for clearing the modlist? (Cleaning Mods folder and modlist.txt — keep respawning).

Used pastebin to try to keep the thread clean. Fatal error and crash when I try to connect to the server.

Ive spent probably 5+ hours to figure it out via searches, updating to the newest launcher, restarts and reboots, disabling mods, etc… Didnt start until IoS release just this week. Worked flawlessly up until IoS. Its hosted on a PC connected directly to out modem, and Im playing on a PC wired into a seperate router.

Thank you for the the tool and for your time.

Good afternoon!
Through the search, I did not find any mention of this problem, so I am writing here.

Problem: There is no “Enable PvP” item in the server settings menu.
It doesn’t depend on the version of the launcher. Apparently with the update they forgot to turn on the button interface or something.

Solution: manually set the value “PVPEnabled=True” in “…\DedicatedServerLauncher\ConanExilesDedicatedServer\Saved\Config\WindowsServer\ServerSettings.txt”

I’ve tried several versions including a clean install. The result is the same.
If you create a cooperative game (through the game), there is a menu item. If through the launcher, it is not.
Here are screenshots for visualization.

Screenshort


Have a nice day!

Do you have the same numbers displayed on the bottom right of the main menu in the game client?

If the modlist.txt file is not read-only, normally it’s just a matter of removing the mod numbers from the “Mod List” field in the launcher, then Save Changes and restart.

Please note that removing mods can cause issues, like building collapsing (if some additional building blocks were handled by the mod - stability loss), etc… so back-ups are highly recommended so you can revert back to the previous version in case of issue.

It is quite rare that updating the launcher helps with game issues: The launcher is just a fancier way to patch ini files and run SteamCMD, but it does not do anything magic that you could not do by hand.

Script stack log unavailable (DO_BLUEPRINT_GUARD_BASE==0)!
Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000000

It’s a generic error, if you are using mods it’s probably caused by a mod which was not updated, in which case I would suggest to do a full backup of your configuration, and try to find the mod causing the problem - which can take quite some time -.

Interesting, I’ll ask someone if they knew about it.

2 Likes

Hi,

I was wondering if someone might be able to help me out, I tried to set this up and as far as I can tell everything was done right, but when it is running and I launch the game it says it can’t connect to the game servers when the main menu first loads and in steam if I open up the servers window and try to find games at the server address it just reads “Server not responding”

Thank you.

For some reason I am still not able to connect to my server and it is showing a 9999 ping. I have port forwarded the proper ports and the port test was successful. On the game machine I have turned all of the firewalls off. I do not have any mods installed on server or client. I have ensured the versions are the same. What else might be causing the ping issue and preventing me from connecting?

Use the local IP address to connect. You can’t connect to the same public IP address you are NATting from.

1 Like

The map selector is finally in the version!

The reason it took so long is that there were some bugs found here and there, some missing features in the backup category, and the dedicated server and the launcher were not agreeing on the format for some of the data strings written in the ini files… which lead me to add a new ini file specially for the Dedicated Server Launcher.

While I was at it, I gave a shot at making the .ini file tabs editable, which may or may not work very well, but as indicated, this is experimental.

1.3.0 (21 september 2020)

  • Added a combo selector to choose between the various maps that can be played on
  • Added a new “DedicatedServerLauncher.ini” file, with its own tab, for the Dedicated Server Launcher settings, to avoid conflicts with the server rewriting ini files
  • Moved the “Branch” and “User” settings from “ServerSettings.ini” to “DedicatedServerLauncher.ini” to avoid problems with passwords disappearing
  • Fixed an assertion related to the Steam Login username not being set in some cases
  • When changing branches, users or map, the launcher now clearly indicates the reason for the change
  • It is now possible to modify the ini files directly from the tool, use CTRL-ENTER to insert new lines, and CTRL-S to save [EXPERIMENTAL]
    Dedicated Server Launcher 1.3.0

Now let see the questions:

I assume that when you Test Port Accessibility everything is green?

If you are on the same local network, try what @Zabran suggested and use the local IP of the machine instead of the external IP.

3 Likes

It’s maybe not a dedi launcher issue, but it does occur with people using it.

There is no field to set the server files location. i have just updated from an earlier version where my files are all set in the root of my drive c:/conan/…

@Toolguy

I get there’s more pressing things in a mechanical way though consider some of those are also not needs, they’re wants by yourself.

As a user I am advising that an existing feature can be vastly improved. Is it a need, no, however part of the process is meeting user desire/demand.

How about a simple CTRL +F in the mod box, then we can at least find the mods without staring at it so long it becomes like one of those 3D puzzle images.

Some anecdotal commentary :
After the recent updates, about fifteen mods were corrupted (as they were not updated). It took hours going through and testing and checking, and testing.

Being able to quickly find and update the list would have been a huge help

I’m having this message myself, had it for a while, did not impact my ability to connect to the server, but just to be safe I’ve asked about what it means.
Stay tuned.

This is covered by this section in the documentation.

No they are not “wants by myself”, they are things that helped me diagnose issues encountered by other people.

I was not ignoring you, which is why in 1.2.5 (18 september 2020) I added a tab showing the content of the server log section about loaded mods.

This is not quite what you wanted, but that at least solved your question of “which number matches which mod”, since the number is part of the filename path, and with CTRL-A + CTRL-C it’s easy to copy the content of a tab to have it in another text editor.

Something “as simple as CTRL+F” is not simple at all, the simple way was to:

  • CTRL+A + CTRL+C the content of the Mod List field
  • CTRL+C to a real text editor
  • Edit things
  • Copy paste back to the Mod List
    definitely not ideal, but you don’t have to do the edition in the tiny mod box

The reason I’m not evolving this thing is because that would be a waste of time, since the plan is to promote the mod system to a real list with reordering, display of update time and dates, status, enable and disable easily, etc… no point fixing the edit field, that would take hours better used for other things.

This is called iterative development.

1 Like

That did in fact work. Thank you for the quick help guys, I really appreciate it. I didn’t realize that I had to use to the local IP if on the same network even with separate host and gaming rig. How might this be effected if I enable Mutlihome IP? Also, other players outside of my network should still login using the external IP when Multihome IP is disabled, correct?

1 Like

Question for you people: 1.1.2 is still the official version, but it has some known issues (like the crash when loading older ini files that was fixed in 1.2.3).

For Siptah I pushed many 1.2.x betas, and yesterday version 1.3.0 with support for the map selector.

So the question is: Which version do you think I should push to Official status, has anyone encountered issues with 1.3.0? With 1.2.5?

Asking for a friend :slight_smile:

I’m using 1.2.5 and having seen any issue with it.

2 Likes

Thank you so much for getting back to me.

Everything was green when I tested port accessibility, but I did made a silly mistake when setting it up and everything seems to be working now.

1 Like

Yes, it has the option to always update during the restart or always update in a period that he sets to look for mod updates, where ite finds himself and does the update normally when restarting

1 Like

SERVER LOAD SLOW

I am using Conan Exiles Dedicated Server Launcher (Official Version: 1.2.5)

I have a problem, I have searched forever before posting as not to aggravate anyone lol.

I run a personal server on a i7 octa-core setup with 16 GB of ram on a 480GB ssd drive, all available cores selected.

My server when reset takes about 18 minutes to load up and to be able to log in, other problem is the high ping with 16 players or more (only players from my country can join).

The question is i keep seeing these message in the server window “LogClass:Warning: Skipping saved property BonusRecipes of ThrallInfo since it is no longer serializable for asset: FMemoryReader. (Maybe resave asset?)” and “LogPackageName:Warning: Please consider resaving package in order to speed-up loading.)”.

How to resaving package ???

Does anyone have an idea what or how i can accomplish this? or figure out why i am loading so slow. Before, the server loaded in 3 minutes only.

Any Ideas would be appreciated thank you.

Not able to find this elsewhere, but real simple problem.
The launcher loads great, however no matter what steam query port I specify, the game starts up with 27015.
The Game client port, raw UDP port and such are set and actually reflect the setting.
I also verified in the engine.ini file that the Steam Query port be set correct and it is.
So I am looking for the start bat (found one and added the query port manually, but did not change the outcome).
So is there any other spot this setting is? What explains why the server always starts with default query port 27015 vs whatever I set in launcher or ini?