Conan Exiles Dedicated Server Launcher (Official Version: 1.3.7 / Beta: 1.3.8)

It’s a bug(+). You need to add the following to Additional Command Line Parameters: -QueryPort=*****

(+) Toolguy edit: It’s a bug in the game server, not in the launcher, and the bug fix has been submitted, just not sure in which version it will be released

1 Like

Thanks for the feedback Wig. I see I should have added it in the launcher verses trying to find the actual launch script. Looks like that did the trick. Thanks.

So, by popular vote, version 1.2.5 is now the official version - replacing the old 1.1.2 -, but please give a shot at version 1.3.0 improvements!

:+1:

Do you have many mods?

Does anyone have an idea what or how i can accomplish this? or figure out why i am loading so slow. Before, the server loaded in 3 minutes only.

I’m not quite sure, but you could ask on the Admins discord, probably some people there have encountered this exact issue and know what to look for.

As answered by @Wigloaf , until the game server is fixed, you need indeed to use -QueryPort=xxxx

I am using the 1.2.5 launcher and am running into issues testing the port accessibility. I have opened the ports 7777, 7778, and 27015 in my firewall and in my router settings but it keeps saying that it was unsuccessful. Is there anyone who might know what is going wrong?

Since it’s 1.2.5, you get the improved error diagnostic message, what errors do you get exactly, time out, socket error, …?

Regarding firewall and router, I assume that:

  • Your ISP allows for port forwarding (some makes it impossible)
  • You’ve setup a fixed IP for the server machine (so it does not change if you reboot)
  • That on the router you’ve forwarded ports 7777, 7778 and 27015 in both UDP and TCP to this fixed IP
  • And that on the firewall you’ve given full access to the launcher (generally to troubleshoot, I shut down the firewalls completely to be 100% sure it’s not a firewall on the computers or router that blocks accesses)

I get the error “Timed out waiting on data from localhost:7777 UDP”, “Timed out waiting on data from localhost:7778 UDP”, and “Timed out waiting on data from localhost:27015 UDP”. I have both TCP and UDP ports open in my router and firewall.

I used to host a multihome server a while back and decided to start it up again with the release of Siptah. However whenever I try to connect, the server will crash and I’ll receive this error:

SourceServerQueries:Error: SourceServerQueries Socket closed unexpectedly

I’ve tried to look through the logs but that is the only error being displayed. I’ve opened additional ports, disabled multihome, checked the server settings. Nothing is standing out and this was the same setup I had running several months ago without issue.

Any suggestions? Thank you

Good afternoon!

I am facing a problem. The server stopped sending messages before restarting. No pop-ups or chat messages. Restarting after finding updates also does not send a warning.
v1.2.5 =\

So when trying to connect through the in-game browser to my (in-house) server, I checked the logs and its line after line of “LogNet: NotifyAcceptingConnection” with the client IP afterwards until it just times out and disconnects completely. Any insight on what’s causing this? The error log was just spawntable stuff so I didn’t get any insight there.

Could you take a screenshot that shows the following:

  • Your complete dedicated server launcher UI with all the parameters visible
  • The firewall UI showing what you changed
  • The router UI showing what you changed

also, if you could give me the brand/model of your router and the name/country of your ISP, that could help narrowing down the issues :slight_smile:

Do you get a .DMP file somewhere inside your Saved/ folder?

Is that just using RCon, or also Discord webhook?
Could you try to just type a message and press “Send” to see if that actually work at all? Could be an issue with the RCon port not behaving as expected.-

There’s a known issue where on some setups, connecting on a server from a machine on the same network does not work, but using direct connect with the local ip of the server would work.
Could you try that?

Hey . First, I would like to thank you for the cool program that makes the life of server administrators a lot easier.
There was a problem: the launcher stopped sending warning messages about server restart to the game and to the discord. I am using version 1.3.0

Ok, so with @SaIInS (using 1.2.5) you are the second person to signal such an issue, could you confirm if it’s only the restart/update messages, or all the messages (like the “Send” button does not work at all)?

What could help is if you could try the earlier versions and find which version seem to have broken the warning messages.

automatic messages do not work. Messages written and sent manually are sent to the server, gamers can see it, but they do not reach the discord channel. Automatic restart messages are not sent to the server and are not sent to discord.

I’ll try to use version 1.2.5 again, I’ll write about the results later.

I couldn’t find one, I ran the server again to recreate the error and no .dmp file was generated.

I have aslo got the error “Timed out waiting on data from localhost:7777 UDP”, “Timed out waiting on data from localhost:7778 UDP”, and “Timed out waiting on data from localhost:27015 UDP”. I have both TCP and UDP ports open in my router and firewall.

Direct connect is the ONLY way we’ve been able to log into the server. It’s annoying.

Can Confirm, BUT I do get the Discord messages just fine via the discord setup, I do not get the messages sent to the server via rcon, I have tried both broadcast and server and I am using pippi mod
but no luck or text either way uning 1.3.0

Messages on the server started working for me, I did nothing, I just removed the dots in the message and clicked the save button. But discord messages still don’t work.

Anyone know if you can set this up on a server that is already functioning, because I have tried so many ways to get this thing to work and at present it does nothing, it will not find the server, it will not connect to the server and it’s just driving me nuts.

I recently replaced the Internet, since my server appears with IP9999 and it is not possible to enter it, can it help to solve this problem? In the launcher the doors are all in green the configurations in the ruter too.