Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

Hi Toolguy,

Thanks!

I’m running the server on a different machine, in fact it doesn’t do anything else than running the server for Conan Exiles.

This machine has a fixed IP, it’s on the same network as the computer I’m using to play.

Yes I meant port forwarding, I have created two separate entries, one for UDP and the corresponding ports and another one for TCP with the corresponding range. Should I open all the ports on UDP and TCP? Port forwarding is only set for the fixed IP of the server, I guess I don’t need to open it on all internal IPs? I have also created inbound rules on the firewall + I also allowed the server application to communicate with the external world, I have also tried to switch off the firewall but it didn’t help.

Thanks!

There’s a known issue there, where in some cases computers on the same local network are not able to connect using the external ip, but can when using the local ip (that means “using direct connect”)

Since port forwarding does not see to work for you, could you give me the exact name/model of your router, and which ISP/country you are are using?

Thanks again for your help!

I have tried direct connect too but I don’t get beyond the pop-up where I have to enter the IP + password while choosing the server from the list brings me to the loading screen.

I’m using a Netgear r6400v2, I’m in Belgium using VOO as network provider. I have found a site with a step by step configuration tutorial for this router but I end up in the same situation. There might be some other option somewhere else that needs to be triggered but I haven’t found any additional information about this.

It’s IP:PORT + Password, you need to specify the game port after the IP

I’m using a Netgear r6400v2, I’m in Belgium using VOO as network provider.

Somebody suggested to reset the router: https://forum.voo.be/conversations/ma-connexion-internet/port-forwarding-ne-fonctionne-plus/5e53e4814cf00d702bf74068 (from 2019)

Based on what I read, it looks like contacting VOO’s support could be a good idea, apparently some people have a configuration that does not allow port forwarding:

https://www.informaticien.be/forum_topic-6866--VOO__pb_avec_NAT_.html (from 2013, so a bit old):

Les abonnements domestiques, pour les petites formules portent le doux nom de CGN,
En clair, ca veut dire double NAT.
Il t’est donc impossible de sortir en VPN, ou de router du trafic de l’extérieur vers l’intérieur.
Ce qui dans ton cas t’empêche de router le trafic externe vers ton port 80 vers l’ip interne de ton serveur Web.

Donc, d’un point de vue technique : Oui tu as de l’internet donc pour le brave gars au support, tu es un idiot qui ne sais pas faire de NAT.

D’un point de vue pratique, le flux n’est possible que dans un sens; ce qui ne t’arrange pas.

Afin de résoudre cela : appelle le support Voo et tu leur dis que tu es en CGN et qu’ils doivent changer cela; ca demande 5 min de config chez eux et le reboot du modem.

Hi Toolguy,

Thanks for the additional info!
I have tested some other elements that would rule out any issue with VOO.

I have installed the server on my Surface tablet (win10) to try something else:

  • Surface Pro + Netgear + VOO => all ports are red
  • Surface Pro + VOO Modem + VOO => all ports are red
  • Surface Pro + 4G modem => all ports are red
    I also added rules to my Windows 10 firewall but it didn’t help

So unless I have really bad luck with my two network provider, I’m back to square zero. :frowning:

any idea left in your magic hat?

I would just contact the VOO support and ask them :slight_smile:
I’ve never done port forwarding on a 4G modem, I’ve no idea if that’s actually possible.

side note: many ISPs don’t allow modem/switch/access point configuration, you have to contact support with such request
unless of course you use private devices

1 Like

The only recommendation I really have is that the docs should probably contain more detailed information about how the server settings are configured via the .ini files. Where are the different .ini files located. What the different files do (the more important ones anyway). How the tool itself behaves in that it adds values to the .ini. How the server behaves in that it removes lines that are set to default values. A more clear link to a full list of the values. That sort of stuff.

The vast majority of problems I had were with configuring the server settings, and while in the end my biggest problem was caused by user error, the overall experience was very frustrating at first.

Eventually I figured out what I needed to do, and obviously others have as well. The discord is super helpful, but I feel that having all of the relevant information in a single location would be very helpful.

1 Like

This will probably change in some version not that far down the line: I had way too many problems with values disappearing, which is why I introduced the “Launcher.ini” where I will start migrating the values, and they will be the “authoritative ones”, which I will keep as a base to update the actual game server ini files.

When that’s done, I’ll documenting that :slight_smile:

Hi Toolguy,

Thanks but my 4G solution is not using VOO, it’s a totally different network. I have tried to use multiple phones in 4G and I get the same result. There is no port forwarding as there is no router involved, you directly connect to the network.

Could the server work with other ports?

thanks

Well yes, some people are running more than one game server on the same physical machine, each game server use a different set of ports, and each set of port is forwarded on the router.

Hi, I am trying to boot up a server for the first time using 1.3.1 and have set up everything, and everything seems to download correctly but when it tries to launch the server it say all of the mods are out of date and doesn’t launch. I can see that the mods were just downloaded for the first time and on steam can see that at least some of them have been updated today so an outdated dev-kit version shouldn’t be the problem for all of them. Does anyone know what I did wrong with my setup? Thanks.

it lies
I mean, this feature need a little work, but if your server won’t start there is probably issue with one or more mods

thanks, I suspect its one of the mods that haven’t been updated to the new release then. I will wait until the weekend after they have been updated and try again.

So just to touch on this, mine is doing the same but we are running 1.3.0, should I update to 1.3.1 and see if that works? Multiple mods updated last night

All servers with MoDs are having this issue as far as I know.
I have not heard of any fix on the way, or any information at all on this issue. Would be nice to hear some one let us know what’s going on.

@Frostie @Eldin89 the message you are getting is from the game itself, that has nothing to do with the launcher version you are using (the only place where the launcher is involved is the detection of updates, which may or may not be working as expected)

When you launch the server from the launcher, what happens is:

  1. The launcher starts SteamCMD telling it to update the server and the list of mods
  2. The server is started
  3. The server checks the mods

The point 1 only happens if you have setup “update on startup” in the launcher, else it skips directly to 2.
The point 3 is something recently added by the dev team to limit the compatibility issues between the game and mods and still being worked on.

So just to touch on this, mine is doing the same but we are running 1.3.0, should I update to 1.3.1 and see if that works? Multiple mods updated last night

If you look at the Release History the only difference between 1.3.0 and 1.3.1 is:

Fixed a bug introduced in version 1.2.5 with the “Test Port Accessibility” showing grey instead of red lights for errors.

Updating will not hurt, but it will not change anything to your mod issue :slight_smile:

Ok, First of all thank you. Not only for the information, But just for responding. After a bit of work I managed to get our server up and running. Once again Thank You.

1 Like

May I ask how you fixed it, it seems I still have the same problem.

Follow Toolguys information from above, Make sure you have it set to “auto update on restart” and I also checked the “validate server installation” for the first restart. If you still are having the issue then its one of the mods in your mod list is not updated and causing the Issue. We had to remove DyeMoreBetterer . Ran a little laggy for a bit then stabilized and is running fine. Good luck, Hope this helps.

1 Like