Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

As @drachenfeles wrote, this is a part of the game/balance changes the Exiles team is doing, that has nothing to do with any settings on your side or that the Dedicated Server Launcher is doing.

Glad you managed to get it working :slight_smile:

@Tovan_MacKelly @Sulvix The team is tying to come up with solutions to make mod issues easier to diagnose and fix, but yeah at the moment it’s a bit painful, sorry for that.

isn’t there a way to set the server to auto restart if it recognizes that the game has been updated?

That’s on the top left: “Check for Updates and Restart” and the number on the right is how often the check is performed (default is 00:05 which is “every 5 minutes”).

You can also click on [?] to show you the current state of what you have installed and what the current versions on Steam are.

1 Like

thx a lot

1 Like

Hi all,
Can someone help me with a problem? You can have the restart/shutdown reported in discord. How do I do it ingame? So that the players learn ingame about the restart.

1 Like

For that you need to have RCON working, which means:

  • Enable the RCON checkbox
  • Have a valid RCON password
  • Make sure the RCON port is not used by something else
  • Use “Broadcast” if you are using a vanilla server (will show a big message box dialog)
  • Use “Server” if you have Pippi mod installed (will show the messages in the chat instead)
1 Like

thx a lot =) it works

1 Like

Hello, i need some help. I made a dedicated server using this tool. I can see the server in the online tab and i can conect using Direct conect but a friend of mine cannot, it says timed out. i don’t remember if he used the external IP address and he has to use the external IP what numbers needed for the port ? the 7777 or the 27015 ?

Do you get all the green lights when you test the ports?

Normally friends of yours (outside your local network) can just use the server browser list in the game - assuming the port forwarding is properly done, and that all the firewalls are properly setup as well.

Thanks for the replay Toolguy. Hm, the 3 ports lights are red now that i pressed the test port button :frowning:
since i can’t upload the image as a new user i will try to write down what my router port forwarding is ( hope it helps)

Protocol : both
WAN Host Start IP Address : blank
WAN Host End IP Address : blank

WAN Start Port : 7777
WAN End Port : 7778
LAN Host IP Address : (it is the same as in the launcher under network config )
LAN Host Start Port : 7777
LAN Host End Port : 7778
I don’t know if and where i should use the steam query port

You do need the three ports forwarded, in both TCP and UDP.

Ideally you want to make sure that will never change, so whatever router you are using, make sure to not use DHCP for this PC but instead to associate the IP to the MAC/Hardware address of the network card of this machine (it’s displayed on the network section of the launcher, with a small button to copy the value so you don’t have to type it manually).

If after that it is still red, it either mean that:

  • Your ISP does not allow port forwarding
  • Or that you have another part of the system that blocks the port forwarding (could be another modem not bridging data properly, could be one of the many firewalls people have, could be an anti-virus, …)

Hey Tool guy, thanks for your help. I did 3 ports today. i checked the windows firewall, i made a static IP also. I did not check the Malwarebytes though ( i only use windows defender and malwarebytes ). i will check those also. If nothing happens then is my ISP. Thank you very much for your help :slight_smile:

1 Like

Hello again, i spoke with my ISP and that was the problem. Now all the port lights in the server tool are green and i can connect without using the Direct connect button. Thanks again for your support Toolguy. Now excuse me but i have some building and slaying to do :slight_smile: Have a good day !


Win10 Pro user here, on a system where I have my font sizes increased. Whenever I move or try to resize my windows, it cuts off the right-edge of the GUI window and that edge is not allowed to be dragged/resized.

What’s your screen resolution, and which fontsize/dpi have you selected?

4096x2160 with a 350% custom scale factor.

Ok, I don’t a 4k screen here, I tried with a 2560x1440 screen at 200% and the tool behaved properly.
Could you try at 100% and if that works well, then 200%, and if that still works, go higher until it starts misbehaving, maybe it’s an overflow in the rescaling code, but without being able to reproduce this type of bug it is hard to fix :slight_smile:

So you confirm that the display is correct when you launch the program, it only clips when you try to move it or resize it?

Have you try to minimize and then restore it?

Hi Toolguy
Can you help me? We have 3 copies of the game and we want our own server. I can’t start the server on my PC. The ports are still red. I have a TP-Link MR6400 V1 with a 4G SIM. I used No-Ip and port forwarding, but I can’t set it up properly. Would help via TeamViewer or something be possible? I’m not good at networking, thanks.

Problem discovered, ISP does not support port forwarding

It’s common for mobile subscriptions to not support port forwarding, some allow it, but generally it’s different types of subscriptions that only some ISP/telcos provide.

That being said, some people managed to bypass that by using VPNs (not sure how it worked for @deathshand958 with his attempts with the “Hamachi Virtual Ethernet”), knowing that this would only work for a very limited number of people, because the impact of the VPN on the performance is quite significant.

It definitely was when I moved or resized. Minimizing did not fix it (and you can’t maximize it).