Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

Ok, I don’t a 4k screen here, I tried with a 2560x1440 screen at 200% and the tool behaved properly.
Could you try at 100% and if that works well, then 200%, and if that still works, go higher until it starts misbehaving, maybe it’s an overflow in the rescaling code, but without being able to reproduce this type of bug it is hard to fix :slight_smile:

So you confirm that the display is correct when you launch the program, it only clips when you try to move it or resize it?

Have you try to minimize and then restore it?

Hi Toolguy
Can you help me? We have 3 copies of the game and we want our own server. I can’t start the server on my PC. The ports are still red. I have a TP-Link MR6400 V1 with a 4G SIM. I used No-Ip and port forwarding, but I can’t set it up properly. Would help via TeamViewer or something be possible? I’m not good at networking, thanks.

Problem discovered, ISP does not support port forwarding

It’s common for mobile subscriptions to not support port forwarding, some allow it, but generally it’s different types of subscriptions that only some ISP/telcos provide.

That being said, some people managed to bypass that by using VPNs (not sure how it worked for @deathshand958 with his attempts with the “Hamachi Virtual Ethernet”), knowing that this would only work for a very limited number of people, because the impact of the VPN on the performance is quite significant.

It definitely was when I moved or resized. Minimizing did not fix it (and you can’t maximize it).

I went and played with it and it probably had to do with my custom scaled factor being set to 350%. I think Windows is doing a weird thing where they scale factor between different screens (I have a regular 1080p monitor on here too)

Does the tool display properly on the 1080p screen?
This type of bug is typically super hard to fix when it can’t be reproduced.

Question: Does the tool appear first correctly on one of your screen, and then you move it to another screen that has a different DPI setup?

It’s possible that my code is failing on something related to querying size information on the wrong monitor when doing moving and resizing. (I’m using a combination of WM_GETMINMAXINFO and WM_SIZE, but maybe I should also track WM_DPICHANGED…)

I have a problem with the Mods checker update.
The settings is on “Check for Updates and Restart” and the timer is on “00:05” and Checkmark in “Close Steam” and no checkmark in “Validate Server Installation”

But everytime there’s a mod update, the server don’t check for it and no restart happend.
If I press the questionmark for manually check for updates, it find the update and I can then manually restart the server and the mod update will apply to the server.

Any clue why it’s not working, anything i’m missing?
I desperately tried older version of Dedicated Server Launcher, but still the same for them.

1 Like

Imo the next step is to check the logs for errors, specially in your case, the actual Dedicated Server Launcher logs, they are located in the DedicatedServerLauncher\Logs folder at the same location as where you’ve put the launcher executable, all the logs are named “DedicatedServerLauncher(x.y.z).*.txt”

1 Like

There’s been some recent issues regarding Steam updates, detection of changes, etc… so I made a small quality of life update for the server launcher which actually logs what happened with SteamCMD as a part of the Dedicated Server Launcher log files, so we can actually look at the issues later.

And while I was at it, I added a new tab in the UI so you can monitor the actual launcher logs without having to manually open the log file from disk.

1.3.4 (30 november 2020)

  • The log output of the SteamCMD operation is now added to the Dedicated Server Launcher log files in a section starting by STEAMCMD OUTPUT
  • Added a new tab with the content of the Dedicated Server Launcher log
    Dedicated Server Launcher 1.3.4

@Twiixx using this version, please look for the following messages:

  • Setting the background mod check to every 5 minutes
  • Starting to check if the server and mods (2160533143,880454836,1382120864,1695473408) are up to date: Did not find anything to update
1 Like

Hello everyone, trying to start the server through the launcher shows that it works, but when connecting ping 9999 after a long download and the inscription " failed to connect to the server. Lost contact with the organizer of the game " what to do? And there is a video detailed how to set up the launcher?

Have you been through the manual/explanation on the top post on this thread?
Basically you need to get the three first port leds to turn green when clicking “Test Port Accessibility”.

To get that to work, means doing port forwarding on the router, making sure your firewall and antivirus to not block access, and of course an ISP that allows for port forwarding.

There is no video, but that probably not a bad idea at this point.

Hi everyone,
I have some questions about the field “Mod List” in the UI and the modlistt.txt in conan folder structur.

When I add a mod id in the UI field it gets added to the modlist.txt.
What about changing the load order? Do I have to change the order in the UI field or am I able to sort the modlist whithin the file?

Another question is about the ability to import a modlist.txt file from i.e. another server or a single player game.
Do I have to edit the UI field so it is in the same order like the copied (imported) modlist.txt?

Does it break the auto updated functionality if the mod order is not the same within the UI field and the modlist.txt?

Thanks in advance :slight_smile:
– Mikelei –

doesn’t really matter
but it’s easier with a file edits, as UI gets stuff from txt and you need not to start game

Great. Thank you.

@mikelei @drachenfeles indeed the editing possibilities are limited, that being said I did just a quick hack that could make things easier.

Let say you have a modlist that contains that:

c:\Launcher\ConanExilesDedicatedServer\steamapps\workshop\content\440900\2160533143\KDR_Unchained.pak
c:\Launcher\ConanExilesDedicatedServer\steamapps\workshop\content\440900\880454836\Pippi.pak
c:\Launcher\ConanExilesDedicatedServer\steamapps\workshop\content\440900\1382120864\LowerMonsterHPSolo.pak

but you want Pippi first, so you reorder to get that:

c:\Launcher\ConanExilesDedicatedServer\steamapps\workshop\content\440900\880454836\Pippi.pak
c:\Launcher\ConanExilesDedicatedServer\steamapps\workshop\content\440900\2160533143\KDR_Unchained.pak
c:\Launcher\ConanExilesDedicatedServer\steamapps\workshop\content\440900\1382120864\LowerMonsterHPSolo.pak

With my hack, if you drag and drop this new modlist.txt on the UI, it will automatically detected that \steamapps\workshop\content\440900 is actually a part of a path for a SteamCMD workshop deployed folder and extract the number behind, so the tool will rebuild the mod list with only these ids:

---------------------------
Conan Exiles - DedicatedServerLauncher 1.3.5
---------------------------
Are you sure you want to set '880454836,2160533143,1382120864' as your new mod list
---------------------------
Yes   No   
---------------------------

Could that help?

2 Likes

So here is a small version update for people who want to play with mods reordering.
I know it’s not a proper UI fix, that will happen one day, but this change in the mean time allows you to:

  • Edit your modlist as you want, and reimport it without having to enter numbers
  • Import old modlists of other servers

1.3.5

  • Modified the modlist drag and drop to allow reimporting a modlist by replacing ids if they are in the steamapps\workshop\content subfolder
    Dedicated Server Launcher 1.3.5

So, here is how that works (sorry for the large picture):

  1. The way things work, what you type in the Mod List field get processed and regenerated as a modlist.txt file in your Server install (when you press the “Save Changes”)
  2. Now you can open the text file, and change the order. On this picture I swapped “Pippi” and “KDR_Unchained” to get Pippi first (just a random example) and then saved back the modlist.txt
  3. Drag’n Drop the modlist.txt over the Dedicated Server Launcher UI and release the button
  4. The tool detects the drop, processes it and extract the ids (or full paths if they were local files) and asks you if you want to use that as your new mod list
  5. You can see that the modlist has been changed

Feel free to test and tell me if that works fine or if there are issues.

4 Likes

Hi @Toolguy

After you’ve helped me with my port forwarding my server has been running fine until last sunday. The server now keeps on restarting after a minute or two. I have tried to disable auto updates, I have disable BattleEye but somehow I still have the problem.

Looking at the log, I see much more lines than before and the last ones are the following:

[2020.12.08-20.42.10:989][ 0]Persistence:Display: WorldPersistence: Loading 327 actors
[2020.12.08-20.42.13:186][ 0]LogPakFile: New pak file …/…/…/ConanSandbox/Content/Paks/VFX.pak added to pak precacher.
[2020.12.08-20.42.13:186][ 0]LogUObjectGlobals:Warning: Failed to find object ‘Object /Game/Items/BPGameItemWeapon_NPCKnockUp_250.BPGameItemWeapon_NPCKnockUp_500_C’
[2020.12.08-20.42.19:594][ 0]Persistence:Display: WorldPersistence: Finished loading actors
[2020.12.08-20.42.19:791][ 0]LogMemory:Display: Entered application state ‘WorldPersistenceDone’.
[2020.12.08-20.42.20:078][ 0]Persistence:Display: WorldPersistence: Found 1 alive characters
[2020.12.08-20.42.20:082][ 0]Persistence:Display: WorldPersistence: Found 1 alive characters
[2020.12.08-20.42.20:086][ 0]Persistence:Display: WorldPersistence: Found 279 Server Population Recordings
[2020.12.08-20.42.20:086][ 0]LogGameState: Match State Changed from WaitingToStart to InProgress
[2020.12.08-20.42.20:104][ 0]LogLoad: Took 33.619870 seconds to LoadMap(/Game/Maps/ConanSandbox/ConanSandbox)
[2020.12.08-20.42.20:105][ 0]LogLoad: (Engine Initialization) Total time: 51.34 seconds
[2020.12.08-20.42.20:105][ 0]LogExternalProfiler: No external profilers were discovered. External profiling features will not be available.
[2020.12.08-20.42.20:105][ 0]LogWindows: FPlatformMisc::RequestExit(0)
[2020.12.08-20.42.20:110][ 0]LogMemory:Display: Entered application state ‘LeavingMap’.
[2020.12.08-20.42.20:110][ 0]LogGameMode:Display: Match State Changed from InProgress to LeavingMap
[2020.12.08-20.42.20:110][ 0]LogGameState: Match State Changed from InProgress to LeavingMap
[2020.12.08-20.42.20:110][ 0]LogDreamworld:Display: SQLLite query data for TEXT (char*) at column 2 and row 0 result 0 is null, will return empty string instead
[2020.12.08-20.42.20:110][ 0]LogDreamworld:Display: Trying to flushing main thread job queue but it’s getting bigger. Aborting.
[2020.12.08-20.42.20:110][ 0]LogNet: Browse: /Game/Maps/ConanSandbox/ConanSandbox?closed
[2020.12.08-20.42.20:110][ 0]LogNet: Failed; returning to Entry
[2020.12.08-20.42.20:110][ 0]UnitTest:Display: ClientState: 0
[2020.12.08-20.42.20:110][ 0]LogLoad: LoadMap: /Game/Maps/ConanSandbox/ConanSandbox?closed

All lights for ports are in grey while there were in green earlier today, I can’t click on the test port button (it’s greyed out) but when it appears for a few seconds, all lights go to green.

Do you see anything in the logs that could explain the problem?

Thanks

Yes. This helps me a lot.
Thank you.

1 Like

It’s hard to diagnose things with partial logs, but it’s very probable that your server is in a crash loop, either because there was an update that conflicts with mods, or some db corruption.

It’s most probably not the server launcher, and you can easily check that yourself: Instead of launching the server manually, click on the top of the launcher where the path to the server executable is displayed, that will open a explorer window: Close the server launcher, and manually launch the server executable from the explorer window. If stops by itself, it’s a problem with the server.

If that’s the case, then I would recommend joining the server admin discord, because there are probably people here that could help more than I could.

One important thing though: Have you setup the backup system on the server launcher, so you can revert to a previous game database or sets of ini files in case of problems?

@Toolguy
Thanks!

I first try like you suggested and the server was not restarting anymore. I then followed your idea about the backup.

I restarted a new server, clean slate, it was not rebooting anymore but I had lost the game content. Luckily I had enabled a daily back up and I simply copied the game.db file to the new server and I managed to connect to the game with the latest progress in the game. I’ll leave it running like this to see if it keeps on working, I still see much more chatter in the logs than before so there might still be something wrong. It’s really strange, I didn’t change anything and it suddenly stopped working.

Thanks for your help again!

1 Like