Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

Does the tool display properly on the 1080p screen?
This type of bug is typically super hard to fix when it can’t be reproduced.

Question: Does the tool appear first correctly on one of your screen, and then you move it to another screen that has a different DPI setup?

It’s possible that my code is failing on something related to querying size information on the wrong monitor when doing moving and resizing. (I’m using a combination of WM_GETMINMAXINFO and WM_SIZE, but maybe I should also track WM_DPICHANGED…)

I have a problem with the Mods checker update.
The settings is on “Check for Updates and Restart” and the timer is on “00:05” and Checkmark in “Close Steam” and no checkmark in “Validate Server Installation”

But everytime there’s a mod update, the server don’t check for it and no restart happend.
If I press the questionmark for manually check for updates, it find the update and I can then manually restart the server and the mod update will apply to the server.

Any clue why it’s not working, anything i’m missing?
I desperately tried older version of Dedicated Server Launcher, but still the same for them.

1 Like

Imo the next step is to check the logs for errors, specially in your case, the actual Dedicated Server Launcher logs, they are located in the DedicatedServerLauncher\Logs folder at the same location as where you’ve put the launcher executable, all the logs are named “DedicatedServerLauncher(x.y.z).*.txt”

1 Like

There’s been some recent issues regarding Steam updates, detection of changes, etc… so I made a small quality of life update for the server launcher which actually logs what happened with SteamCMD as a part of the Dedicated Server Launcher log files, so we can actually look at the issues later.

And while I was at it, I added a new tab in the UI so you can monitor the actual launcher logs without having to manually open the log file from disk.

1.3.4 (30 november 2020)

  • The log output of the SteamCMD operation is now added to the Dedicated Server Launcher log files in a section starting by STEAMCMD OUTPUT
  • Added a new tab with the content of the Dedicated Server Launcher log
    Dedicated Server Launcher 1.3.4

@Twiixx using this version, please look for the following messages:

  • Setting the background mod check to every 5 minutes
  • Starting to check if the server and mods (2160533143,880454836,1382120864,1695473408) are up to date: Did not find anything to update
1 Like

Hello everyone, trying to start the server through the launcher shows that it works, but when connecting ping 9999 after a long download and the inscription " failed to connect to the server. Lost contact with the organizer of the game " what to do? And there is a video detailed how to set up the launcher?

Have you been through the manual/explanation on the top post on this thread?
Basically you need to get the three first port leds to turn green when clicking “Test Port Accessibility”.

To get that to work, means doing port forwarding on the router, making sure your firewall and antivirus to not block access, and of course an ISP that allows for port forwarding.

There is no video, but that probably not a bad idea at this point.

Hi everyone,
I have some questions about the field “Mod List” in the UI and the modlistt.txt in conan folder structur.

When I add a mod id in the UI field it gets added to the modlist.txt.
What about changing the load order? Do I have to change the order in the UI field or am I able to sort the modlist whithin the file?

Another question is about the ability to import a modlist.txt file from i.e. another server or a single player game.
Do I have to edit the UI field so it is in the same order like the copied (imported) modlist.txt?

Does it break the auto updated functionality if the mod order is not the same within the UI field and the modlist.txt?

Thanks in advance :slight_smile:
– Mikelei –

doesn’t really matter
but it’s easier with a file edits, as UI gets stuff from txt and you need not to start game

Great. Thank you.

@mikelei @drachenfeles indeed the editing possibilities are limited, that being said I did just a quick hack that could make things easier.

Let say you have a modlist that contains that:


but you want Pippi first, so you reorder to get that:


With my hack, if you drag and drop this new modlist.txt on the UI, it will automatically detected that \steamapps\workshop\content\440900 is actually a part of a path for a SteamCMD workshop deployed folder and extract the number behind, so the tool will rebuild the mod list with only these ids:

Conan Exiles - DedicatedServerLauncher 1.3.5
Are you sure you want to set '880454836,2160533143,1382120864' as your new mod list
Yes   No   

Could that help?


So here is a small version update for people who want to play with mods reordering.
I know it’s not a proper UI fix, that will happen one day, but this change in the mean time allows you to:

  • Edit your modlist as you want, and reimport it without having to enter numbers
  • Import old modlists of other servers


  • Modified the modlist drag and drop to allow reimporting a modlist by replacing ids if they are in the steamapps\workshop\content subfolder
    Dedicated Server Launcher 1.3.5

So, here is how that works (sorry for the large picture):

  1. The way things work, what you type in the Mod List field get processed and regenerated as a modlist.txt file in your Server install (when you press the “Save Changes”)
  2. Now you can open the text file, and change the order. On this picture I swapped “Pippi” and “KDR_Unchained” to get Pippi first (just a random example) and then saved back the modlist.txt
  3. Drag’n Drop the modlist.txt over the Dedicated Server Launcher UI and release the button
  4. The tool detects the drop, processes it and extract the ids (or full paths if they were local files) and asks you if you want to use that as your new mod list
  5. You can see that the modlist has been changed

Feel free to test and tell me if that works fine or if there are issues.


Hi @Toolguy

After you’ve helped me with my port forwarding my server has been running fine until last sunday. The server now keeps on restarting after a minute or two. I have tried to disable auto updates, I have disable BattleEye but somehow I still have the problem.

Looking at the log, I see much more lines than before and the last ones are the following:

[2020.12.08-20.42.10:989][ 0]Persistence:Display: WorldPersistence: Loading 327 actors
[2020.12.08-20.42.13:186][ 0]LogPakFile: New pak file …/…/…/ConanSandbox/Content/Paks/VFX.pak added to pak precacher.
[2020.12.08-20.42.13:186][ 0]LogUObjectGlobals:Warning: Failed to find object ‘Object /Game/Items/BPGameItemWeapon_NPCKnockUp_250.BPGameItemWeapon_NPCKnockUp_500_C’
[2020.12.08-20.42.19:594][ 0]Persistence:Display: WorldPersistence: Finished loading actors
[2020.12.08-20.42.19:791][ 0]LogMemory:Display: Entered application state ‘WorldPersistenceDone’.
[2020.12.08-20.42.20:078][ 0]Persistence:Display: WorldPersistence: Found 1 alive characters
[2020.12.08-20.42.20:082][ 0]Persistence:Display: WorldPersistence: Found 1 alive characters
[2020.12.08-20.42.20:086][ 0]Persistence:Display: WorldPersistence: Found 279 Server Population Recordings
[2020.12.08-20.42.20:086][ 0]LogGameState: Match State Changed from WaitingToStart to InProgress
[2020.12.08-20.42.20:104][ 0]LogLoad: Took 33.619870 seconds to LoadMap(/Game/Maps/ConanSandbox/ConanSandbox)
[2020.12.08-20.42.20:105][ 0]LogLoad: (Engine Initialization) Total time: 51.34 seconds
[2020.12.08-20.42.20:105][ 0]LogExternalProfiler: No external profilers were discovered. External profiling features will not be available.
[2020.12.08-20.42.20:105][ 0]LogWindows: FPlatformMisc::RequestExit(0)
[2020.12.08-20.42.20:110][ 0]LogMemory:Display: Entered application state ‘LeavingMap’.
[2020.12.08-20.42.20:110][ 0]LogGameMode:Display: Match State Changed from InProgress to LeavingMap
[2020.12.08-20.42.20:110][ 0]LogGameState: Match State Changed from InProgress to LeavingMap
[2020.12.08-20.42.20:110][ 0]LogDreamworld:Display: SQLLite query data for TEXT (char*) at column 2 and row 0 result 0 is null, will return empty string instead
[2020.12.08-20.42.20:110][ 0]LogDreamworld:Display: Trying to flushing main thread job queue but it’s getting bigger. Aborting.
[2020.12.08-20.42.20:110][ 0]LogNet: Browse: /Game/Maps/ConanSandbox/ConanSandbox?closed
[2020.12.08-20.42.20:110][ 0]LogNet: Failed; returning to Entry
[2020.12.08-20.42.20:110][ 0]UnitTest:Display: ClientState: 0
[2020.12.08-20.42.20:110][ 0]LogLoad: LoadMap: /Game/Maps/ConanSandbox/ConanSandbox?closed

All lights for ports are in grey while there were in green earlier today, I can’t click on the test port button (it’s greyed out) but when it appears for a few seconds, all lights go to green.

Do you see anything in the logs that could explain the problem?


Yes. This helps me a lot.
Thank you.

1 Like

It’s hard to diagnose things with partial logs, but it’s very probable that your server is in a crash loop, either because there was an update that conflicts with mods, or some db corruption.

It’s most probably not the server launcher, and you can easily check that yourself: Instead of launching the server manually, click on the top of the launcher where the path to the server executable is displayed, that will open a explorer window: Close the server launcher, and manually launch the server executable from the explorer window. If stops by itself, it’s a problem with the server.

If that’s the case, then I would recommend joining the server admin discord, because there are probably people here that could help more than I could.

One important thing though: Have you setup the backup system on the server launcher, so you can revert to a previous game database or sets of ini files in case of problems?


I first try like you suggested and the server was not restarting anymore. I then followed your idea about the backup.

I restarted a new server, clean slate, it was not rebooting anymore but I had lost the game content. Luckily I had enabled a daily back up and I simply copied the game.db file to the new server and I managed to connect to the game with the latest progress in the game. I’ll leave it running like this to see if it keeps on working, I still see much more chatter in the logs than before so there might still be something wrong. It’s really strange, I didn’t change anything and it suddenly stopped working.

Thanks for your help again!

1 Like

It seems that my server always times out when trying to update any mod 1GB or larger. I have reordered the mod list several times. 900MB mod=no problem, 1GB=timeout.
Running SteamCMD

  • Executable: C:\Users\Grabaman\Desktop\DedicatedServerLauncher\steamcmd.exe
  • Parameters: +login anonymous +force_install_dir “C:\Users\Grabaman\Desktop\DedicatedServerLauncher\ConanExilesDedica
    tedServer” +app_update 443030 -beta default +workshop_download_item 440900 880454836 +workshop_download_item 440900 223
    6570677 +workshop_download_item 440900 1159180273 +workshop_download_item 440900 1699858371 +workshop_download_item 4409
    00 925197087 +workshop_download_item 440900 1705201022 +workshop_download_item 440900 1369802940 +workshop_download_item
    440900 1367404881 +workshop_download_item 440900 1734383367 +workshop_download_item 440900 1629644846 +workshop_downloa
    d_item 440900 1502970736 +workshop_download_item 440900 1835356127 +workshop_download_item 440900 1369743238 +workshop_d
    ownload_item 440900 864199675 +workshop_download_item 440900 1657730588 +workshop_download_item 440900 1249759891 +works
    hop_download_item 440900 2145102437 +workshop_download_item 440900 2209243164 +workshop_download_item 440900 2199839733
    +workshop_download_item 440900 1113901982 +quit
    ----- Started Thu 12/10/2020 12:33:19.83 -----
    Redirecting stderr to ‘C:\Users\Grabaman\Desktop\DedicatedServerLauncher\logs\stderr.txt’
    [ 0%] Checking for available updates…
    [----] Verifying installation…
    Steam Console Client © Valve Corporation
    – type ‘quit’ to exit –
    Loading Steam API…OK.
    Connecting anonymously to Steam Public…Logged in OK
    Waiting for user info…OK
    Success! App ‘443030’ already up to date.
    Downloading item 880454836 …
    Success. Downloaded item 880454836 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\stea
    mapps\workshop\content\440900\880454836” (27506954 bytes) Downloading item 2236570677 …
    Success. Downloaded item 2236570677 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\ste
    amapps\workshop\content\440900\2236570677” (12550411 bytes) Downloading item 1159180273 …
    Success. Downloaded item 1159180273 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\ste
    amapps\workshop\content\440900\1159180273” (9279137 bytes) Downloading item 1699858371 …
    Success. Downloaded item 1699858371 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\ste
    amapps\workshop\content\440900\1699858371” (15683792 bytes) Downloading item 925197087 …
    Success. Downloaded item 925197087 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\stea
    mapps\workshop\content\440900\925197087” (47448289 bytes) Downloading item 1705201022 …ERROR! Timeout downloading item
    1705201022CWorkThreadPool::~CWorkThreadPool: work complete queue not empty, 3 items discarded.
    ----- Finished Thu 12/10/2020 12:38:47.36 with status code 10 -----
    Waiting for 3 seconds, press a key to continue …
1 Like

Interesting, and thanks for the Steam log, so we do get a " Timeout downloading item" error message and a “status code 10”.

My question is: Could you try to manually run the batch file that call steamcmd from a command shell, and if it fails try to run it again, and see if at some point it does work.

Basically, does it look like doing some retries would work, like for example, on a “status code 10” is it worth calling SteamCMD again, or will it always fail?

I never had a timeout myself, and testing for errors is one of the hardest things to do… when you don’t get the errors :smiley:

Today is my last day at work before the Chrismas vacation, so let get a breakdown of what happened during this interesting year 2020.

We left 2019 with version 1.0.44 and we are now at version 1.3.5, so that’s another 17 releases this year.

On this screenshot you can see the difference between the two versions

Here are the details of what changed

  • UI changes:

    • The output is now a tabbed view, allowing to select between the original game server logs, steam cmd output, some filtered views showing player and mod related information, plus also the content of the various ini files (which can be directly edited - still experimental)
    • Added support for CTRL-A and CTRL-C to the log output
    • Added the server PID in the title bar
    • Added plenty of tooltips
    • Extended the CPU/Core list from 32 to 64 entries
    • Reordered the UI element for a more logical and nice to use tab order
  • Maps

    • Support for selecting maps (Siptah or from mods) - also shown in the title bar of the launcher
  • Steam

    • Support for arbitrary steam branches and users
    • The log output of the SteamCMD operation is now added to the Dedicated Server Launcher log files in a section starting by STEAMCMD OUTPUT
  • Moding:

    • Fixed a problem involving mod ids larger than 2147483648 (2^31)
    • The modlist edit field now also accept a copy-pasted list of mods, or a drag and dropped modlist.txt file so you can import or tweak mod lists
  • Backup:

    • The backup code now also handles the “blacklist.txt” and “whitelist.txt” files, as well as any additional game db file
  • Messages:

    • Added a combo box to select between “server” and “broadcast” when sending RCon messages (Maldred)
    • Added many magic tokens to the Discord and RCon messages.
  • Quality of Life changes:

    • The dedicated server launcher log files (in the /Logs subfolder) will now clearly indicate which ini file failed saving when it happens.
    • All restrictions on the maximum number of players have been removed
    • Modified the “Test Port Accessibility” to give some proper diagnostic on what did go wrong: TimedOut, could not bind the port, …
    • The tool is now able to run internally for the new projects, so it will be ready when the new games launch.
    • Clicking on the game server path on the top now opens an explorer window to the location of the executable
    • Removed the “Documentation” link in the Help menu, and fixed the “Forum thread” to actually point to the correct support thread
    • Added a new “DedicatedServerLauncher.ini” file to limit conflicts with the server rewriting ini files
  • Fixes:

    • Fixed a crash happening when trying to load older .ini files that did not have a “DedicatedServerLauncherServerAffinityMask” entry set
    • Fixed an issue with the ini file parser which would not properly remove duplicate entries in the ini files
    • Fixed some problem involving the internal crash reporter not managing to send reports
    • Added some proper quoting to allow SteamCMD to run if the Dedicated Server Launcher was installed in a folder containing spaces in the name
    • Moved the “Additional Command line parameters” before all the other parameters
    • Updated the magic tokens so they are also applied to RCon messages
    • Fixed a bug in the UI framework which would truncate the values to 2048 characters (problematic for the list of mods when using full paths) (veekay)
    • Fixed a bug where the affinity mask would not be reapplied after the server was restarted
    • Fixed a bug where the Run Script option used the wrong variable (Server Priority) to select the behavior.

Since there was no major issues reported for version 1.3.5, it’s now the new official version (+).

See you all next year :slight_smile:

+ Remember that ALL the previous versions are still available in the Release History section on the top post.


Anyone have an issue with dedicated server launcher downloading a big mod and failing to do so ? It says “download timeout” when the file is too large (like AOC mod)

edit: If it’s only possible to do via manual folder transfer, how can I setup the dedicated server manager to detect that the mod is up to date? If I only transfer the updated folders, the manager will still try to download the mod and always timeout.

Thanks in advance

afaik no, if you set it on update it will download from steam even if local file is newer