Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

Yes. This helps me a lot.
Thank you.

1 Like

It’s hard to diagnose things with partial logs, but it’s very probable that your server is in a crash loop, either because there was an update that conflicts with mods, or some db corruption.

It’s most probably not the server launcher, and you can easily check that yourself: Instead of launching the server manually, click on the top of the launcher where the path to the server executable is displayed, that will open a explorer window: Close the server launcher, and manually launch the server executable from the explorer window. If stops by itself, it’s a problem with the server.

If that’s the case, then I would recommend joining the server admin discord, because there are probably people here that could help more than I could.

One important thing though: Have you setup the backup system on the server launcher, so you can revert to a previous game database or sets of ini files in case of problems?


I first try like you suggested and the server was not restarting anymore. I then followed your idea about the backup.

I restarted a new server, clean slate, it was not rebooting anymore but I had lost the game content. Luckily I had enabled a daily back up and I simply copied the game.db file to the new server and I managed to connect to the game with the latest progress in the game. I’ll leave it running like this to see if it keeps on working, I still see much more chatter in the logs than before so there might still be something wrong. It’s really strange, I didn’t change anything and it suddenly stopped working.

Thanks for your help again!

1 Like

It seems that my server always times out when trying to update any mod 1GB or larger. I have reordered the mod list several times. 900MB mod=no problem, 1GB=timeout.
Running SteamCMD

  • Executable: C:\Users\Grabaman\Desktop\DedicatedServerLauncher\steamcmd.exe
  • Parameters: +login anonymous +force_install_dir “C:\Users\Grabaman\Desktop\DedicatedServerLauncher\ConanExilesDedica
    tedServer” +app_update 443030 -beta default +workshop_download_item 440900 880454836 +workshop_download_item 440900 223
    6570677 +workshop_download_item 440900 1159180273 +workshop_download_item 440900 1699858371 +workshop_download_item 4409
    00 925197087 +workshop_download_item 440900 1705201022 +workshop_download_item 440900 1369802940 +workshop_download_item
    440900 1367404881 +workshop_download_item 440900 1734383367 +workshop_download_item 440900 1629644846 +workshop_downloa
    d_item 440900 1502970736 +workshop_download_item 440900 1835356127 +workshop_download_item 440900 1369743238 +workshop_d
    ownload_item 440900 864199675 +workshop_download_item 440900 1657730588 +workshop_download_item 440900 1249759891 +works
    hop_download_item 440900 2145102437 +workshop_download_item 440900 2209243164 +workshop_download_item 440900 2199839733
    +workshop_download_item 440900 1113901982 +quit
    ----- Started Thu 12/10/2020 12:33:19.83 -----
    Redirecting stderr to ‘C:\Users\Grabaman\Desktop\DedicatedServerLauncher\logs\stderr.txt’
    [ 0%] Checking for available updates…
    [----] Verifying installation…
    Steam Console Client © Valve Corporation
    – type ‘quit’ to exit –
    Loading Steam API…OK.
    Connecting anonymously to Steam Public…Logged in OK
    Waiting for user info…OK
    Success! App ‘443030’ already up to date.
    Downloading item 880454836 …
    Success. Downloaded item 880454836 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\stea
    mapps\workshop\content\440900\880454836” (27506954 bytes) Downloading item 2236570677 …
    Success. Downloaded item 2236570677 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\ste
    amapps\workshop\content\440900\2236570677” (12550411 bytes) Downloading item 1159180273 …
    Success. Downloaded item 1159180273 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\ste
    amapps\workshop\content\440900\1159180273” (9279137 bytes) Downloading item 1699858371 …
    Success. Downloaded item 1699858371 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\ste
    amapps\workshop\content\440900\1699858371” (15683792 bytes) Downloading item 925197087 …
    Success. Downloaded item 925197087 to “c:\users\grabaman\desktop\dedicatedserverlauncher\conanexilesdedicatedserver\stea
    mapps\workshop\content\440900\925197087” (47448289 bytes) Downloading item 1705201022 …ERROR! Timeout downloading item
    1705201022CWorkThreadPool::~CWorkThreadPool: work complete queue not empty, 3 items discarded.
    ----- Finished Thu 12/10/2020 12:38:47.36 with status code 10 -----
    Waiting for 3 seconds, press a key to continue …
1 Like

Interesting, and thanks for the Steam log, so we do get a " Timeout downloading item" error message and a “status code 10”.

My question is: Could you try to manually run the batch file that call steamcmd from a command shell, and if it fails try to run it again, and see if at some point it does work.

Basically, does it look like doing some retries would work, like for example, on a “status code 10” is it worth calling SteamCMD again, or will it always fail?

I never had a timeout myself, and testing for errors is one of the hardest things to do… when you don’t get the errors :smiley:

Today is my last day at work before the Chrismas vacation, so let get a breakdown of what happened during this interesting year 2020.

We left 2019 with version 1.0.44 and we are now at version 1.3.5, so that’s another 17 releases this year.

On this screenshot you can see the difference between the two versions

Here are the details of what changed

  • UI changes:

    • The output is now a tabbed view, allowing to select between the original game server logs, steam cmd output, some filtered views showing player and mod related information, plus also the content of the various ini files (which can be directly edited - still experimental)
    • Added support for CTRL-A and CTRL-C to the log output
    • Added the server PID in the title bar
    • Added plenty of tooltips
    • Extended the CPU/Core list from 32 to 64 entries
    • Reordered the UI element for a more logical and nice to use tab order
  • Maps

    • Support for selecting maps (Siptah or from mods) - also shown in the title bar of the launcher
  • Steam

    • Support for arbitrary steam branches and users
    • The log output of the SteamCMD operation is now added to the Dedicated Server Launcher log files in a section starting by STEAMCMD OUTPUT
  • Moding:

    • Fixed a problem involving mod ids larger than 2147483648 (2^31)
    • The modlist edit field now also accept a copy-pasted list of mods, or a drag and dropped modlist.txt file so you can import or tweak mod lists
  • Backup:

    • The backup code now also handles the “blacklist.txt” and “whitelist.txt” files, as well as any additional game db file
  • Messages:

    • Added a combo box to select between “server” and “broadcast” when sending RCon messages (Maldred)
    • Added many magic tokens to the Discord and RCon messages.
  • Quality of Life changes:

    • The dedicated server launcher log files (in the /Logs subfolder) will now clearly indicate which ini file failed saving when it happens.
    • All restrictions on the maximum number of players have been removed
    • Modified the “Test Port Accessibility” to give some proper diagnostic on what did go wrong: TimedOut, could not bind the port, …
    • The tool is now able to run internally for the new projects, so it will be ready when the new games launch.
    • Clicking on the game server path on the top now opens an explorer window to the location of the executable
    • Removed the “Documentation” link in the Help menu, and fixed the “Forum thread” to actually point to the correct support thread
    • Added a new “DedicatedServerLauncher.ini” file to limit conflicts with the server rewriting ini files
  • Fixes:

    • Fixed a crash happening when trying to load older .ini files that did not have a “DedicatedServerLauncherServerAffinityMask” entry set
    • Fixed an issue with the ini file parser which would not properly remove duplicate entries in the ini files
    • Fixed some problem involving the internal crash reporter not managing to send reports
    • Added some proper quoting to allow SteamCMD to run if the Dedicated Server Launcher was installed in a folder containing spaces in the name
    • Moved the “Additional Command line parameters” before all the other parameters
    • Updated the magic tokens so they are also applied to RCon messages
    • Fixed a bug in the UI framework which would truncate the values to 2048 characters (problematic for the list of mods when using full paths) (veekay)
    • Fixed a bug where the affinity mask would not be reapplied after the server was restarted
    • Fixed a bug where the Run Script option used the wrong variable (Server Priority) to select the behavior.

Since there was no major issues reported for version 1.3.5, it’s now the new official version (+).

See you all next year :slight_smile:

+ Remember that ALL the previous versions are still available in the Release History section on the top post.


Anyone have an issue with dedicated server launcher downloading a big mod and failing to do so ? It says “download timeout” when the file is too large (like AOC mod)

edit: If it’s only possible to do via manual folder transfer, how can I setup the dedicated server manager to detect that the mod is up to date? If I only transfer the updated folders, the manager will still try to download the mod and always timeout.

Thanks in advance

afaik no, if you set it on update it will download from steam even if local file is newer

You can store the mod on another location on your disk (not in the launcher folder) and add the full path in the mod input field, it will be added to the modlist.txt but the launcher will not try to update it.

1 Like

^^ oh actually genius! Thx
I just have to link the server mod list to my own user mod folder! (copy paste my own modlist.txt to the server modlist.txt)

Mod WARRIOR Mutator for Conan Exiles id 1402835318 error download, how to fix that?

Running SteamCMD
- Executable: D:\Mojia Conan Server\DedicatedServerLauncher\steamcmd.exe
- Parameters: +login anonymous +force_install_dir “D:\Mojia Conan Server\DedicatedServerLauncher\ConanExilesDedicatedS
erver” +app_update 443030 -beta default +workshop_download_item 440900 1402835318 +workshop_download_item 440900 880454
836 +workshop_download_item 440900 1797359985 +workshop_download_item 440900 2169663966 +workshop_download_item 440900 8
64199675 +workshop_download_item 440900 1125427722 +workshop_download_item 440900 1369802940 +workshop_download_item 440
900 1369743238 +workshop_download_item 440900 1666355337 +workshop_download_item 440900 880177231 +workshop_download_ite
m 440900 1472647650 +workshop_download_item 440900 1159180273 +quit
----- Started Tue 12/29/2020 2:58:25.15 -----
Redirecting stderr to ‘D:\Mojia Conan Server\DedicatedServerLauncher\logs\stderr.txt’
[ 0%] Dang ki?m tra c c c?p nh?t hi?n c"…
[----] Dang x c minh ci d?t…
Steam Console Client © Valve Corporation
– type ‘quit’ to exit –
Loading Steam API…OK.
Connecting anonymously to Steam Public…Logged in OK
Waiting for user info…OK
Success! App ‘443030’ already up to date.
Downloading item 1402835318 …ERROR! Timeout downloading item 1402835318
----- Finished Tue 12/29/2020 3:03:32.29 with status code 10 -----
Waiting for 2 seconds, press a key to continue …

That’s unfortunately the same issue that @domyz has, and that some other people had, I never had the problem so it’s hard for me to reproduce, and when I asked people if they could try something they did not do it.

So what I would be interested in, is to know if calling SteamCMD again, when there’s a TimeOut, will eventually work after a while, of if it will fail forever.

So to anyone who has the problem, I need to know two things:

  • How did you proceed to actually fetch the mod
  • Can you try to call the SteamCMD command the Dedicated Server Launcher is using, multiple time, and tell me if it keeps with time out or if it sometimes work

I took the mod id from steam and added it to the mod list, when steamcmd downloaded the mod it reported an error, I restarted many times for it to update it still got the same error. The other ids are working properly, I think the mod is so big that this is causing this error (1.8GB). Sorry for my bad English

Thanks for testing!

So the question remains: Why do some of you manage to download the mod (from the Workshop page?) while SteamCMD fails, if anyone can come up with a solution, feel free to share!

EDIT: Could you try what is suggested on this post:

Actually I think I figured it out… I was able to add “validate” to the end of the mod update and it seems to have resumed the mod download. Just have to repeat that process in my script a few times, like so;

workshop_download_item 346110 572277026
workshop_download_item 346110 572277026 validate
workshop_download_item 346110 572277026 validate

It’s a messy way to do it, as you might end up validating the mod a few times after it’s fully downloaded, but it’s better than NOT having the full mod downloaded.

Happy new year! I’ve been having issues connecting to my Dedicated Server. The server is running off a separate computer on the same network. All lights are green, steam is set to close, ports are different. My server shows up in the browser. Trying to connect gives me this:

Via browser: Could not connect to server. Your connection to host has been lost.

Direct Connect: Connection timed out! Could not find server.

Here’s a link to my server launcher screen: imgur(dot com)/a/qnzckgI
Network configuration IP is set the same as multihome

I can connect to other servers fine, a friend was able to join the server
Tried changing steam settings, clean reinstall, no anticheat, anticheat, tried setting modlist the same as server, tried no mods, tried opening DMZ, and more that I can’t think of off the top of my head.

I’m wondering if I’m maybe messing up which ip to direct connect or which ip for multihome, I’m honestly at my wits end, I’ve been trying to get this to work since christmas, I’m thankful for any help or suggestions

If other people can join the server, it means the configuration is 100% fine.
Most probably what happens is that you are one the same local network as the server, and because of an issue that the team is still trying to fix, trying to join a machine on the same network using the external IP (the one everybody else has to use) will fail.

Try to use direct connect with the local network ip of the server instead

And happy new year to you too :slight_smile:

I have a suggestion for the Server Manger, for people like me whos ISP changes there IP frequently, can you add auto refresh to check the External IP for better reporting?


That’s actually a very good suggestion, I’m kicking myself for not having thought about that.

Question: What happens when your ISP changes the IP and the server is running and people are currently connected, does the game suddenly stop working and you need to restart the server, what exactly happens?

Is you idea that I should, for example, check every 10 minutes, that the external IP has not changed, and if it has, post a message and force restart, or…?

1 Like

If the ip updates while people are connected they stay connected, so it wouldnt need to restart the server when the ip changes.

but what id love to see is the ip getting checked and if the ip has changed just a message gets sent via the webhook to say… hay the ip just updated guys… when you wana connect now please use this ip and port.

but the server doesnt need to be restarted if the ip changes… people still stay connected.

but just checking the ip… reporting any changes… would be awesome!!

1 Like

can someone explain where to put my backup file to revert the server back to a previous version