Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

I took the mod id from steam and added it to the mod list, when steamcmd downloaded the mod it reported an error, I restarted many times for it to update it still got the same error. The other ids are working properly, I think the mod is so big that this is causing this error (1.8GB). Sorry for my bad English

Thanks for testing!

So the question remains: Why do some of you manage to download the mod (from the Workshop page?) while SteamCMD fails, if anyone can come up with a solution, feel free to share!

EDIT: Could you try what is suggested on this post: https://steamcommunity.com/discussions/forum/1/215439774859993377/

Actually I think I figured it out… I was able to add “validate” to the end of the mod update and it seems to have resumed the mod download. Just have to repeat that process in my script a few times, like so;

workshop_download_item 346110 572277026
workshop_download_item 346110 572277026 validate
workshop_download_item 346110 572277026 validate

It’s a messy way to do it, as you might end up validating the mod a few times after it’s fully downloaded, but it’s better than NOT having the full mod downloaded.

Happy new year! I’ve been having issues connecting to my Dedicated Server. The server is running off a separate computer on the same network. All lights are green, steam is set to close, ports are different. My server shows up in the browser. Trying to connect gives me this:

Via browser: Could not connect to server. Your connection to host has been lost.

Direct Connect: Connection timed out! Could not find server.

Here’s a link to my server launcher screen: imgur(dot com)/a/qnzckgI
Network configuration IP is set the same as multihome

I can connect to other servers fine, a friend was able to join the server
Tried changing steam settings, clean reinstall, no anticheat, anticheat, tried setting modlist the same as server, tried no mods, tried opening DMZ, and more that I can’t think of off the top of my head.

I’m wondering if I’m maybe messing up which ip to direct connect or which ip for multihome, I’m honestly at my wits end, I’ve been trying to get this to work since christmas, I’m thankful for any help or suggestions

If other people can join the server, it means the configuration is 100% fine.
Most probably what happens is that you are one the same local network as the server, and because of an issue that the team is still trying to fix, trying to join a machine on the same network using the external IP (the one everybody else has to use) will fail.

Try to use direct connect with the local network ip of the server instead

And happy new year to you too :slight_smile:

I have a suggestion for the Server Manger, for people like me whos ISP changes there IP frequently, can you add auto refresh to check the External IP for better reporting?

2 Likes

That’s actually a very good suggestion, I’m kicking myself for not having thought about that.

Question: What happens when your ISP changes the IP and the server is running and people are currently connected, does the game suddenly stop working and you need to restart the server, what exactly happens?

Is you idea that I should, for example, check every 10 minutes, that the external IP has not changed, and if it has, post a message and force restart, or…?

1 Like

If the ip updates while people are connected they stay connected, so it wouldnt need to restart the server when the ip changes.

but what id love to see is the ip getting checked and if the ip has changed just a message gets sent via the webhook to say… hay the ip just updated guys… when you wana connect now please use this ip and port.

but the server doesnt need to be restarted if the ip changes… people still stay connected.

but just checking the ip… reporting any changes… would be awesome!!

1 Like

can someone explain where to put my backup file to revert the server back to a previous version

Having an issue with the server setup. I’ve got the ports forwarded on my router and firewall, and even turned the firewall off, but they won’t connect.

I’ve got a TP-Link TL-WR940N

I’ll see what I can do.

If you click on one of the two blue icons on the bottom left, a explorer window will open, pointing on the location of the ini or log files.

From there you can move up and you will see your Game.db files.

Restoring a backup is basically overwriting these ini files or game database files with the ones from the backups (same thing with the white list, black list, etc…

Here is where the backed up files are selected from by the launcher:

  • “*.db”
  • “blacklist.txt”
  • “whitelist.txt”
  • “Logs\” SERVER_LOG_NAME
  • “Config\WindowsServer\Game.ini”
  • “Config\WindowsServer\Engine.ini”
  • “Config\WindowsServer\ServerSettings.ini”
  • “Config\WindowsServer\DedicatedServerLauncher.ini”

Could be many things, but the first one is: Does the “Test Port Accessibility” shows green lights?
Second, who are “they”, are we talking people on the internet, other people on the same home local network, etc… ? :slight_smile:

The Test Port Accessibility is showing all red and saying it is timing out. Hope I can figure it out here! Appreciate you being responsive! :slight_smile:

Well, as long as the test is red, you will not be able to get anyone to connect to your server, so you need to solve that.

Common issues are:

  • ISP that does not support port forwarding (often because the put multiple customers on the same external IP)
  • The port forwarding is on the wrong local IP (often happens when you use DHCP, because the router gives different ips to the various machines, you can fix that by associating a fixed IP to the specific MAC/hardware address on the server)
  • Port forwarding only done on TCP or UDP instead of both (in your case you would have at least some green there)
  • ISP that have both a modem AND a router, on which both need to be setup for the routing to work
  • Firewall or anti-virus, either on the router, or the server, that blocks the packages so they never reach the server launcher or game server

Ah, the modem and router part got me thinking, that we have a line from upstairs running to a router downstairs. Prob need to forward that then, as well.

Cause I’ve got my firewall opened, even tried having it off, got them forwarded here. So, ill give that a try.

Still no go, very confused. Hmm

I sent you a private message.

I may ask why the dedicated server is lagging after the 2.2 update? We have a server on this program, the internet works fine, the server itself is the same, and the lags are as if the ping was around 600 ms.
Before patch everything was fine.

not saying its your issue but look into ipv4 pinning. i ran into an issue where i could not connect to my server and the ports were showing red but others could connect. i had to join via internal ip. the cause for me was my isp having the modem set so that an external ip could not connect to the same external ip(loopback).

Sigh, I have to be another one to nag the toolguy. Btw, thank you for letting us nag you so frequently, and for being so patient with us know-nothings.

I think this is the place to put this, as it is only happening on my dedicated server. My girlfriend and I do not lose stamina when we sprint or climb. I personally dont like this as it makes the game way too easy, and combat is really unrewarding.

I had not updated or played with the current server installation since august.

Found a tutorial that explained how to wipe your world.

Deleted all of the database files from the conansandbox\saved directory.

I downloaded the newest server launcher and ran and update.

Started the server and logged in.

No stamina drain, like the nosprintcost is checked for everyone.

I checked the ini file and the spring cost is set to default. “PlayerStaminaCostSprintMultiplier=1.000000”. Tried recreating a character. Restarting the server. No dice.

Any help would be appreciated. I love to learn.

Edit: I forgot to share the mods I have installed. Pickup+, betterthralls, and thrall radius. Nothing that seems like it should affect players stats.

Edit2: It also acts as though I have a 3x or 4x exp multiplier, though it is set for 1.0000 in the ini file.

That’s a question for the dev/support team, all I do is to maintain the tool that launches the server, but it get the server from Steam like everybody else.

The question would be relevant for me here, if for example you figured out that since version 2.2 there is some ini file, or command line parameter that has changed, and that the server launcher was not updated and writes some data or command line parameter that impacts the performance of the server… in which case I would make a change for that to not happen, and publish a new version.

Not really, it would be the place to put this here if the issue was caused by something the launcher did, like for example if the game allowed you to now have up to 700 players at the same time, but the launcher would limit to 100, then yes that would be something to fix in my tool

For questions related to which setting impacts what, how to manage your dedicated server, diagnosing issues in general, I suggest you join the Admins United Discord.

Good luck :slight_smile:

I just made a small test version, which hopefully will address two of the issues we have (mods downloading timeout and external IP monitoring), but since 1) I never experienced the time outs and 2) my IP never changes, it was kind of difficult to test.

So please, @ErynLyn @hoangducdt @domyz and anyone else having similar issues, you could you gie a shot at this version and tell me if that helps (or if it does not work at all)?

1.3.6 (11 january 2021)

  • Added “validate” to each of the +workshop_download_item command sent to SteamCMD, hopefully this will help with timeouts on large mods
  • The launcher now monitors the External IP every 10 minutes and signals when it changes
    Dedicated Server Launcher 1.3.6
1 Like