Conan Exiles Dedicated Server Launcher (Official Version: 1.3.8 / Beta: -----)

Automatic Updates are no longer working, it happened after new year I think.
When I use the ? mark, I get this:

Conan Exiles - DedicatedServerLauncher 1.3.5 - The Exiled Lands - (PID:1492)

Bias: -60
UTC : 2021.01.19 15.00.03 | W. Europe Summer Time:-60
Local: 2021.01.19 16.00.03 | W. Europe Standard Time:0

#443030 () [FAIL]
#1629644846 (Kerozards Paragon Leveling - A Multigun Refresh - v2.2.8)
Install=2021.01.19 14.56.25 Steam=2020.10.29 05.36.00
#1453301901 (Tier 4 Thralls - Medium Increased Spawn - v5.7.2)
Install=2021.01.19 14.56.26 Steam=2021.01.10 13.15.00
#2234744777 (LitMan Increased Weight - Recompiled)
Install=2021.01.19 14.56.27 Steam=2021.01.10 22.51.00
#880454836 (Pippi - User & Server Management - v3.4.6)
Install=2021.01.19 14.56.27 Steam=2021.01.08 14.00.00
#877108545 (Unlock Plus (with Pickup) v1.4.5)
Install=2021.01.19 14.56.28 Steam=2021.01.06 19.42.00
#1734383367 (Endgame Extended Weapon Arsenal (EEWA))
Install=2021.01.19 14.56.29 Steam=2021.01.12 16.48.00
#1797359985 (Hosav’s Custom UI Mod - Revamped!)
Install=2021.01.19 14.56.30 Steam=2021.01.06 19.08.00

OK

I have to restart manually.

This is working awesomely!!

Could you try with this version?

1.3.7 (13 january 2021)

  • Modified the server update detection code to use the “buildid” field of the ACF files instead of the timestamps to avoid problems when switching between two branches where the same build has been deployed being detected as an update.
    Dedicated Server Launcher 1.3.7

I did a quick test and got that:

---------------------------
Conan Exiles - DedicatedServerLauncher 1.3.7
---------------------------
Bias: -60 
UTC  : 2021.01.20 07.43.21 | Romance Daylight Time:-60
Local: 2021.01.20 08.43.21 | Romance Standard Time:0

#443030 (Conan Exiles Dedicated Server)
Install=2021.01.08 11.44.42 (Build 5995489)
UPDATE=2021.01.19 12.47.06 (Build 6084789)
#1402835318 (WARRIOR Mutator for Conan Exiles)
Install=2021.01.08 11.46.16 UPDATE=2021.01.09 00.45.00
---------------------------
OK   
---------------------------

Ok, then it will be probably be gone in some near future version.
Less code, less butons, less things to keep working and explain to people :slight_smile:

Cool!
Thanks for the feedback. :slight_smile:

Yes, this version worked without error. I guess it will also work on the next patch too.

Another thing:
In the player tab at the bottom, you can see when a player log in and what the character name say in chat, can it also show when a player (character) log off?

Ok, cool, thanks :slight_smile:

I’l let you test it a little longer, and if nobody finds catastrophic issues, I’ll push it to “new official” tomorrow or the day after that.

Possibly, I’m doing pattern matching, so if I find any of these strings in the log, it gets shown in the PlayerLog:

  • ChatWindow:
  • Join succeeded:
  • Login request:
  • PreLogin failure:
  • VerifyIdentity Completed:

If you can find a 100% certain correct element in the log that I can use to detect a character leaving, with relevant display information, just say, and I’ll add it. (can also be anything else useful related to players, and same thing for the other sections - like mods -)

Only ‘disconnect’ message I found in conansandbox.log is from Battleye:
‘BattlEyeServer: Print Message: Player #2 XXXXX disconnected’

Conansandbox.log is a mess since everything goes in there. Just by restarting the server you get hundreds of new lines.

The text in the seperate tabs are difficult to read since they refresh after a few second.
Is it possible to take the text in these tabs directly into notepad, not to edit but just to read?

Normally CTRL-A + CTRL-C should work, at least last time I tried it did.

Ok, Thanks.

And there was a new update today and now it worked perfect.

Every time I log out I get this in the log:

LogNet: UChannel::ReceivedSequencedBunch: Bunch.bClose == true. ChIndex == 0. Calling ConditionalCleanUp.
LogNet: UChannel::CleanUp: ChIndex == 0. Closing connection. [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: xx.■■■.xx.■■■:xxxxx, Name: IpConnection_1, Driver: GameNetDriver IpNetDriver_0, IsServer: YES, PC: FunCombat_PlayerController_C_1, Owner: FunCombat_PlayerController_C_1
LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: xx.■■■.xx.■■■:xxxxx, Name: IpConnection_1, Driver: GameNetDriver IpNetDriver_0, IsServer: YES, PC: FunCombat_PlayerController_C_1, Owner: FunCombat_PlayerController_C_1, Channels: 686, Time: 2021.01.19-14.58.57
LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: xx.■■■.xx.■■■:xxxxx, Name: IpConnection_1, Driver: GameNetDriver IpNetDriver_0, IsServer: YES, PC: FunCombat_PlayerController_C_1, Owner: FunCombat_PlayerController_C_1

I am always the only player on the server though, might be just some cleanup thing.

edit:// RemoteAddr is a placeholder here, don’t know why it got formatted to those little squares. :smiley:

We have a problem with the autoupdate function. The option “Check for Updates and Restart” is enabled, but it no longer detects new updates. In addition, it shows an error message when I run the check manually. Only after a server restart the update is found via the steamconsole.

Tested with Version 1.3.1 and 1.3.6

Screenshot_1

Logs:

[2021-01-20 15:37:03.740] [TID:10048] IMPORTANT: DedicatedServerLauncher - Starting to check if the server and mods () are up to date
[2021-01-20 15:37:17.847] [TID:10048] IMPORTANT: DedicatedServerLauncher - - Did not find anything to update
[2021-01-20 15:37:26.394] [TID:10048] IMPORTANT: Server - [MessageBox] Message 'Bias: -60 
UTC  : 2021.01.20 15.37.03 | Mitteleuropäische Sommerzeit:-60
Local: 2021.01.20 16.37.03 | Mitteleuropäische Zeit:0

#443030 () [FAIL]' was answered by '1' 
[2021-01-20 15:38:01.822] [TID:17488] IMPORTANT: DedicatedServerLauncher - Starting to check if the server and mods () are up to date
[2021-01-20 15:38:04.114] [TID:10048] IMPORTANT: DedicatedServerLauncher - Starting to check if the server and mods () are up to date
[2021-01-20 15:38:10.756] [TID:10048] IMPORTANT: DedicatedServerLauncher - - Did not find anything to update
[2021-01-20 15:38:11.787] [TID:17488] IMPORTANT: DedicatedServerLauncher - - Did not find anything to update

Blockquote

Get the new version 1.3.7, it solved this.

2 Likes

Hi, since update 2.2.1 my dedicated server don’t run what should I do please?:

[2021.01.20-20.40.33:605][ 0]LogWindows:Error: === Critical error: ===
[2021.01.20-20.40.33:605][ 0]LogWindows:Error:
[2021.01.20-20.40.33:605][ 0]LogWindows:Error: Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 1373]
[2021.01.20-20.40.33:605][ 0]LogWindows:Error: No outstanding IO, no nodes in the queue, yet we still have ‘PackagesWithNodes’ in the graph.
[2021.01.20-20.40.33:605][ 0]LogWindows:Error:
[2021.01.20-20.40.33:605][ 0]LogWindows:Error:
[2021.01.20-20.40.33:605][ 0]LogWindows:Error: !0x0000000000000000
[2021.01.20-20.40.33:605][ 0]LogWindows:Error:
[2021.01.20-20.40.33:605][ 0]LogWindows:Error: Crash in runnable thread FAsyncLoadingThread

edit: I have quote this and now my server work.
image

@Terrance I just promoted 1.3.7 as the new Official Version, for reminder here is the link:

1.3.7 (13 january 2021)

  • Modified the server update detection code to use the “buildid” field of the ACF files instead of the timestamps to avoid problems when switching between two branches where the same build has been deployed being detected as an update.
    Dedicated Server Launcher 1.3.7

So from your Edit, I guess things are working now?
Did you change anything? (first time I see this error message actually)

I honestly have no idea, could be quite a lot of things.
Maybe ask on the Admin Discord if anyone has a suggestion?

1 Like

Ah, sorry, I wasn’t really clear about what I’m responding to.

@stinger asked for a way to log when a player logs off and you asked for a detectable element for pattern matching, I was responding to that. Hopefully someone will be able to confirm that it’s unique to player logging off.

1 Like

Lol, yeah I totally missed that :slight_smile:
I guess the problem is that:

  • The first method only works if BattlEye is enabled
  • The second does not provide the name of the player (only player controller X)

Maybe I should just ask the team to add a clear log message when players leave :slight_smile:

1 Like

Just another minor upgrade

1.3.8 (22 january 2021)

  • The status bar should not appear truncated anymore if the launcher is started on a very small screen width (like a tiny Remote Desktop Session)
  • Removed the “Close Steam” option
  • Renamed “Stream Query Port” to “Source Query Port”
    Dedicated Server Launcher 1.3.8

Not much on the outside, but I did a bit of cleaning in the code, keeping the “Technical Debt” in check.

2 Likes

You’re right, my problem is over. I don’t have change anything exept tick "validate server installation. After that, the update was installed.

1 Like

Has anyone been able to get this tool to work correctly on Server 2019 Core? The only thing holding me back is that the tool wants DirectX libraries that Hyper V simply doesn’t use and a lot of the documentation and files involved are almost a decade old. UE4 Prerequisites Setup Fatal Errors during installation.

Everything else is running and ready to go.

I’m running it (just fine) on Windows Server 2019 Datacenter, if that’s any help.

1 Like