Conan Exiles Dedicated Server Launcher (Official Version: 1.4.5 / Beta: 1.4.6)

Great tip, it worked!

I had to check “validate server installation” to have the dedicated server launcher do its job and re-create the folder structure however.

Then, I added manually a “steamapps” directory in ConanExilesDedicatedServer and the game was done.

Thank you for the workaround.

2 Likes

Anytime I run the DedicatedServerLauncher1405 I get the following error:

ERROR! Failed to install app ‘443030’ (Disk write failure)

I successfully used the launcher days ago but all the information reverted to default and now I’m stuck with this error. I used the maturemindedgamers guide to launch a server and it worked but I couldn’t connect to it. Hope some helpful information comes up on here soon.

Suggestion: Read the two messages above yours :slight_smile:

1 Like

I copied your pathway. My dedicatedserverlauncher is at c:/dsl but only contains a folder titled “dedicatedserverlauncher” and the app titled "dedicatedserverlauncher1405.
I do have a steamapps folder in the folder titled “dedicatedserverlauncher”

If I go into the folder I have 24 items starting with a folder titled “appcache” to an app ext titled “vstdlib_s.dll”

I copied my steamapps folder and pasted it into the ConanExilesDedicatedServer folder. Now when I click the big button in the launcher I get Success! App ‘443030’ is already up to date, but it won’t launch the server. Looking closer at your picture, I only have the “ConanSandbox” folder and the newly pasted “steamapps” folder in there.

You were not supposed to copy the existing steamapps folder at the root of the launcher, it was necessary where it was: The SteamCMD bug is that apparently they changed something that requires ANOTHER “steamapps” folder to be present at the location I mentioned.

All you needed was to create a new empty folder, not copy or move anything :slight_smile:

1 Like

Success! Awesome.

1 Like

Hi Toolguy, I done as you mentioned by adding that steamapps folder into the ConanExilesDedicatedServer folder and made some progress but now it shows me this:

Running SteamCMD

  • Executable: C:\Program Files (x86)\Conan Server\DedicatedServerLauncher\steamcmd.exe
  • Parameters: +login anonymous +force_install_dir “C:\Program Files (x86)\Conan Server\DedicatedServerLauncher\ConanEx
    ilesDedicatedServer” +app_update 443030 -beta default +quit
    ----- Started 09/06/2021 14:18:02.21 -----
    Redirecting stderr to ‘C:\Program Files (x86)\Conan Server\DedicatedServerLauncher\logs\stderr.txt’
    [ 0%] Checking for available updates…
    [----] Verifying installation…
    Steam Console Client (c) Valve Corporation
    – type ‘quit’ to exit –
    Loading Steam API…OK.
    Connecting anonymously to Steam Public…Logged in OK
    Waiting for user info…OK
    Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
    Update state (0x61) downloading, progress: 4.01 (129476993 / 3229900205)
    Update state (0x61) downloading, progress: 6.27 (202542180 / 3229900205)
    Update state (0x61) downloading, progress: 7.41 (239249292 / 3229900205)
    Update state (0x61) downloading, progress: 8.51 (274900876 / 3229900205)
    Error! App ‘443030’ state is 0x402 after update job.
    ----- Finished 09/06/2021 14:18:14.99 with status code 8 -----
    Waiting for 2 seconds, press a key to continue …

It seems to start the download now but stops at a certain point, any idea why?

Edit: Something to note as well is that when I continue to press the button at the bottom it seems to progress the update,and then gets the error again. This doesn’t seem healthy to me, what are your thoughts?

Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
Update state (0x61) downloading, progress: 17.87 (577319431 / 3229900205)
Update state (0x61) downloading, progress: 18.49 (597242375 / 3229900205)
Update state (0x61) downloading, progress: 19.82 (640237422 / 3229900205)
Error! App ‘443030’ state is 0x402 after update job.

I wish I could answer you positively, but I’ve no idea.
Does it always stop at the exact same location?
Have you tried to enable “validate”?

Huh, for some reason it unchecked itself, I must have forgotten to save the setting.

I just tried it there and The same issue occurs. The weird thing as as mentioned in my edit is that it is progressing. I’m now ~ 60% complete but have to press the launcher button at the bottom right

To update you I completed the download by just having to constantly press that button, I can now see the switch so I’m assuming everything installed fine but will need to test it. Thanks for your help mate

Edit: Everything appears to be in working order, thanks again

1 Like

Hello. Earlier you disccused error " Failed to install app ‘443030’ (Disk write failure)"

Have the same problem with server lauch. Tried all variants that you suggers in the topic - nothing helped. Is there is any solution for this error?

A new version of the Dedicated Server Launcher has been released: 1.4.6.

It technically does not bring any improvement, but if you are the unfortunate owner of a 10th or 11th generation Intel processor, that may help with not having your server to crash on startup when initializing Open SSL.

1.4.6 (10 june 2021)

  • Added some code (SetEnvironmentVariable(“OPENSSL_ia32cap”, “:~0x20000000”)) to avoid OpenSSL issues on recent Intel processors (10th and 11th generation)
    Dedicated Server Launcher 1.4.6

The main difference visually will be one of these new messages in the Launcher log tab before starting the server:

  • Set Environment Variable ‘OPENSSL_ia32cap’ to ‘:~0x20000000’ successful
  • Set Environment Variable ‘OPENSSL_ia32cap’ to ‘:~0x20000000’ failed

Regarding the “Disk write failure” and other SteamCMD problems, other than what I suggested (manually add a “steamapps” folder in the ConanExilesDedicatedServer folder), I do not have any other suggestion.

I fear we have to wait for Valve engineers to release a new version, or provide an different way of doing things.

Sorry!

3 Likes

Greetings, I’ve done all the settings as requested, and I’ve turned off the firewalls, but the port lights are still red.
The server is visible but not logged in, it says time out.

thanks for answering

If the port lights are off, then there is obviously something blocking it. Most likely port forwarding needs setting up on the router.

i allready did

I’m having an issue where my server was working fine earlier this morning but I went to start the server later in the day and now it can’t connect to my ports. When I test the ports I get an error that says it failed binding socket for all my ports. For a couple days it was working fine and could connect without any issue. Can anyone help?

For a couple days it was working fine and could connect without any issue. Can anyone help?

I assume that the machine did not reboot and got a new IP from your router?
Could you check that the port forwarding is still working fine and matches the server ip?

Launching a dedicated server on Game Pass only shows a small window says close this window to shut down the server. So I downloaded and opened the Dedicated Server Launcher instead of using Game Pass.

I could Log in to my server from the Game Pass version. So I tried to transfer my server into dedicated server launcher version but I couldn’t find any game.db in Saved file(Game Pass version). Not like Steam file locate in steamapp file, I think Microsoft put it in a different location. Sorry for my bad English. I wonder is there any way to transfer my data from Game Pass to the Launcher version?

I’ve no idea, I’ll ask the team and come back to you if I get an answer. (I did not even know you could start the game server from the gamepass version of the game)