Conan Exiles Dedicated Server Launcher (Official Version: 1.4.5 / Beta: 1.4.6)

Just follow the guide at the top of the post (#6) and it should work!!

Just make sure then when you move over your windowsserver .ini files and game.db files that you still have the server launcher up, that how i got it to work, and i am using the 1.3.0 version

Hello, this is my first post in this forum and I just joined to ask this question. I tried to search if there was same question in the forum which I am very sure there was, but I couldn’t find the answer unfortunately.

So setting up a server initially was very smooth considering I have little to no knowledge of any technical terms, so huge appreciation from me for publishing this tool!
Now I have to move my server file from laptop to desktop PC which is located in the same network, and I am currently stuck heavily in here.

I copied all the file under “Dedicatedserverlauncher”, and the launcher setting was all imported (at least it seems) in the desktop. [EDIT] I downloaded the exe file separately to the desktop PC too… I should’ve copied this too?
However, when I try to join the server, I cannot connect to the server even if I can see it in the server list. Connection times out.

I think I am not getting “rename the folder” part as I didn’t and I was not sure what folder to rename, as I am copying everything over. Could someone please help me?:frowning_face:

Thank you very much for looking into this!

Regarding “Can only connect using local IP” when using a computer on the same network

That’s unfortunately not my domain (I’m not a part of the Exiles team), what I could suggest is for all the people who encountered this particular issue to use a single forum post regarding the issue, and post details about your setup (wired or wifi network, model of router, use of multihome or not, ports used, etc…) so the dev team gets all the reports on the same place.

I was told the issue existed but was not widely happening, but there seem to be quite many people impacted by that, so the more information they can get, the better.

Ok, so maybe it’s something inside the messages that cause some issue, could you find me some examples of messages that do not work at all, so I can try to reproduce it?

I tried with my own set of messages, and they worked fine, on direct Send, on mod update, on restart, and delayed restart, both on Discord, RCon broadcast and RCon server.

What @Magwan wrote, look at “Importing an existing server” in the first post

Is it everybody who can’t enter, or only you from the same local network? If it’s only you, try Direct Connect using the local IP.

If it’s not that, then it’s a case of checking the logs for the server and clients to see what goes wrong, generally you see an attempt at connecting and then it fails for some reason.

So, let see, you had multiple points there:

I think I am not getting “rename the folder” part as I didn’t and I was not sure what folder to rename

That was just an example: The launcher does not care about where it is, so you could shut it down, rename the folder where it is located, and restart it, that will work. Your case is different, you tried to move the installation from one machine to another one, and assuming you’ve changed the network parameters on your router to properly point to the new machine’s IP address, that should work just fine.

I copied all the file under “Dedicatedserverlauncher”, and the launcher setting was all imported (at least it seems) in the desktop.

I highly recommend to NEVER install anything on the desktop, it’s bad things waiting to happen: Put that in a short folder. like C:\MyServers\Conan or D:\ConanExiles, etc… avoid long paths, avoid to put things in C:\users, avoid desktop, etc… (but you can put a shortcut to the desktop if you want)

I downloaded the exe file separately to the desktop PC too… I should’ve copied this too?

Does not really matter, as long as you have a working version of the launcher :slight_smile:

However, when I try to join the server, I cannot connect to the server even if I can see it in the server list. Connection times out.

Do you have a green light when you test the ports?

I cant manage to properly run the server (+ connecting, but not port-related)

I disabled firewall completely, i host server on same computer im planning to play, so ports shouldnt be a problem.

I tried without mods/with mods, new save, old save, doesnt matter, i always get spammed with:
“SpawnTable:Error: Data: USpawnTableComponent::SpawnNPCFromWeightedTable - could not find weighted table with id: …”
and many different ids there, Thralls, Wildlife, etc.

Pastebin: wLDD3ekG (cant give links so yeah)

Age shows ??? Ping show 9999

I and others have no issues connecting direct. 7777,7778 and other standard ports open. Server Launcher Green lights all those ports.

Server Information

  • Name: The Lost FL
  • Code Version: 247381/26570 (Live branch)

hello I have a dedicated server with several people on it. It runs without problems but nevertheless in the errors tab it detects several that I would like to know what they are specifically. Can I send you the log to verify what all these events are due to?


Ok after beating my head up against a wall for several min, I figured that the port for rcon was not open like it should have been even after setting up the firewall right

After a bit i was able to see the port and all works as expected!

Not sure what I did, (running server 2016 and had dhcp and dns servers running) among other magical mystical keystrokes (no idea what i typed) but it works so im leaving it alone

1 Like

The problem was solved by itself. Was cured by a banal restart of the computer. I do not know what was the matter, maybe some errors are accumulating, maybe more … The server (hardware) worked for a month without rebooting.

1 Like

Ok, so a case of “Have you tried to turn it off and on again” :slight_smile:

Let cross fingers so things continue working :slight_smile:

I guess you can, though there’s a large chance that these errors are things most people have, Exiles has unfortunately a large amount of log spam that has not been resolved yet, the team has been working on that but there’s still a huge amount to go through.

That’s a known issue that the team has been trying to solve for quite a while, I know there are some fixes in the pipeline, that seems to be related to the client (or server, or both) sometimes losing the connection with these systems that measure ping and stuff, and failing to reconnect because it still thinks it’s connected.

Have you tried the “Validate install” button?
Could be some data corruption.

Regarding actual game errors, I can’t help: I’m not part of the Exiles devteam, not been for at least two years, imo you’ll have more chance asking on the support threads, or possibly to join the Exiles Admins Discord which has many knowledgeable people

Thank you so much for your reply! I never checked “test port accessibility” before, so I did…

  1. desktop PC (the one I am trying to move all the server data): ALL GREY o.O
  2. laptop I was running my server on: grey for 7777 & 25575 (but according to port forwarding network utility tool 25575 is open too)

I tried to open port on my router (luckily the same one as the example, it’s asus one) & Norton, but it seems I am not doing it correctly since ports aren’t opening up.
So I tried to run my server again in my laptop just to relax, and… now I encounter the same issue as the desktop PC… forever in loading screen even though I can see it in the server list :sob:

Probably I did something very wrong either when I’m trying to open ports or when I’m copy-pasting server files (or both, very likely).
I will try to figure out at least until I can run the server on the laptop again, and figure out the port forwarding part… hopefully I can move the server soon though as my husband is taking the laptop for the foreseeable future soon.

Will come back here once I figure out the port forwarding! Thank you so much for your help, Toolguy:)

Perfect, to whom could I send the error events on my server?

Damn, that’s a bug, just tested, I broke something, the test itself is valid, the error message is valid, but it was supposed to be:

  • Grey: Untested
  • Green: Tested and working
  • Red: Tested and not working

but yeah, if you did not have green, it means it’s not open.
The RCon port is not tested because it does not have to be port forwarded, you can if you want to RCon from another machine, but technically just having it working locally is good enough - at least if you want the server launcher to be able to send messages to the server -

You could just put the error messages you are wondering about in something like pastebin or some other text sharing online system, makes it easier to go through.

Just a minor release to fix the issue found by @mogeizo

1.3.1 (1 october 2020)

  • Fixed a bug introduced in version 1.2.5 with the “Test Port Accessibility” showing grey instead of red lights for errors.
    Dedicated Server Launcher 1.3.1

Here is what the port testing is supposed to look like when it fails:

1 Like

Thanks, I took a look at the link, some of these were already flagged as “log spam” and may be fixed in future updates, but I can’t really tell you anything regarding if these errors are actually causing issues or not.

Good afternoon!

As for the missing messages on restart.
Unfortunately, I didn’t have enough time to test the various versions. All this time I was busy with work. There was no time for the server. Tomorrow I am still working, but hopefully on Sunday I can be more precise.
The players are very saddened by the sudden restarts. When a mod or server update is detected, the restart timer starts, but no messages appear. At some point, the server just shuts down everyone and reboots.
Maybe you can quickly identify what the problem is.

I didn’t quite understand how sending messages (manual) works. I tried submitting but no result.

Yeah that doesn’t help me at all. I have no clue what any of that means or how to do it. The step by step guide doesn’t work, I have no idea where I am supposed to get these files from because my server box isn’t in my house or on my pc.

Well, the main issue there is that your first message did not clearly state that:

Anyone know if you can set this up on a server that is already functioning, because I have tried so many ways to get this thing to work and at present it does nothing, it will not find the server, it will not connect to the server and it’s just driving me nuts.

The way I was reading it was that:

  • You already had a server running, using some other tool, script or whatever, on some machine
  • You wanted to use the Dedicated Server Launcher instead, and were trying to import the existing server

Now when I read “it will not find the server, it will not connect to the server and it’s just driving me nuts.” I think it’s a just a big misunderstanding: The Dedicated Server Launcher is not some kind of control panel you can use to control some remote server, it is a tool that allows you to run your own server - on the same machine where you install the Launcher tool.

Could you describe what you actually wanted/hopped to do?

1 Like

Ah ok so it isn’t for all dedicated servers, just ones you run on your own pc. Gotcha. I don’t think you can help then. I wanted to use the server/Discord link really.


Has anyone found a fix for the steamCMD bug yet as per below :

@ [quote=“Hugo, post:1, topic:21699”]
@A: If your mods stop being updated, and SteamCMD displays errors such as ‘\src\common\contentmanifest.cpp (650) : Assertion Failed: !m_bIsFinalized’ then you are probably a victim of the SteamCMD bug which has been reported by many people for many games.

Some people are saying that deleting the appmanifest_xxxxx.acf in the steam apps folder fixes it, but some other people are reporting that the fix did not work for them…

Any suggestions welcome as this really slows down the server maintenance process, having to first get the mods from a client device and then transfer them to the server.