Conan Exiles Dedicated Server Launcher (Official Version: 1.5.8 / Beta: 1.6.0)

Here’s exactly what I had to do:

Make a new server folder. Put the dedilauncher in that folder and run “DedicatedServerLauncher1600.exe -steamid 931580” to create the folders with only the right id. Edited all the fields to be what I wanted (ports, server name, branch, etc). Now it had the right server version because I never ran it with 443030 (which confused my original).

Ok, good to know :-/

Probably means that going from one product id to another on the same install location is not working smoothly, possibly some SteamCMD artifacts, or maybe some local differences between the two versions of the game server) :thinking:

1 Like

Yeah its something like that. If I tried in the old server, it was giving me messages like “931580 is already up to date!” even tho it was stuck. Fresh install only using your fix on first launch of dedi is apparently key…. That and dont change the branch accidentally after creating it (like I stupidly did)

Suggestion: If it were possible to point the “players joined” and chat box to the discord hook with a checkbox, it would be very, very cool. With a certain mod we could do this before, but it would be awesome if it were directed to discord by the launcher like the update events and such.

1 Like

Wondering if anyone can assist with an issue I’ve started to have in recent days.

I’m using Dedicated Server Launcher 1.5.8 on a Window 10 machine to host two servers, and for some reason I’ve got a version mismatch between the server, and the steam client.

It seems to be a server issue with my box, because I can connect to any other public server on the internet no worries, but for some reason my server version is way ahead of what’s currently public.

  • Dedicated Server is showing 372351/32628
  • Game client is showing 354133/32628

When running, the servers seem perfectly healthy, boot fine, and when I try to validate files on startup, they’re all good, and return a good validation with no need for an update.

They’re both showing 9999 ping in the server list and can’t be connected to.

Can anyone assist in troubleshooting this?

No idea what’s causing it, and there doesn’t seem to be a difinitive answer on how to fix it everywhere I’ve looked.

Any help would be much appreciated :slight_smile:

I dont know whats causing it but I know what I’d try. I’d make a new folder with the 1.6.0 dedi launcher, run it to generate the server data and folders, then move over the old database and server settings.

I’m at a loss here - Tried a fresh install of Dedicated Server 1.6.0 and it also installed with 372351/32628.

I have no idea what’s causing this :S

Actually, I just looked at my existing server (non-testlive) and that’s the correct version. Did you try direct connecting to them?

Yeah, I can’t direct connect to them either for some reason. Ports are open for them, and they’re exposed to the internet, so I guess I’ll have to do more troubleshooting :slight_smile:

Did you enable battleeye like officials? I think they have it on.

I tried on the standard live version, and I do have 372351/32628 for both the server and client.

So you server is correct, not sure why your client is wrong, is it on the proper Live branch as well in Steam? (or are you using the Epic or Windows Store version of the Game Client maybe?)

If you are using the Steam client, try to validate the install, see if maybe you have a half installed version with mixed files.

Fyi I had to redo my server again today (I think the pc had a windows update… :confused: ). Something is unstable about holding the steamid. I guess I’ll just hope it doesnt happen again since it wouldnt make a lot of sense to totally track this down during limited testlive. Just more or less posting this here so people know to look out for it.

1 Like

Could you check the Dedicated Server Launcher log see if you can see a message related to this line of code?

"Using command line option: -steamid %d", m_SteamIDServer

Another place you can check is in the SteamCMD parameters during the update:

appUpdateInformation += " +app_update " + std::to_string(m_SteamIDServer);

Basically check the logs for any instance of 443030 or 931580, that would at least eliminate an unknown parameter: Is the DSL somewhat forgetting the override or is it something else.

EDIT: I may have found a reason.

If you use the “Launch program on login option”

image

the information is stored in the registry in
Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
but this string is not modified if you pass different command line parameters.

So if you started once the launcher without any parameter and enabled the launch on login, the registry will look like that:

If then you quit, and start it again with -steamid 931580 it will properly enable the new steam id, but the registry is not going to be updated, so on the net login it will start the launcher with the default id.

What you should do is to either edit the registry key, or disable then enable again the launch on login so the registry key looks like that:

That should make the override sticky over restarts.

That’s the only thing I can think of right now.

1 Like

I’ll take a look after work. Thanks for the details.

1 Like

So I just checked the log and dedi, I didnt have launch on login for this server checked (which for simplicity I’m glad I didn’t) and curiously, the only version it mentions is 931580… very curious. Reading the log you wouldn’t know anything is wrong, but it did load with the old version. Very curious indeed.

At any rate, installing it again did get it working again by just moving over an earlier backup database from that day and copying over serversettings, so no big deal for me. Hey it’s testlive afterall right? :wink:

1 Like

What would be interesting is to do a folder diff between a version that worked and stopped working, and a brand new one reinstalled that still work, see what the differences are.

1 Like

I’ll give a whirl

1 Like

You can try the 30 days free trial of Beyond Compare*.

It has a folder compare mode, just select the two folders, right click → Compare.

Then you can double click on things in red to get an actual diff of specific files.


(*) This is not a commercial endorsement of the product, but I’ve been using it for the last 20 years or so, so I’m just used to that one, there are probably other equivalent products :slight_smile:

1 Like

Where in the Folder-Structure should the “html”-folder be placed?

Edit
I might have found the answer, but I’m not a 100% sure.
I have placed my “html”-folder in X:\Server\Conan Exiles Dedicated Server\DedicatedServerLauncher\ConanExilesDedicatedServer\ConanSandbox\html

Is this correct?
Thanks in advance!

Directly inside the folder created by the launcher, at the same level as where you have the “appcache”, “steamapps”, etc…

You can try that to see if that works:

  • Add the html folder
  • Inside create a “style.css” file

And then put that in the file:

body { font-family: Arial; background: #ffa201; }

Should display the pages in some hard-to-miss orange background color :slight_smile:

When changing the CSS, you may have to CTRL-F5 in the web browser to force reloading the changes.

1 Like