Conan Exiles Dedicated Server Launcher (Official Version: 1.6.2 / Beta: 1.6.4)

I believe Conan Exiles requires Direct X 11.
Which version of Windows are you using?

1 Like

Windows 10 Home, 64 bit

Not having any problems with the game, just this server launcher. I saw that there’s an entry in the FAQ about this kind of error, but the link there is broken and I assume it was just a link to a directx installer?

1 Like

Are you sure it’s the launcher showing the message?
Do you get the Direct X error when starting the launcher, or when the launcher tries to launch the game server?

1 Like

It happens when I try to start the server. Got the same error just now following a different guide for installing / configuring steamcmd manually, so it looks like it might actually be an issue with that?

1 Like

Could you try to install Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center ?

The Microsoft DirectX® End-User Runtime installs a number of runtime libraries from the legacy DirectX SDK for some games that use D3DX9, D3DX10, D3DX11, XAudio 2.7, XInput 1.3, XACT, and/or Managed DirectX 1.1. Note that this package does not modify the DirectX Runtime installed on your Windows OS in any way.

1 Like

Tried it, but no dice. Got the same error as before. Maybe I didn’t install them to the right location? Afraid I’m a bit out of my depth here, though I appreciate the help.

Oddly enough, my husband did get it to work on his computer yesterday. We’re not sure what happened but I guess he left it running in the background and suddenly it kicked on. Unfortunately the ping was at 9999 and we hadn’t forwarded the ports for his PC yet so we still have to sort all that out before we have a server we can actually connect to.

1 Like

I fear I can’t provide more help on that, not really my domain.

What I suggest is that you join the Admins United discord server, which has plenty of people who’s been running the Exiles servers on all kind of weird setups.

Good luck :slight_smile:

1 Like

Wasn’t aware a basic gaming PC qualified as a “weird setup”, but yeah, that sounds like it could be helpful.

1 Like

Was not referring to your machine, some of the admins out there I’ve tried on earlier versions of windows, linux servers, versions of windows server that refuse to even get direct x installed, etc… if they managed to get that working, I’m confident somebody will have an idea about why your machine is not happy.

1 Like

As a Webmaster dating back to '97, if only I could have convinced clients of that, I wouldn’t have burnt out a couple of years ago…

2 Likes

Hi this tool is awesome and I have got a server up and running for my friends, but I noticed that we still have a tethering distance. Is that just by default in the settings and we dont need to worry about it or is there a way to remove it completely? Thanks for the help

1 Like

have got a server up and running for my friends, but I noticed that we still have a tethering distance.

Weird, that’s not supposed to be the case, tethering is just there when a player joins another player sessions in co-op on his own game, not when joining a server.

Could you describe what you are doing, like the specs of the server machine and how people connect to it?

1 Like

Important: If your Dedicated Server Launcher does not seem to start after the big patch update of Exiles, check that your log folder does contain some humongously large ConanSandbox.log files.

I’m investigating the issue, but in the mean time I suggest you delete these files (or move them somewhere else out of the folder), if you don’t want the launcher to spend half an hour starting up.

Update: MisanthropicFace (on Discord) suggested a temporary fix to help with the problem:


If your log file becomes huge just go to your Engine.ini and add

[Core.Log]
LogStreaming=all off

to the end of it. Restart, problem solved. Thank me later ~


1 Like

New version for you people, quite a lot of changes inside, but at some point you have to release things so they can be tested.

1.5.0 (23 august 2021)

  • First version of the build in webserver page, allowing to see basic information about the game server, as well as Starting, Stopping and Restarting it.
  • Optimized the loading of the log files to speed up the launcher start up time when having to parse gigabytes large files
    Dedicated Server Launcher 1.5.0

For the web part, you can refer to what I posted last week it still works the same.

For the large log files, it’s not going to make the launcher start instantaneously, but in my tests with a large 1.5GB file the startup time has gone from 12 minutes to 30 seconds, but the real solution is to not have these huge files in first place. :scream_cat:

Feedback (good or bad) is welcome.

Thanks :slight_smile:

1 Like

Great, thanks a lot for your updates. :slight_smile:

Just a pity the issue on scaling resolutions still exists with moving window (it cuts the right part of program, it ends with “select” button so Performance column is gone means also the start/stop button is not visible in that case). It’s just a bit of annoying because minimize window has the same result with getting back to screen or try to resize window. Maybe just because of annoying and because of low part of users with scale setting it’s low prio for sure.

1 Like

I tried to fix it, trust me on that, I did manage to reproduce the issue, I did manage to fix it, but that broke something else. There’s must be something buggy in the win32 gui mini-framework I’m using, which predates the windows high-dpi support, and so far I’ve not found the cause of it.

2 Likes

There was apparently an issue with the “server ready” message being sent again and again in some conditions, so hopefully this one fixes the issue:

1.5.1 (24 august 2021)

  • Fixed a problem with the log file loading which in some cases would trigger a full reloading of the log, resulting in redisplaying the “server ready” message
  • Fixed the initial values of the karma points and backup trim duration
    Dedicated Server Launcher 1.5.1
1 Like

Web page is looking snazzy! I noticed that the Web Page Port light isn’t lighting up on 1.5.1 even when forwarded and tested. Not a huge deal, the port still works, but the icon remains grey.

2 Likes

Yeah, I basically copy-pasted the code used for the other ports… but obviously that can’t work, because the other ports are used by the game server, so they are free to use by the launcher when the server is not running.

The web port on the other hand, is used by the launcher itself, and the check is done only if “enabled” is checked… which means the port is already in use, so it fails.

I need to change the logic to use the actually running web server to see if it receives the external request.

Not critical, so adding that to the list of things I’ll do when I do a second pass of work on the web page.

Thanks for pointing it out :slight_smile:

1 Like

According to log my server crashes