Conan Exiles Dedicated Server Launcher (Official Version: 1.6.2 / Beta: 1.6.4)

If the versions don’t match, that will not work.

The gamepass release is a brand new thing, you and another person are the two firsts trying to use the gamepass version of the game with the DSL, and as far as I know that should work, but one thing to remember is that versions have to match.

The main issue there is that the DSL deployed version of the server comes from Steam, and your game client is installed from Microsoft servers (I guess), and I’ve no idea (I’ve just asked the people working on that, will come back to you when I have an answer) about how and when these versions are deployed.

1 Like

Ideally, I would need a full log of both your game client and server, sent as private message so you don’t advertise your IP and other information to the world (but please don’t remove anything because else it’s like trying to solve a mystery using redacted secret defense documents where everything has been covered in black marker :smiley: )

1 Like

@lagir10547 could you try to redeploy both your game and server?

The currently expected version is 299146.29534 which you can easily check on your server launcher top line.

1 Like

How do I send the .log files?
It won’t let me because I’m a new user here.

I tried copy and pasting the text here but it wouldn’t let me either, it said that there were words not allowed in my message.

1 Like

my server is in the correct version, but my game is in the 296540.29534 version. That must be the problem is there any way to fix it?

1 Like

I reported your issue, and the answer I got was:

There are two possibilities::

  1. Microsoft store often doesn’t recognize that there is an update available. They will need to try signing out of the MS Store, Xbox App, and signing in again. If that doesn’t work then restarting sometimes triggers it. This is out of our control and is a problem with the MS Store.
  2. There is an issue with the MS store patching system so they can’t actually deploy our update. If the user does manage to fix #1 they will need to reinstall the game to get the update until we get this sorted with MS.

Could you try #1 first (sign-out/sign-in) and see if that works?

Bonus question: Are you a regular user of Gamepass/MS Store installed games, does it always work smoothly or do you get issues now and then?

1 Like

Hello there,

Just like Pajonius, few posts ago, I’ve been trying to create a dedicated server to play with my brother for several days with no success, we always get the very same result; it apparently loads up normally only to be timed out when the bar gets full.

I too, tried many things to fix the issue with no luck and I have no idea what to do more, to get it working.
I tried hosting the server on 2 different machines, with or without mods, but no matter what, my brother and I always time out when the loading to server finishes.
Even though we are playing on LAN, I still port-forwarded my router just in case, and light are green in the Dedi Server Launcher -thank you very much for this very handy software, by the way-.

I would be very grateful if anyone is able to help me out on this, we really want to play without tethering.

1 Like

Sent a private message for you to send logs.

1 Like

Sent a private message for you to send logs.


how can i update this for my PC Server?

1 Like

It works! Thanks for your time!


I just wanted to say thanks to the team who made this Dedicated Server Launcher, you guys are awesome!

As someone who is fairly competent pc-wise, but has never ever attempted a dedicated server before, the only places I struggled a little bit was with port forwarding & firewall exceptions, but it once I got it up & running it ran/is running perfectly!

I do have 2 questions regarding CPU Core/Thread Affinity & Tick Rate.

I should point out that I am running the game from the same PC as my dedicated server & that we are only 2 players (maybe will be 3-4 at some point, but likely never more than this).


  • Ryzen 3600X
  • 32GB RAM (4x8GB)
  • Samsung (fast) SSD
  • AMD RX 6800XT
  • Internet Connection: Fibre - Ethernet (of course) - 350-400Mbit download, 35-40Mbit upload - ping 8ms

I’ve tried it with only selecting cores/threads 6-11, the game runs fine, but I’m wondering if there is a sweet-spot for this for my specs & low player count?

Also the 30 tick rate runs fine but it’s a tiny bit delayed in response time for things like mining & sometimes in combat some of the enemies do weird teleporting/rubberbanding (not often thought, which is good), so I thought increasing the tick rate to 64 seemed reasonable, especially considering we are only ever going to be a handful of players playing at any given time, what would you recommend? Leave it at 30? Try the 64? Or can I get away with even more? (I am launching the server using the directconnect option in-game, which I assume is the best way to connect to my server?)


I will tell the team :slight_smile: … he answered “Glad you like it!” :slight_smile:

Well, the main problem you need to consider is that Conan Exiles was built on Unreal Engine 4.15, before many of the networking and audio improvements made by Epic, so the game is mostly single threaded, with the odd thread here and there to do minor things.

In your context, what you probably want is to have just a few cores running as fast as they can, and trying to not stamped on each other feet.

So generally we try to leave the first core to Windows and system stuff, and if you are running the game on the same machine it will probably also use the lower cores, so I would suggest running the server starting from the end, like maybe give it an affinity to the last four cores.

I will personally not play with the tick rate, but if both you and the players are having a very good network bandwidth and latency, you could tweak the ini files to increate the amount of data allowed to send per second (but that needs to be done on both server and client side), but remember that your server is limited by how much it can send (which in your case is the 35-40 megabits).

For the direct connect, you don’t really have the choice since there’s a known bug when trying to play on the same local network if you try to use the public ip.

Imo, you should just do some benchmarking/measurement and try to find the bottlenecks and fix these first.

Like typically, if you are running a client AND a server at the same time, they will try to load data from the same disk, so make sure you are not limited there.

I would also check on another machine what is the amount of memory/cpu/io used by the client and the server - independently - before having them run together, so you can measure the impact of having the two running together.

Good luck :slight_smile:

1 Like

If the lights are red, things will not work, don’t even try: You saw the server on the list because it could talk to the outside, saying “Hey, I’m here!”, but the incoming packets are not going through.

If you have done the port-forwarding correctly (right ports on the right IP that match the proper network card, and for both TCP and UDP), then the most probably issue is your ISP: Have you managed to run any server at any time from inside your network (could be another game, a webserver, etc…?) some ISP don’t allow that because they are using some tricks to get more people on a few number of IPs so port forwarding does not work.

Which country/ISP are you using?

1 Like


Is there a way within the dedicated launcher to assign more threads specifically to a workload? When using task graph benchmarks, I see two threads, a single thread with work getting hit hard, and I would like to assign more threads to that specific workload if I am able too.

LogTaskGraph: Started task graph with 5 named threads and 12 total threads with 1 sets of task threads.

I have 15 threads, already and ideally would like to ensure that I could support the workload as not all threads are getting used effectively across the group. This is in particular when raid time starts or people are building in a specific way. Is there something we can do with the launcher or setting that could support that?

1 Like

Hi there.

I’ve been attempting to set up a server these past few weeks (I used to host one back when the game was early access; no issues) and have never been able to connect to one that I establish and get running. All of the lights are green on testing port accessibility, but no matter what I do, the game shows up on the server list with 9999 ping. After some cursory searching, I’ve tried workarounds such as attempting to direct connect (In my case, I’m connecting from a local machine on the same network, but not the same machine as the hosted server), but no dice. Direct connect comes with an error saying that the server can’t be found, and joining from the server list results in a VERY long loading screen that ultimately tells me the connection to the host was lost/failed.

I ended up renting a server in the interim so my buddies and I can play, but I’d really like to get this working so I don’t have to keep renting. Thanks for any and all assistance.

1 Like

The launcher has absolutely zero additional access to what the Conan Exiles server does, compared to other launchers, manual scripts, etc…

All it does is to run the server if it’s not running, detect it if it’s already running, then using the pid or handle use that to set the affinity or priority, but any third party program could do that.

Not sure what you are referring to by “task graph benchmarks” :slight_smile:

If you can come up with a programmatically way of doing what you want to do, please explain, and if that makes sense could be added to the launcher, but at the moment I’ve no idea on how I could fine grain the thread allocation of an external process.

1 Like

Direct connect on the public IP, or on the internal/local IP?

When the game was in early access, the networking part was using the SteamSDK, which does a lot of fancy black magic to handle firewalls, routers, etc… but a year or so back, there was a major change done to help have Exiles run on other stores (Microsoft Store, Epic Store, etc…) which meant the Steam stuff had to be replaced by some other code, and unfortunately one specific issue is that connecting to a server on the same local network, using the external IP, does not always work, in which case you have to use the local network IP of the server.

Ultimately, the only way to resolve these issues is to look at log files.

1 Like

Turkey / TürkNet

1 Like

Looks like that’s the problem:

“It’s 2021, I call TurkNet and say, “I want dynamic Real IP, not static IP”, their answer to me is sir, you need to get static IP to do IP forwarding.”

1 Like