Conan Exiles Dedicated Server Launcher (Official Version: 1.6.2 / Beta: -----)

You got the window doubled?

Just to be sure, have you excluded the entire Dedicated Server Launcher install folder in your anti-virus?

I checked your two logs, and the DSL did restart your server early because no player was detected, and indeed the last line of stats report is that one:

[2022.07.22-08.49.19:846][715]LogServerStats: Sending report: exiles-stats?players=0

If you look in the game server logs, you’ll see that there were up to two players connected, then they all dropped for some reason, and then there was some reconnection attempts that took some time and the server was restarted before the entire processing of the new connection was done, so the exiles-stats?players=1 was not yet sent.

Linking this over in case anyone needs it:

2 Likes

I’m kind of confused, I tried the test live versions before the summer break - to test the log file format change - and there was no problem deploying the server.

I’m currently checking with the team, looks like the Steam ID of the server changed, but I need confirmation.

Right now I’ve no idea how I can support 443030 for the current Live version and 931580 for Test Live, I don’t have anything like that in the code… I guess I could possibly add a new override parameter when defining branches, like “Name|Password|ID”?

I launched your dedi and setup a testlive, turned the server and dedi off, used that command pointed at the server exe in that folder, then when I reopened the dedi launcher, it had the right version. When it started it didnt get the old version either.

MAGIC

1 Like

If other encounter the same issue, could you try the following:

  • Instead of starting the Dedicated Server Launcher normally, open a command shell at the same location the launcher is located, and start it with the following command line:

DedicatedServerLauncher1600.exe -steamid 931580

Basically the DSL is compiled with hardcoded values 443030 and 440900 for the server and client ID values, but this command line can be used to override the value (there’s also “-steamidclient” for the client value).

What happened is that the 3.0 TestLive version has a different Steam ID, so when you try to fetch it with the DSL, it will get the old Test Live server, not the 3.0 one.

Until I find an elegant way to solve that, it’s possible to use this manual launch with the override parameter.

6 Likes

That is certainly more elegant on its own! Thanks!

Getting mixed results but one of the two methods has worked so far for the cases I’m aware of fyi.

After a mishap (I accidentally changed branch by typing in the wrong field) I cannot get the server back up and running using either method…

Okay I managed to fix it by installing the server in a new folder and doing the simple -steamid method

Here’s exactly what I had to do:

Make a new server folder. Put the dedilauncher in that folder and run “DedicatedServerLauncher1600.exe -steamid 931580” to create the folders with only the right id. Edited all the fields to be what I wanted (ports, server name, branch, etc). Now it had the right server version because I never ran it with 443030 (which confused my original).

Ok, good to know :-/

Probably means that going from one product id to another on the same install location is not working smoothly, possibly some SteamCMD artifacts, or maybe some local differences between the two versions of the game server) :thinking:

1 Like

Yeah its something like that. If I tried in the old server, it was giving me messages like “931580 is already up to date!” even tho it was stuck. Fresh install only using your fix on first launch of dedi is apparently key…. That and dont change the branch accidentally after creating it (like I stupidly did)

Suggestion: If it were possible to point the “players joined” and chat box to the discord hook with a checkbox, it would be very, very cool. With a certain mod we could do this before, but it would be awesome if it were directed to discord by the launcher like the update events and such.

1 Like

Wondering if anyone can assist with an issue I’ve started to have in recent days.

I’m using Dedicated Server Launcher 1.5.8 on a Window 10 machine to host two servers, and for some reason I’ve got a version mismatch between the server, and the steam client.

It seems to be a server issue with my box, because I can connect to any other public server on the internet no worries, but for some reason my server version is way ahead of what’s currently public.

  • Dedicated Server is showing 372351/32628
  • Game client is showing 354133/32628

When running, the servers seem perfectly healthy, boot fine, and when I try to validate files on startup, they’re all good, and return a good validation with no need for an update.

They’re both showing 9999 ping in the server list and can’t be connected to.

Can anyone assist in troubleshooting this?

No idea what’s causing it, and there doesn’t seem to be a difinitive answer on how to fix it everywhere I’ve looked.

Any help would be much appreciated :slight_smile:

I dont know whats causing it but I know what I’d try. I’d make a new folder with the 1.6.0 dedi launcher, run it to generate the server data and folders, then move over the old database and server settings.

I’m at a loss here - Tried a fresh install of Dedicated Server 1.6.0 and it also installed with 372351/32628.

I have no idea what’s causing this :S

Actually, I just looked at my existing server (non-testlive) and that’s the correct version. Did you try direct connecting to them?

Yeah, I can’t direct connect to them either for some reason. Ports are open for them, and they’re exposed to the internet, so I guess I’ll have to do more troubleshooting :slight_smile:

Did you enable battleeye like officials? I think they have it on.