Conan Exiles Dedicated Server Launcher (Official Version: 1.6.9 / Beta: 1.7.1)

Just another minor upgrade

1.3.8 (22 january 2021)

  • The status bar should not appear truncated anymore if the launcher is started on a very small screen width (like a tiny Remote Desktop Session)
  • Removed the “Close Steam” option
  • Renamed “Stream Query Port” to “Source Query Port”
    Dedicated Server Launcher 1.3.8

Not much on the outside, but I did a bit of cleaning in the code, keeping the “Technical Debt” in check.


You’re right, my problem is over. I don’t have change anything exept tick "validate server installation. After that, the update was installed.

1 Like

Has anyone been able to get this tool to work correctly on Server 2019 Core? The only thing holding me back is that the tool wants DirectX libraries that Hyper V simply doesn’t use and a lot of the documentation and files involved are almost a decade old. UE4 Prerequisites Setup Fatal Errors during installation.

Everything else is running and ready to go.

I’m running it (just fine) on Windows Server 2019 Datacenter, if that’s any help.

1 Like

Are you sure it’s the Tool (Dedicated Server Launcher) that require Direct X, or is it the actual “Dedicated Server” game?

Like, do you get an error when trying to run the tool, or is when trying to deploy/launch the game server?

Thank you for the response. I do not get any issues when I run the tool. I’ve been able to do the setup, port testing, install, everything works great.

When I try to launch the server it complained, as you said in your documentation, about the VC2015 C++ distro and DX. I was able to get the VC distro stuff on and it only complains about DirectX but for the life of me I cannot find anything that will install on that machine. It’s Microsoft Windows Hype-V Server 2019 Core. It’s a leased dedicated box from OVH and uses their OS template. I do not have access to the box physically, drives, or USB ports.

I’ve tried DirectX web installer, it fails right off the bat with a fatal error. Trying to run the UE4Prereq setup results in a fatal error with the message stating: Windows server roles and features cannot be automatically installed or uninstalled using the windows features control panel. “The following command cannot be executed: FONDUE.EXE /enable-feature:NetFx3 /caller-name:mscoreei.dll” See Attached. Server2019Error

No, server 2019 core does not have a GUI. Things run fine in powershell and I see the Tool running in a window as you normally would.

I’ve honestly no idea regarding this Core Server, I would personally suggest asking to the OVH people, they probably know about that, I doubt you would be the first person encountering this issue :slight_smile:

Thanks for taking the time to answer. I originally had more luck running on Linux CentOS 8. I know it has little to nothing to do with your tool and more to do with the UE4 engine and how limited CORE actually is.

Bonjour, je n’arrive pas activer le message qui préviens avant le restart du serveur, quelqu’un peut m’aider svp

Il existe un mod qui peut le faire. Nous utilisons
pour faire nos messages de redémarrage du serveur.

I have another suggestion, has to do with the whitelist, occassionlay I have this weridness where the whitelist… gets wiped, yet the whitelist doc still has all the information, then I have to go into conan and do the whitelistplayer id commands all over to reload the list, could you look into a way to show the whitelist or reload the whitelist for these kind of issues?

Idéalement l’Anglais est recommandé, ca augmente les chances que quelqu’un d’autre puisse aider.
Est-ce que les autres messages apparaissent, si vous mettez un message en bas a droite et appuyez sur “Send” est-ce que le message apparaît? Si non, est-ce que vous avez bien activé RCON avec un mot de passe?

Don’t you have the backup feature enabled?
The whitelist is supposed to be saved with the rest of the files, is it also wiped in all the backups?

le RCON est activé, mais a chaque fois que je met le mot de passe, une fois redémarrer, le champ de mot de passe Rcon est vide, et aucun message, et de plus j’ai essayé de faire sens un message, ça ne marche pas non plus :confused:

Typiquement ce genre de changement, il faut le faire quand le serveur ne tourne pas: Il arrive souvent que le serveur décide de réécrire les fichiers INI, et tout ce qui a été modifié dans le DSL entre temps est annulé.

Pourriez vous tenter ca.

  • Stopper le serveur
  • Mettre le mot de passe RCON
  • Cocher “Enable” RCON
  • “Save Changes”
  • Démarrer le serveur

yup backups happen with ever reboot… but ive not tryed restoring the backup to get the whitelist back… though i think i know what causes it… if i use mcron to whitelist someone… instead of going in game and doing it with the console command… it breaks things…

merci ça marche super

1 Like

Whitelisting IN GAME with the console commands does work fine, but doing the same thing with the rcon command, breaks the whitelist file?

Hello i have problem my server not sowing up on list and cant connect with ip ports are fine external and internal ip are statick . launcher says all ports if fine . it sows up on local not on internet