Conan Exiles Dedicated Server Launcher (Official Version: 1.7.2 / Beta: 1.7.5)

My conan exiles dedicated server shuts down immediately after starting it. and it shows the message in the ServerLog area of the launcher: “LogConsoleManager:Warning: Console object named ‘granite.AllowPerDLCGraniteCaches’ already exists but is being registered again, but we weren’t expected it to be! (FConsoleManager::AddConsoleObject)” . i am pretty lost on how to fix this any help would be appreciated thank you. My version of the app is 1.4.5.

1 Like

I can not open a dedicated server. The application does not start a server, it never runs anything. On the launcher the lightswitch immediatly turns off after downloading the server supposedly. In the same manner, straight up running the dedicated server also does the same thing without a launcher, it immediatly closes. Please help me Im dying here.

1 Like

OFC u can it so symple

1 Like

Is there a way i can get the server to shut down instead of just restarting? I want the server to shut down for 15 minutes and then start at a later time so that I can restart the hardware it’s running on once a week at least, but with this server only having an option to restart I have to do a whole windows schedule command workaround and it’s really annoying if it breaks, I worry about data corruption/loss cause the windows commands fail to execute on the server - i’ve had to recreate the commands in windows twice already due to something breaking after an update on the conan side of things, so building a STOP and START schedule into the server manager client itself woudl be more useful than having to use windows to close the server window process and hope that it doesn’t break.

1 Like

Ok people, I’ll be back at work tomorrow.

Could you summarize what is still valid in the list of issues?

  • @EmooseDagny @akashado Dedicated Server crashing/stopping on startup, does that still happen or was that after a patch and is now working just fine?
  • @Sikky @Chvrlx Are your servers still restarting all the time by themselves? Or was it a crash like what signaled just above?
  • @Killiaynna_Fayne Have you managed to get the server to run?
  • @Sikky To get notifications in game, you need the RCon to be properly configured
  • @Sev There’s no way to do that at the moment, but easiest way to safely stop the server is to send a CTRL-C command (or WM_CLOSE) to the main server window.
1 Like

I wrote some time ago that I would try to get some way to control the launcher from a web page, I started a prototype, and that’s what it looks like at the moment.

There’s no CSS of fancy graphics (other than a favicon), that may come later, but the priority is to get the core features working and debugged. If the feature does not work for you people, adding a fresh coat of paint will not help :slight_smile:

So, basically there’s a new port in the network configuration section, which will also have to be port forwarded if you want to be able to access the web page from the outside.

There’s also a small checkbox to enable or disable it (the effect is instantaneous, so if somebody starts to do naughty things you can just remote to the machine and disable the page while leaving the server running).

There’s also a place to enter a password which is used for authentication.

And here is the current page/workflow.

Right now all you can do is to start, stop and restart the server, and see some data about it.

There’s some latency, and not all the internal states are covered, so during a restart some of the buttons may still be displayed for a few seconds, but hey, it’s a prototype.

I still have a couple of things to clean up, then some testing to make sure nothing bad happens (like trying to bypass the authentication, etc…) then I’ll try to get the 1.5.0 version out for you to test and provide feedback.

You can react on what I posted right now of course.


Can’t get the server to start. Keep getting an error saying DirectX Runtime is required, but I’ve verified that DirectX12 is installed on my PC so I don’t know what’s going on. Anybody got any insights?

1 Like

I believe Conan Exiles requires Direct X 11.
Which version of Windows are you using?

1 Like

Windows 10 Home, 64 bit

Not having any problems with the game, just this server launcher. I saw that there’s an entry in the FAQ about this kind of error, but the link there is broken and I assume it was just a link to a directx installer?

1 Like

Are you sure it’s the launcher showing the message?
Do you get the Direct X error when starting the launcher, or when the launcher tries to launch the game server?

1 Like

It happens when I try to start the server. Got the same error just now following a different guide for installing / configuring steamcmd manually, so it looks like it might actually be an issue with that?

1 Like

Could you try to install ?

The Microsoft DirectX® End-User Runtime installs a number of runtime libraries from the legacy DirectX SDK for some games that use D3DX9, D3DX10, D3DX11, XAudio 2.7, XInput 1.3, XACT, and/or Managed DirectX 1.1. Note that this package does not modify the DirectX Runtime installed on your Windows OS in any way.

1 Like

Tried it, but no dice. Got the same error as before. Maybe I didn’t install them to the right location? Afraid I’m a bit out of my depth here, though I appreciate the help.

Oddly enough, my husband did get it to work on his computer yesterday. We’re not sure what happened but I guess he left it running in the background and suddenly it kicked on. Unfortunately the ping was at 9999 and we hadn’t forwarded the ports for his PC yet so we still have to sort all that out before we have a server we can actually connect to.

1 Like

I fear I can’t provide more help on that, not really my domain.

What I suggest is that you join the Admins United discord server, which has plenty of people who’s been running the Exiles servers on all kind of weird setups.

Good luck :slight_smile:

1 Like

Wasn’t aware a basic gaming PC qualified as a “weird setup”, but yeah, that sounds like it could be helpful.

1 Like

Was not referring to your machine, some of the admins out there I’ve tried on earlier versions of windows, linux servers, versions of windows server that refuse to even get direct x installed, etc… if they managed to get that working, I’m confident somebody will have an idea about why your machine is not happy.

1 Like

As a Webmaster dating back to '97, if only I could have convinced clients of that, I wouldn’t have burnt out a couple of years ago…


Hi this tool is awesome and I have got a server up and running for my friends, but I noticed that we still have a tethering distance. Is that just by default in the settings and we dont need to worry about it or is there a way to remove it completely? Thanks for the help

1 Like

have got a server up and running for my friends, but I noticed that we still have a tethering distance.

Weird, that’s not supposed to be the case, tethering is just there when a player joins another player sessions in co-op on his own game, not when joining a server.

Could you describe what you are doing, like the specs of the server machine and how people connect to it?

1 Like

Important: If your Dedicated Server Launcher does not seem to start after the big patch update of Exiles, check that your log folder does contain some humongously large ConanSandbox.log files.

I’m investigating the issue, but in the mean time I suggest you delete these files (or move them somewhere else out of the folder), if you don’t want the launcher to spend half an hour starting up.

Update: MisanthropicFace (on Discord) suggested a temporary fix to help with the problem:

If your log file becomes huge just go to your Engine.ini and add

LogStreaming=all off

to the end of it. Restart, problem solved. Thank me later ~

Update of the update: Xevyr (also on Discord) is saying this is wrong and instead should be using one of the many levels defined in the Unreal code, such as.


and so should do that instead:


I have no idea, so there you go, fight!

1 Like