Conan Exiles Dedicated Server Launcher (Official Version: 1.7.2 / Beta: ----)

I’m back in this forum and I have a question after my update of the launcher and I found the magic token in messages very nice.

Just one question, is it possible to remove the password in {steamconnect} ?

Thanks for your help.


I’m hosting a game server at home, no mods, recommended hardware specs, and everytime I join my own server, 10 to 30 seconds later I’m disconnected from it, with no specific reason whatsoever on the log (server or client log).

Everyone else seems to be able to join and play normally, I get disconnected every time.

I’ve tried:

  • Disabling Battleye (in client)
  • Disabling Battleye (in server)
  • Unistalling and Reinstalling battleye
  • Changing server ports (Game and Query)
  • Disabled server firewall and forwarded all ports (TCP and UDP)
  • Tried many connections at different day times
  • Unistalling game and reinstalling (Client)
  • Searched google and all the threads I could find, and done most of the solutions
  • Activated and Deactivated RCON

Nothing worked, I keep getting disconnected from the server.

The only reason I could thing of, might be the fact that I’m joining the server from the client using the same IP adress as the server, I dunno if that has some kind of validation that checks for that.

Can someone please help me out on this matter.

Many thanks in advance,

I would like to leave the log here, as it might have something I could be missing or could help someone understanding the issue:

Server Log

Hey there.
I tried to get the Programm Source… but i don’t got it -.-

Now i read we can’t edit the Source :’(

I want to change the Language of the Messages {reason} etc. in german.
There is no Settings-File where we can change it. Please let us change the Messages.

So, a new test revealed that when I stop forwarding my ports in the router, I can stay in the server for as long as I want, but when I reopen them, the issue starts all over again.

something tells me that thats something related to the IPs being the same (server and client).

I am a server administrator from China, my English is not good, please forgive me.

I would like to make a suggestion: it is possible to add PVE / PVP options to the management tools.

Because I found that the server could not be displayed in PvE mode through tools and server settings.

I mean, people can’t find it in the server list PVE pattern.

Although I finally solved this problem, I can add the following command to the server settings file:


The server is then displayed in the PVE list.

But I don’t think many people know this, because I asked many server administrators around me, and many other server administrators have asked me the same question.

Many people are troubled by this problem.

So here I put forward this suggestion, hoping to improve the tool.

The above text from the translation software, if the expression is not clear enough, please understand.

Thank you very much.

Has there been a fix to this issue? I’ve just recently started trying to host my own server and it shows up in the server browser but stays at 9999 ping with 0 players.

Hey thank you for the fast response. I was just wondering if that means we have to wait for an update or if anyone found a good work around for this issue.
Thank you in advance.

Thank you again for the quick response unfortunately. It seems like I’m not gonna be able to fix the issue since I tried that and still have the same problem.

Hello everybody, I’m back from holidays :grimacing:

I see that you’ve been busy (26 messages) including some support from some of you answering questions and issues of others, which makes me quite happy, thanks everybody :slight_smile:

I’ve not been in details in all the messages, I’ll address that later, but in the meantime I got a bug fix for you all that happen to get failures updating some recent mods with larger than usual workshop ids!

1.1.1 (10 august 2020)

  • Fixed a problem involving mod ids larger than 2147483648 (2^31) caused by the use of a “int” variable instead of “uint64”
    Dedicated Server Launcher 1.1.1

It was a very dumb bug, basically if you had a mod id larger than 2147483648 (like for example “KDR Unchained” with ID 2160533143), the code would fail parsing the id and would try to access some invalid negative value on the steam workshop site, which obviously does not work. :upside_down_face:

That was a 1 liner fix in the code, so should be safe to use if 1.1.0 did work fine for you.

@Kriptor @flakpredator @BJG @Tsumikara @Jtgarrett @bbtech What’s the status for your problems, did you manage to find solutions?

I’ve some plans for that, just did not have the time, because if I do that it has to be done properly

Are you talking of the Windows Event Viewer?

I believe it’s the default behavior of the tooltip system I’m using, but apparently it can be extended to support the concept of “Tracking” tooltips: “Tracking tooltips remain visible until they are explicitly closed by the application, and can change position on the screen dynamically. They are supported by version 4.70 and later of the common controls.”

Did you change the password while the server was running?

Well yes, everything is possible, but what would be a valid reason for that? Without the password the connection is not possible. Are you hopping maybe to give the password personally to players so they have to manually enter it when trying to join?

Same machine for the client and server, or two different machines but on the same local network?

Not totally trivial, I guess a way to do that would be to expose the messages in .ini files you could modify.

Nope, I think I covered that in the FAQ in the first post, the idea is to limit the features to what is purely administration of the actual server program, independently of the evolutions of the game, and which game it work on (the same launcher will be able to run other Funcom games).

The right way to do it is to setup your server with a password, run it, connect to it, and then use the administrator panel in the game to set the game rules you want.

The definition of PVE and PVP already changed at least three times already since the launch of Exiles, so that would be a moving target for me.

You can make this administration task much easier by adding the Pippi mod :slight_smile:

9999 Ping, connection… issues

I know the team has been working hard on fixing all the ping, latency, disconnect, etc… issues, and they still have work to do, these issues should be discussed on other support thread because there’s nothing I can do on my side, and it’s not related to the launcher tool, sorry!


No the server was shut down when I attempted the change (verified again before posting this). Does it need to be running?

No the server was shut down when I attempted the change (verified again before posting this). Does it need to be running?

Nope, just wanted to double check that, because it happens that the server overwrites changes to ini files from time to time.

On your screenshot it looks like you have both ServerPassword and AdminPassword in the same ini file? That’s not the case, normally the ServerPassword is in Engine.ini and AdminPassword is in ServerSettings.ini - I just checked and they both changed fine for me.

1 Like

Ah, you are correct and this is a case of ignorance/inexperience. I didn’t realize Engine.ini held the server password, but it’s there and updates accordingly. Thanks.

1 Like

Hi, thanks for the reply.

Same machine for the client and server, or two different machines but on the same local network?

different machines, same network.

basically a dedicated server on a 24/7 machine, inside my home network, where I connect to the same router, server by cable, client by wifi.

is there any reason why this happens?


Have you tried to connect to the server using the local ip instead of external ip?

Regarding the reasons, well, the FLS version of Conan Exiles had a massive amount of changes done to the networking code, and some of the things that used to not work are now working better, and some of the stuff that used to work, is sometimes not working anymore as expected - but the team is trying to address each of these cases when they happen -

Hello Toolguy ,

i run a private dedicated windows conan exiles server. So far all runs good but the blacklist.txt and whitelist.txt not working.

In the server log i have the following entries:

020.08.03-04.00.40:083][ 0]ConanSandbox:Display: AServerBlacklist::LoadSettings(): Blacklist file D:/Conan/DedicatedServerLauncher/ConanExilesDedicatedServer/ConanSandbox/Saved//blacklist.txt does not exist
[2020.08.03-04.00.40:083][ 0]ConanSandbox:Display: AServerBlacklist::LoadSettings(): Whitelist file D:/Conan/DedicatedServerLauncher/ConanExilesDedicatedServer/ConanSandbox/Saved//whitelist.txt does not exist

The blacklist.txt file exist i think the problem is the double // but i can not change it. I use the Conan Exiles - Dedicated Server Launcher 1.0.49 on a german windows 10


Did some quick test, even with // it worked here.

Dumb question: By default Windows machines are setup to hide extensions, are you sure your file is not called “whitelist.txt.txt” instead of “whitelist.txt” ?

1 Like

Hi there,

Hopefully this is a simple issue but I’m failing to solve it myself despite a day of trying; I’m hoping the solution is simple and I’m just missing it.

All ports are forwarded in my router, and all ports are passing the dedicated launcher port test and yet I cannot find my server, nor can I direct connect to it. The server does not respond in anyway and the connection times out.

I know the server is running as I am able to connect to it internally from 2 machines and play normally, but it’s blissfully unaware of any external connection attempts.

I’m running both server and client from the same machine with the multihome function enabled.

Any help greatly appreciated.

Edit: Reading up I see bbtech seems to have had a very similar issue, and I too can see my server in the server list and joining there does the same long hang before timing out with a lost connection; I have already moved my ports from the default ports and forwarded them in the router - No joy. :frowning:

What would help is if you could do a fresh start of the server and provide three log files:

  • One from your internal connection from one of the machines that can play normally
  • One from one of a machine that tries to connect and then times out
  • One from the game server itself showing what happened during the whole time when people tried to connect (and succeeded or failed).

Well, at least my reply edit worked, even if your server doesn’t. I wanted the problem and solution to be contained inside one post in case someone else had the same issue.