Connectivity issues

So i’m experiencing “failure to connect to character server” issues, also when i do get to character selection screen and try to log into my char, game stucks on loading screen forever. Now i’ve tried shutting down antivirus and firewall it didn’t help. Checked if used ports are being blocked and eliminated that. Also i’ve set up vpn on my router and still nothing. Now i’m beginning to think that problem is not on my end. Anybody has any ideas?

Do you happen to be a steam user? Sometimes Steam has issues connecting to the server properly, one of the non-benefits of being a steam user.

That said right now my steam is logging in alright, but it can be localized.

Nope.Was before but i switched to standalone client. It’s all really weird. I remember playing the game few years back had absolutely no problems. Enjoyed it so much. Tried googling it, tried also everything i could find on the net and it still wont work.

So i’ve tried:

  1. shutting down firewall and antivirus,
    2)checked if game used ports are being blocked,
    3)changed DNS servers for google ones,
    4)set up VPN on my router ,
    5)checked if some parental control rules are blocking something,

And nothing.

No idea then sorry =/ haven’t heard of something like that before that I can recall.

I read in another post that someone said their patcher said it was trying to connect to age of Conan or something like that and wouldn’t connect. Do you know what yours says?

Where do i check that? I’ve managed currently to get to the loading screen of kingsmouth. Then it just freezes. On other loading screens it was trial and error. One attempt out of 5 usually succeeds.

I have no idea, but here’s the post. You may be able to find other posts about connectivity issues, this one just stood out to me.

Just to help others if they have similar problems, resetting the router to factory settings solved the problems for me. After that had no more connection issues. Now, since i have nvidia card, game sometimes crashes. Later i’ll try to switch to dx9 to see if that helps. Someone also mentioned switching to driver version 436.15, will have to try that too.

Switching to 9 definitely helped me after I was able to play on DX 11 for about a year with barely any crashes.

Also can confirm that switching to dx9 solved my crashing bug. Dont think it’s hardware issue, since my computer is capable on running it in dx11. Whatever the reason it’s fixed now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.