Death and Axes will be the death of me

I go into the spirit realm and follow the ghost around and around and around, I know where the clues are. But when I get back to the land of the living, I cannot interact with the phone or any other thing I am suppose to investigate…what am I missing?? Besides a couple brain cells.

I know where all of the items are and I have looked at those pages and still cannot interact with the items I need too. I am on tier 2. I followed the spector around but cannot pick up the cell phone after I come back to the world of the living.

I have went to run the mission and i am able to interact with the phone,
The phone should go to your “Mission items” inventory and is able to be interacted from within there.

1 Like

I checked my inventories and there is nothing there. I will have to call a GM in game maybe, but will have to wait till the weekend.


still no word from a GM I guess I will move on to other missions until I hear back.

Have you tried grouping with anyone to see if they can advance the mission?