Dedicated Server: Recipes missing after latest patch

servers

#1

Game mode: Online Dedicated Server (PVP-C (PVP without building damage))
Problem: Bug
Region: EU


Disclaimer: This is my first posting in a game forum/posting bugs, so please bear with me in case I’ve broken any “etiquette”.

After updating to the latest patch after June 29th, my character does not have all recipes available when connecting to the server or spawning after death. Have tried the workaround to drink a Yellow Lotus Potion and redistribute Attributes and Feats, but upon death or logging out/in, recipes are missing again.

About 80-90 % of the recipes (sometimes even all) are randomly missing, both basic ones as well as higher level ones. Also applies to workbenches etc., both with and without thralls (even thrall specific recipes are missing). Seems to only happen to my character (but a couple of friends have not logged on since the update, so I can’t tell for sure).

Check DB bat files reports no errors.

No server mods. Changes to default/OOTB server settings:
LogoutCharactersRemainInTheWorld=False
NetServerMaxTickRate=40 (up from 30)
MaxPlayers=20


Steps on how to reproduce issue:

  1. Log on server - a random selection of about 80-90 % of all recipes are missing
  2. Drinking Yellow Lotus Potion to reset Attributes and Feats works to “re-learn” recipes
  3. Upon death or disconnecting and reconnecting to server, recipes are missing again.
  4. Quitting the game to desktop and reconnecting does not help, but sometimes the recipes missing changes. EDIT: I tried once connecting 4 times, and then it was ok until death/disconnect.

#2

Additional note: Yesterday I tried disconnecting from the game after a while and reconnect, with recipe filter set to building items. Upon reconnecting, only building items was available (but not all of them), even after removing the recipe filter.

Could be a coincidence of course.


#3

Solved in latest patch today.


#4