Delving Bench does not delve armors after Hotfix 2.1.1

if this is intended, you should remove the ability to delve something taht is not going to yield anything,

or fix it and have it working again.

1 Like

been trying this most nights since the last patch and cant get anything from armor delving, testing on single player vanilla no mods, putting in 2k eldarium and various armors and not finding one recipe ! got fed up of waising the stuff on the official server so testing on single player now

Hey there,

This doesn’t look like working as intended, so we’ll relay it to the team so they can look into it.
For future bug reports, please help us relay information to our team more accurately by following the guidelines found in this post:

there is NOTHING to add into it , ignasis, its all there, simply put armor pieces into the delving bench, and see there is no recipes coming from it. how much more accurate do you want it? cant understand what you are trying to say here. it is crystal clear

I am having in issue with the Delving Bench and armors as well on my server. Some recipes do work, like the Pride of
Aesir (it delves itno giving the recipe for Pride of Aesir)

I have used all sorts of combos for Cimmerian Chieftain armor and Ice Giant and have gotten nothing.

I tried
100 Silent Legion Helmets = nothing
100 Silent Legion Boots = nothing
100 Pride of Aesir helmets = 4 pride of Aesir recipes
50 Champion helmets = nothing

Game mode: Online private
Type of issue: Bug
Server type : PvE
Region: US Gportal

Mods running:
Hosav’s custom UI
Dude’s Delightful Decorations
Unlock Plus with Pickup (will replace Pickup+)
Barbarian Barber
Akuba’s Salon
Immersive Armor
Northern Timber
Shadows of Skelos
DM Tools
Building Shortcut Bar
Savage Steel vol 1 (more placeables)
Savage Steel Vol 2
Less Build Restrictions
Fashionist 4.0

Also having this issue. We are currently stockpiling armor and eld. while we await a fix, but we have already been doing this for some time.

I think now, you can understand why there is so many annoying bugs still occuring in their games. How devs can fix their games if those in charge to relay info are simply too lazy or stuck behind inefficient report mecanics…

1 Like

makes you wonder if they even play their own games !


@R4t probably not as much as we do. If you have to work on something all day long, when you get home you will probably want to do something else.


Well they better figure this stuff out soon and probably take stock that their current Community Support process isn’t working at all.

Today marks approx 50% of their entire player base since Siptah have abandoned the game.

It would appear the audience isn’t sticking around for the hotfixes or negotiate reasons to stay.

Still not working after 2.1.2 patch.

Hey there,

As mentioned above, we’ve relayed the information to the team.
We’ll proceed to close the thread since it’s being derailed from its original purpose.
Thanks for the feedback.

1 Like