Dismantle won't refund resources


#1

Game mode: Online | PvP
Problem: BUG
Region: Europe


Since the “Mother of all Patches” (or Mother of all bugs…) one out of those many bugs is very annoying. You are not getting resources back when dismantling structures.
Is this an “update” or a bug?


Steps on how to reproduce issue:

  1. Approach a Structure
  2. Click “E”
  3. Select “Dismantle”
  4. -> no resources refunded

#2

Do you mean that you do not get an update on things added to inventory (usually at the bottom right corner of the screen? Yes this started happening after the M.O.A.P
Are you using mods? (read that some mods can interfere with the game)
What type of structure was it, Stone, Reinforced, Insulated, Black Ice, Khitan?

I dismantled my base yesterday and moved it and had enough t3 resources to rebuild at a new location.


#3

Yes, I do not get resources back. I am dismantling Black-Ice Reinforced Foundations. Usually I got 2 insulated wood and 2 steel reinforcements back. Now i dont get anything back. No i am not using any mods I am playing on an official server.

Regards


#4

On official it seems like the amount of resources refunded is not even half…


#5

Still the same problem - any comments?


#6

Probably went on vacation, so many game breaking bugs right now, not that the game didn’t have bugs before lol, but no comments from team.
I have the same problem on official pvp server.


#7

yep same problem on official pvp server i play on. Since the 500+ bug patch.
But hey nothing we can do and nothing Funcom will do since they are all on vacation until sometime in August. So we just have to sit and wait and put up with the bugs. Or just play something else.


#8

Thank you for the report, and sorry I didn’t see this thread earlier. I unfortunately may miss some threads going through our various communities. I’ll forward this to the devs and have them look!
If you say this happens on official servers, please be sure to include the server number. Juuuuust in case for whatever reason it happens on some and not all. Thank you!!


#9

I’ve seen that dismantling doesn’t show the resources you get back every time if you’re doing multiple things that give the same materials back.

IE: Iron Jug gives 7 iron and so does Iron Pot. When I dismantle the first I see the +7 Iron message but the second item being dismantled doesn’t show anything being returned, but I have the 14 iron in my inventory so I think it’s just a graphical bug.

But I haven’t tested dismantling black ice buildings yet so I can’t confirm for sure.


#10

Problem at official PVP #1062


#11

It´s only a visual bug. You still get resources back.


#12