Expired AMD driver message at startup. The return

Hello everyone,
I’m back on what I now think is a simple bug: The message to the display that is:

It seems that you are using an outdated graphics driver that could be instabbed with our game. You are strongly advised to update it with version 12.5 or later. You will be able to download the latest drivers for your graphics card from http://www.amd.com. Would you like to leave the game and download the latest drivers available?

I thank the customer support from AMD and Funcom for looking with me but we found nothing. I did an AMD report but BOF. So I decided to look, look and I have a hypothesis. I wonder if this is a false positive because, I use the Super Task Manager “Process Explorer” and I discovered something.

The message says you have a driver prior to 12.6 and strangely, the dxdiag that clicks before the launch of the game stops the top: C:\Windows\System32\DriverStore\FileRepository\rt640x64.inf_amd64_124774e567f968ba\rt640x64. Pnf

With some research, I’m stumbling on the forum TSW (the origin) and people in 2013 already complained about this while AMD, had released in 2012, a driver supporting the game. How can this little be done that if AMD supported the game, this message is displayed. So it would be present from 6 years then.



If there is a check driver software, it would not take the driver in the file Driverstore the 12.4 as current version. This coincides as precisely 12.4 < 12.5. Strange. This driver “12.4” reinstalls itself to every big update of Windows 10, depending on the date of creation of the file so it is well brought by the system.

Even though I have a very average graphics card (AMD R5m330), this is the only game for which even in low graphic or I have huge variations of FPS. I can go from 30 to 10 FPS at one time.

That would be cool to look if it works well on that side there.

If this older driver reinstalls after Windows Update wouldn’t that make it a Microsoft problem?

I don’t think so. DriverStore is a folder where there are old version of drivers, used in the case of compatibility mode (if I’m wrong). It’s kind of the Swiss Knife of the drivers. The strangest thing is that the DxDiag in the SWL folder in Progamme Files well detects the correct version of the Driver I use. Very very strange.

This message does not bother me because I do not everytime but having some graphics bug like white lines on the game when I run for example, I wonder if indirectly there might not be bad behavior at that level there. Compared to all the other games I own in my PC.

A litlle capture.
It dates from early January but the message is still relevant.

From what I can tell this is a bug that has popped up from time to time since the launch of the classic TSW. The problem is that the AMD driver version that was required at the time of launch was 12.6 or newer. BUT recently AMD changed their driver numbering system. The newest drivers, though more than five years newer than 12.6 are detected by the SW:L driver check as being lower than 12.6

So, this is a Funcom issue and the check needs to be updated.

For me unfortunately the problem is worse than a persistent warning box. Every time I start the game it defaults to the minimum graphics settings. If I open the video settings and turn things up it works, but neither DX9 or DX11 are selected. All DX11 and advanced settings are disabled. I can select DX11, but it requires a restart to take effect and when the game restarts it hits the check again and reverts to the minimum. So… after getting a brand new computer and lovely new monitor to enjoy the game on I am left with worse performance and graphics than on my old machine.

Please address this as soon as possible. I’m a Grand Master and have been playing since beta. I love the game… but this is very frustrating. I’m sure this is ancient code that no one has touched in 5 years or more… but you have to fix it. This must be effecting many users and most of them will not have the deep love and patience I have for the game. Please…

I successfully managed to force the driver error to appear(on nvidia) by adding lines

<Value name="MinimumDriverName_Seven_ATI_DX10" value="&quot;12.6&quot;"/>
<Value name="MinimumDriver_Seven_ATI_DX10" value="&quot;898&quot;"/>
<Value name="MinimumDriverName_Seven_NVidia" value="&quot;500.00&quot;"/>
<Value name="MinimumDriver_Seven_NVidia" value="&quot;555555&quot;"/>

(My actual driver version is 391.01)
to %localappdata%\Funcom\SWL\Prefs\Prefs_3.xml file and making it read only (patcher keeps resetting it).

Doing the same, but with low/matching values may remove the error.

I have no idea if this will work, probably not, but since no one has mentioned it;

/option MinimumDriverName_Seven_ATI_DX10 seems to be set to “12.6”, try changing it to match your current driver number with /option MinimumDriverName_Seven_ATI_DX10 "XX.X"(except use the right number). It’s string so quotes are necessary. There’s also MinimumDriver_Seven_ATI_DX10 which seems to be set to “898”, no idea what that number is.

There are bunch of other options under MinimumDriver* too, since setoption is currently broken ill just list their values here.

MinimumDriverName_Seven_ATI_DX10 value:12.6 default:12.6
MinimumDriver_Seven_ATI_DX10 value:898 default:898
MinimumDriverName_Vista_ATI_DX10 value:12.6 default:12.6
MinimumDriver_Vista_ATI_DX10 value:898 default:898
MinimumDriverName_XP_ATI value:12.6 default:12.6
MinimumDriver_XP_ATI value:898 default:898

I tried setting some of the (NVidia)values really high for myself, but didn’t manage to get the error message.

1 Like

A good track. Thank you :wink:

Humm, that looks very promising.
I found the Prefs_3.xml file and added those lines. I think the file is getting red because the other Prefs_3 file, the bxml one is getting updated to have the new values. But when I change the minimum driver number and restart I still get the same message. I would expect that even if it didn’t work I would see the 12.6 number change, but it’s still there and not the number I put into Prefs_3.

Did you have to do anything else? (Assume I’m an idiot :wink: So even something obvious that I should just know to do…)

Also, from your first response, I tried entering the command (/option MinimumDriverName_Seven_ATI_DX10) into the chat prompt in game, and I did get a response, something like “The variable is” but it just ended and there was no value.

Any other ideas?

If the file is not set to read-only it just removes the lines when you launch the patcher, i also went through the .bxml file and confirmed that the values were not there either.
For me it does update the error message too

Option and Setoption are currently bugged,and fail to print out the values, which is why i had to make a small mod to see what they were set to.

Thanks. I’ll mess with it a little more. I did set the file to read only and the values in there didn’t get overwritten when I started the game. I think there may be a problem in the logic that tests the version number. The format of the version changed from a simple decemal to a 4 part number, that is from 12.6 to something in the format ■■■.■■■.■■■.■■■ so it may just be unable to parse the new format :frowning:

Try 0? i would hope anything counts as bigger than zero
i was wrong, 391.01 < 0

It seems that the value you need to change is actually MinimumDriver_Seven_ATI_DX10

No error for me using

	<Value name="MinimumDriverName_Seven_NVidia" value="&quot;500.00&quot;"/>
	<Value name="MinimumDriver_Seven_NVidia" value="&quot;0&quot;"/>


	<Value name="MinimumDriverName_Seven_NVidia" value="&quot;500.00&quot;"/>
	<Value name="MinimumDriver_Seven_NVidia" value="&quot;999999&quot;"/>

errors out

1 Like

Do you think that I need to create a ticket again (first ticket close in december 2017) or we expect with this forum post ?

If you have your old ticket you could post the number, but someone should come around during the week.

1 Like

My ticket was #1038116. it works, wait for the coming week :slight_smile:

1 Like

I tried a ton of different possible driver version values but I always see the same 12.6 number in the error. I know I have the right file and that I am setting it to read only. I don’t know… the parameters say DX10 and the options are 9 or 11 maybe that has something to do with it… or maybe the actual driver version format whatever it is just trips the eror no matter what, but you would think that it would at least show the values I am entering in the config file if it was reading them properly. I really just wish they would fix the bug :frowning: