Fix this crap asap

Game mode: [Singleplayer/offline]
Problem: [Crash | Bug | Performance | Misc]
Region: [Norway]


[Free text]

Alright I’m tired or this. I bought the game on release. Played until update 1.05 then put the game on shelf. Now on update 1.09 the game is still lady as f***
I’ve been reason patch notes every time they are released. They all say the same 4-5 tings. How about instead of “improved stability” you should say “added Minor stability improvement” which is hardly noticable anyways. Instead of adding and changing stuff. Get a huge stability improvement installed asap. Game also breaks the internet. Even on offline gameplay. The game has got some serious memory leaking. If I close the game it’s all back to normal with whatever other game that I play. I like the game but the price it was sold for in the first place is absolutely ridiculous. The game seems to be 1/5th finished in terms of stability.

I understand that the developers are working on improvement. But sofar (my opinion) it seems like they write the patchnote exactly the same except for adding a +1 number to the update.

At least I now got the sword available that I unlocked via a code…

Also after last update. My previous save file (I had altered some of the settings) they were all put back to default. Which I’m not impressed with…

If I don’t play the game for a day or so. The game runs fine for about 15-30 minutes before it starts lagging again.

Ps. This page is not mobile friendly any more. Writing this topic was a pain in he f**** a**

Steps on how to reproduce issue:
1.
2.
3.
4.

1 Like