Funcom Launcher Stinks

Game mode: [N/A]
Type of issue: [Bug]
Server type: [N/A]
Region: [USA]

[Funcom Launcher has no game launcher Icon (Can’t Play Game)]

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Click on Desktop Icon to start the game
  2. Funcom Launcher Starts up
  3. Nothing you can do to start the game at this point

My settings are maxed and I’ve tried finding a back door to launch the game with no luck. This game has had balance issues for some time regarding the boss fights. I’m only able to enjoy the game if i use the ingame cheats (makemeadmin) I’ve posted this before on game feed back. Now your new launcher will not even let me play the game at all. To be honest i would just like to have all the money back i spent on this game. However i would be willing to settle for just getting the launcher fixed by the end of April 2021. If not would you please give me all my money back i spent on this game and its expansions?

1 Like

Look in your install folder, binaries folder to be exact. Use the exe in there. Im not at my computer to give you an exact location, but it’s not hard to find.

Or change your app resolution to 100%.

Either option will work, and yes, Funcom is working on it. Demanding a refund here won’t result in anything though. You’ll need to contact the outlet you purchased from.


Someone told me about the Binaries folder before. I looked again and finally found it. I got into the game through there ty. I know they are working on the issue, however that should be a priority to be fixed. The longer it takes to fix that issue the more people they will loose and will want there money back. Specially any new players. Also Steam will not let me have my money back. Steam is a thief 3rd party company, however if you want to play any good games your forced to use them.

This has been going of for over two weeks, but they refuse to fix it for some reason!?!

1 Like

But how can I run it with Proton instead of using regular WINE that way? I suppose if I can get it working with WINE that I can then use Lutris and tie it with Proton.

I’m not a Linux user. Somebody made a post here on how they got it working.


I got it to work, excellent.

Update: I got the game to run on my laptop but not my desktop where I can get more performance (especially since my laptop has trouble switching GPUs so it uses Intel UHD 630 and good luck playing this game with that, wasn’t playable but that’s a different problem that just happened out of nowhere).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.