Game Crashing, cant find Siptah, public beta crashing

Hello, I guess I’m not the only one love hating this game, My game keeps crashing, it says I’m using the wrong key. Yet I’ve been playing it for months. Also I bought the Siptah DLC and I can’t find it. And I tried playing on the public beta test server and it crashes within ten to twenty minutes of game time. Now, do I have a problem on my end or is this bad game development? I love this game and want to play it but can’t. I’ve tried clearing my download cash and other ways to restart yet no help from either funcom or 95 game shop where I bought the first key to the base game. Note I bought Siptah straight from funcom. Help please. thank you. Frustrated in the exiled lands!

The public beta servers have been closed for weeks.

Thanks for the info, didn’t know. It allowed me to start a game and build a base and then it started crashing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.