Game Password Changing does NOT work

When changing the game password (not site password), I go to Change Password > Game Only > then enter a new password and confirm the password, it does not take effect in the Age of Conan client.

Again this is for the game client password change, NOT the site password.

1 Like

Takes 10 - 15 mins to change in-game.

It’s been a few days since I have tried to change it. Is anyone else having this problem or am I changing it in the wrong place. I cannot post links here but it is register. ageofconan .com

1 Like

You could try account.ageofconan.com

A friend’s account is completely locked after changing the password a month ago. Petition sti hasn’t been answered

Halfdead, I did try that and it only updates my site password. My game password remains unchanged.

2 Likes

I changed mine at https://register.funcom.com/account/customer/ctrl/changepassword. I used the dropdown and I selected “Billing and all Game Passwords”. It took awhile to work. I was not able to log on after 10 minutes, but the next morning the new password worked.

Yeah crazy how simple things such as password changes and buying funcom points are such a hassle.

1 Like

Roddam, select Billing and All Game passwords ended up changing my site password. I closed the Age of Conan client and relaunched it but my new password did not take effect in the client. I’ll check again tomorrow to see if has changed then.

1 Like

yea makes you think about not purchasing any of their games! I’ve been trying to change my site password now for a few days! I can’t log in

Can confirm changing password only takes effect on the Account Webpage. Tested on a few alt accounts.

The old password however still does currently work in-game…so it must be a huge delay…

1 Like

I cannot change my Game Password either. It has been 4 days and it still won’t take effect. I have tried changing through, “Lost your password?” on register.ageofconan and the Dropdown Menu on Account Management > My Account > Game > Change My Password:

  • Billing and all Game Passwords
  • Game Password
  • Billing Password

Anyone find a solution to setting the game login password?

1 Like

This must have been broken recently. This worked before march 2020.

Doesn`t work for me either, if there any chance Funcom will take a look?

1 Like

still doesn`t work