Gear not equipping

Hi there

Running into trouble where my gear no longer equips.

When I hit a hot key I hear the equip sound but I instead go into hand to hand. It is definitely not invisible equipped. Nothing equips - weapons, shields, tools, etc. However things like food, constructions and so on work fine off the hot keys.

I have logged in and out plus turned my server off and on.

Anyone know if there is a way to correct this problem?



generally takes place after you die. i’ve managed to fix it once by trying some things recommended on other forum posts. but this seems like a huge problem as it entirely keeps you from being able to play.

Dance. Seriously. If it’s the bug I’m thinking it is, performing an emote will fix it. XD

1 Like

super useful, thanks!

Here are a couple more possible fixes, in case using an emote doesn’t work.

1 Like

Had this a few times, store ur stuff, remove bracelet, respawn, collect stuff n re-equip. Fixed it everytime for me

Thank you all

Fixed it - for me I had to unequip everything, empty my inventory, run out naked and die.

When I respawned could equip again. I did try some of the other suggestions here and on the older forums but this worked for me.

Sounds like a pervasive bug that would be difficult to recreate and fix if so many methods seem to work

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.