Healing arrow not firing after using aloe potion or when switching arrow types

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvP
Map: Exiled Lands
Server Name: 1599
Mods: =MODS=


Bug Description:

healing arrow not firing after aloe potion use or when switching arrow types on bar.


Bug Reproduction:

Fired healing arrow and cloud appeared used aloe potions and healing arrow stopped firing. Also seems to happen if switching arrow types on bar as well.

1 Like

That is correct. When you switch arrows on hotbar it seems game doesn’t register it right, so you actually shooting bow with no arrows, but animation is there, so is stamina cost. But when you check, there is still same amount of arrows, game doesn’t tells you that you are out of ammo or anything. I thought it is just me, but it seems lots of people have same problem.

Tried on solo play with and without mods, also on server (private) with mods and no mods, same thing happens.

Issue seems to be that if you have no healing arrows in your inventory and only on the hotbar, you won’t fire any healing arrows. You can test this easily using the following steps:

  1. Empty inventory of all arrows.
  2. Place a stack of healing arrows on the bar.
  3. Fire - Count does not go down, no healing cloud at impact point.
  4. Split Stack and ensure some are in inventory, some are in bar.
  5. Fire - Count in inventory goes down, healing cloud at impact point.
  6. Repeat, but this time add other arrows to inventory and hot bar. You can hot swap, and as long as you have healing arrows in the inventory, it works. The moment you run out, and only have healing arrows on the hotbar, it stops working.