Horses... its just me? or mounting is more diffficult after 3.0?

it looks harder to mount now./


It is and maybe we get a fix in one year.


if lucky!



They totally screwed it up with 3.0 and here we are two patches later, still horrible. Each patch finds some new way to punish players who do anything besides building, and yet if you just spend your time building you get admin wiped. GG!

1 Like

hey, you can still get a latrine (that does not work) and a bathtub which is obviously non functional for 1855 CC (at discount) lol lol .

1 Like

Is this relevant to the topic at all?

it is, due to the lack of fixing stuff… it is VERY relevant.

how is your question any relevant to the topic?

You’re confusing “constructive” and “relevant”.

Players buy. Money goes in. Money gets spent. Yet, quality does not improve.

Quality is relevant. Therefore, prices are relevant.

Does that help?


That’s some impressive mental gymnastics.

The cost of a bath and latrine is irrelevant to the questions posed. And your gymnastics there are operating on the assumption that they aren’t working towards a fix.

Would it have been nice if issue had been fixed weeks ago? Absolutely. But the the price of some particular BLB items doesn’t mean anything. Irrelevant.

1 Like

just to name a few…

lets talk about the climb issue (still not fixed)

lets talk about the server transfers (pve) , they god disable months ago saying that they are fixing it, and they will post news (never happened) (there are people that lost their main toons in limbo, and they still dont have their toons back after what? 7 or 8 or more months?)

its not the first time funcom has not fixed something, so my comment can be based on experience , i have bene here since launch day.
the extra income DOES have everything to do, they are now getting much much more revenue, and i will expect then to fix issues much faster, thatn they used to be, and so far i am not seeing then making any changes.

the latrine does not Work, people cant place it despite of,

  1. store item ,that is being sold to people, people paying their overpriced stuff should expect to at least have it working, (are they testing stuff? before releasing? it certainly does not looks like,
    2, they are sending out bugged stuff in the bazaar,
  2. multiple reports, they should have fixed this issue in 24 hours. since its something that brings revenue.

bottonline, they are NOT testing their stuff, despite of the added revenue. so it you think about bugs, it has EVERYTHING to do regarding how funcom operates and on how they add stuff to the game,

i am not going into the pvp problems with some stormglass and some BP1 items that has HP values they shoulnt have, (yet the problem still here, and there is no fixes…)


Nobody was making a claim about whether they are working towards a fix or not. People are complaining that the quality of Funcom’s releases isn’t improving.

Mounting has been seriously screwed up ever since the 3.0 release. On official servers, you pretty much can’t mount without spamming the interaction key and moving around your horse.

And that’s just one screwup in the latest streak of screwups.

Not that the “latest” streak of screwups is very distinguishable from the never-ending streak of screwups that has been their track record for years now. The only thing that’s different is that they now have the new monetization, which – given the much higher prices than the DLCs and the greater variety of offerings – should be bringing them a lot more revenue than before.

So yeah, people kinda expect the quality of what they release to improve.

Instead, it remains the same, if you look at it as generously as you can. If you don’t, well, you might be a tad miffed that they released a BLB offering that contains a bit that you can’t use due to a bug and then went on vacation.

And yeah, I know, people deserve vacations, not to mention that certain laws in certain countries mandate certain time off. I know all that. I’m not saying they shouldn’t take time off. I’m saying they shouldn’t release stuff they didn’t test properly right before taking time off. It’s not really a novel bit of wisdom in software development.

It also would have been nice if they had taken the time to do a very simple fix for the Legendary Armor Patch kits as soon as it was reported, rather than skipping a couple of patches before finally fixing it.

The fact that their increased revenue isn’t helping improve the quality of what they produce is grating on many of us. If you can’t understand that, that’s your own problem.


I don’t seem to be having any issues with my horse apart from the saddle that doesn’t want to stay dyed but apart from that no issues.
I click on my horse I get on.
press [C] I get off.
Why what seems to be the issue if you don’t mind me asking?

@Deamo read here.,… (it seems you are playing modded, b/c the coomment of the saddle dye)

Let’s see I have 2 accounts

Main: I have no mods on that should effect Animals or dyes but yes I do have mods on.
No issues with horses but saddles won’t stay dyed. Solved it by un then re equipping it.
I’m also playing on a single/ private server.

On my other account (testing account) on my second PC I’m on a private server single no mods still no issues apart from my horse saddle is still messed up. I don’t own Siptah on that account so I can’t check the rhino saddle.

you cant dye saddles, there is not even the option afaik.

Oh so that’s why I can’t dye my saddle on my test account that’s the issue I was having. Lol ok so that’s a mod issue thanks.

Damn now I need to find the mod interfering with my saddle.

Dyeing saddles can’t be done without mods, which means you’re playing on a private server or in single-player. For whatever reason, the problem manifests itself most prominently on official servers.

Most of my time on private servers was before the 3.0 update, but I did spend some post-3.0 time playing on @Pugilist’s private server and I never had any problems with mounting. I suspect the difference is that official server specs are utter crap, and the server is either not receiving or not processing the mount command correctly.

Still, having the mount command be so fragile is a problem they need to fix.

I havent noticed an issue but I use controller.

I think it’s a sign the horse wants a big health buff