How to disable auto lock? :(

Hey! Thanks for checking my thread and apologies for bothering.

New player here, and enjoying the game, but there’s quite a big fork stuck in my heart that halts any more enjoyment for me.

Everytime i engage something i want to kill and i either 1. Draw my weapon, it auto locks onto whatever is near. 2. Zoom out it auto locks onto whatever is near. This has happened unintentionally too cause of the forced mechanic. Having to unlock the target lock with Q after every fight is out of the question for me.

I don’t want anything to do with the auto lock system if possible. My girl has also encountered issues with it and she dislikes it too.

Would greatly appreciate any help. :slight_smile: Looked through settings numerous times to no avail.

EDIT: So, this actually seem to happen whenver i do ANYTHING that cause me to exit first person. Like draw a tool or weapon it auto targets something near, when i press P(Exit or enter first person) it auto locks onto something. Or when i zoom out it auto locks onto something.

What the hell is this ****?

1 Like

Try unchecking the ‘disable auto facing on attack’ box in settings. That might be it.

I dont’ have the problem so it’ll be some kind of setting. Do you have a controller plugged in maybe?

1 Like

That setting does nothing and me and my girl aren’t using controllers.

weird stuff

try checkin all your keybindings and setting, might be some weird binding going on since an update or smthn. :disappointed:

I don’t think it’s the Auto-Facing that’s doing this as I have that option turned on without ill effect. However, I also make certain that Controller-style movement is disabled and that Toggle Target Lock doesn’t have anything bound to it.


Caveat: If it’s already auto-locking and the toggle keybind is clear, then you may need to bind a key to it just to toggle it back off again.

1 Like

Thanks for trying to help all. I tried to turn controller style movement off and unbind lock, and also enable/disable auto facing and restarting game and it still happened.

I’ve about had it with this game soon.

Keep in mind this happens to both me and my girl and it annoys her like crazy too.

I just tried it myself. I go into first person draw weapon and no target lock and my enable auto facing is checked in settings. I do however have Q set as target lock and may have toggled it, I really can’t remember as I have had the game a long time :slight_smile: .

The only other thing I did also check was the server settings and you can turn auto lock on and off there, so if you play single player go admin and turn it off or if you play on a server just check their settings.

Yeah. It’s a server setting… Single player is out of the question i think, so.

I thank you all for trying to help me, you’re super nice.

We decided to try and refund. It’s caused more headache than what it’s worth already.

1 Like

Server settings are in single player - sp is really a server that only you are in. Just go to the settings and make yourself admin, then change the server settings. You have all the access in Sp as you would an admin on a multiplayer server.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.