Isle of Siptah Mod Mismatch, again

Been playing Conan Exiles for months with mods, no issues. So we decided to try out Siptah 2.4, now 7 out of 8 players gets the dreaded Mod Mismatch issue. We have tried all the remedies we can find but none work. Anyone at Funcom have any input as to why this would happen and a possible fix? I tried Siptah last year and had to quite due to so many issues then. Hopefully this is not a glimpse of what to expect for v1.0.

Mod mismatch is not a Funcom issue.

Mod mismatch means your players have the wrong mod list, or the server is running a mod that hasn’t been updated on the server yet (most likely the cause). And if you are using Gportal, the latter is even more likely.

1 Like

What Multigin said ^^

Furthermore, if you are playing now 2.4 with mods, this means you are using TestLive. You should not use mods with TestLive as they are built for the Live version and may have competibility issues with TestLive.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.